backspace or delete is deleting too much

VERIFIED FIXED in M16

Status

()

Core
Editor
P3
critical
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Brade, Assigned: Brade)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood-][nsbeta2+])

(Assignee)

Description

18 years ago
I see this on a Macintosh build from today; I do not see it in yesterday's build.

* Select a few characters in the urlbar.
* Press backspace/delete key.
* notice that the selection and the previous character are deleted.
I expect only the selection to be deleted.

Kin doesn't see this on today's linux or windows builds.
Suzanne sees this on Mac builds for AIM login editfields.

I don't see this problem with forward delete (only the selection is deleted).

Comment 1

18 years ago
I selected 3 letters of a word in the URL bar, and 4 were deleted when I hit 
backspace (The extra character deleted was the one preceding the selected text.)

Comment 2

18 years ago
since brade is debugging this one, assigning it to her for now
Assignee: beppe → brade
(Assignee)

Comment 3

18 years ago
This is cross platform.  On Mac, it's the backspace key; on linux and windows 
it's the delete key.

cc saari; apparently the keybindings aren't paying attention to the fact that the 
editor has handled the events.  I think this is your bug...
OS: Mac System 8.5 → All
Hardware: Macintosh → All
Summary: backspace is deleting too much → backspace or delete is deleting too much

Comment 4

18 years ago
This is everyone's bug, however, I'll own it and track it as it involves a lot 
of band aids in the code and then doing the right thing once I make some event 
changes...

Brade, if you're interested, try and make sure anyone that is handling the event 
is setting prevent default (unless it is a click, that gets messy) and that 
everyone handling an event is checking the prevent default flag before doing 
so. The new event stuff we need is a flag that doesn't have the standards 
compliance issues that prevent default does
(Assignee)

Comment 5

18 years ago
adding keywords for nsbeta2 and dogfood

it sucks to have too much deleted (especially if you don't realize or know what 
was deleted)
Keywords: dogfood, nsbeta2

Comment 6

18 years ago
Workaround is available...yeah it sucks, but will make [dogfood-][nsbeta+].
Whiteboard: [dogfood-][nsbeta+]

Comment 7

18 years ago
setting to m16, place for all + bugs
Target Milestone: --- → M16

Comment 8

18 years ago
nsbeta2+
Whiteboard: [dogfood-][nsbeta+] → [dogfood-][nsbeta2+]

Comment 9

18 years ago
*** Bug 42877 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

18 years ago
The fix for this bug has been checked in.  There will be one additional small 
checkin to fix a similar problem in coding (probably by cmanske if I don't check 
it in).  I am going to resolve this bug now so that QA can verify it sooner.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
shouldn't this have been logged as a Mac bug and not "All" ??

anyhow verified in 6/20 build.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 12

18 years ago
No, this is a cross-platform bug.  On Windows and Linux, the forward delete key 
was broken in the same way that the backspace/delete key was broken on Macintosh.  
(I hope that makes sense!)
You need to log in before you can comment on or make changes to this bug.