Bloat data should include allocations via nsIMemory::Alloc

RESOLVED DUPLICATE of bug 84831

Status

SeaMonkey
General
P3
normal
RESOLVED DUPLICATE of bug 84831
18 years ago
14 years ago

People

(Reporter: Simon Fraser, Assigned: Warren Harris)

Tracking

({helpwanted})

Trunk
Future
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
scc sez that nsMemory::Alloc allocations do not show up in bloat figures, which 
means that string data (and lots of other data) don't show in the numbers. We 
should really fix this.

Comment 1

18 years ago
In this case `the numbers' being the bloat and leak numbers on Tinderbox.
(Assignee)

Comment 2

18 years ago
I hadn't thought this all the way through when I spoke to you about it earlier. 
Doing this would require us to get a lot more clever about how we note object 
sizes. Right now we're just keeping the sizeof(*this) in a hashtable entry, and 
then counting instances. We'd have to accumulate size data instead. We'd also 
have to change the bloat/leak output, and adjust the bloatdiff tool to 
compensate.
(Assignee)

Updated

18 years ago
Keywords: helpwanted
Target Milestone: --- → Future

Updated

17 years ago
Hardware: All → Macintosh

Comment 3

15 years ago
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".
(Reporter)

Updated

15 years ago
OS: Mac System 8.5 → All
Hardware: Macintosh → All
Fixed by using trace-malloc-based leak stats.

*** This bug has been marked as a duplicate of 84831 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.