Closed Bug 425159 Opened 13 years ago Closed 13 years ago

"No chrome package registered for chrome://help/content/contextHelp.js", when starting Browser

Categories

(Firefox Build System :: General, defect, P2)

defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.9

People

(Reporter: sgautherie, Assigned: Gavin)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b5pre) Gecko/2008032402 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

No bug.

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b5pre) Gecko/2008032501 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

Start Browser, for example:
get the following Message
{{
No chrome package registered for chrome://help/content/contextHelp.js
}}
(This can show up more than once...)

Probably a regression from bug 423486 check-in.
Something wrong/missing related to the new |MOZ_HELP_VIEWER| define ?
Assignee: neil → nobody
Component: Help → Build Config
Product: Mozilla Application Suite → Core
QA Contact: danielwang → build-config
Looks like configure/autoconf.mk is missing an AC_SUBST for MOZ_HELP_VIEWER.
Flags: blocking1.9?
I'm not sure this is exactly what is wanted, but I just copied MOZ_SAFE_BROWSING. I haven't tested this.
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attachment #311824 - Flags: superreview?(benjamin)
Attachment #311824 - Flags: review?(neil)
Comment on attachment 311824 [details] [diff] [review]
add --enable-help-viewer

I can verify that my suite build enters toolkit/components/help with this patch.
Attachment #311824 - Flags: review?(neil) → review+
Flags: blocking1.9? → blocking1.9+
Comment on attachment 311824 [details] [diff] [review]
add --enable-help-viewer

Somebody please make sure a followup bug is filed, if there isn't already, on moving this code to someplace seamonkey-specific?
Attachment #311824 - Flags: superreview?(benjamin) → superreview+
Priority: -- → P2
Target Milestone: --- → mozilla1.9
(In reply to comment #5)
> Somebody please make sure a followup bug is filed, if there isn't already, on
> moving this code to someplace seamonkey-specific?

Bug 424130 comment 2 ;-)
I filed bug 425541 to remove the help viewer, once bug 424130 is fixed.

mozilla/config/autoconf.mk.in 	3.459
mozilla/configure.in 	1.1968 
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Keywords: checkin-needed
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → FIXED
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9pre) Gecko/2008032816 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

V.Fixed.
Status: RESOLVED → VERIFIED
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.