Can't open mail in today's build

VERIFIED FIXED in M17

Status

P1
blocker
VERIFIED FIXED
19 years ago
7 years ago

People

(Reporter: phil, Assigned: waterson)

Tracking

({smoketest})

Trunk
x86
Windows NT
smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+]Updated info... problem is reproducible.)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Using 2000-06-14-08 commercial M17 build on NT

1. Run app, starting in browser
2. Click on mail icon in Taskbar
3. CPU spikes, app doesn't launch
4. Tried launching -mail, same result
(Reporter)

Comment 1

19 years ago
Severity blocker, added smoketest and dogfood keywords
Severity: normal → blocker
Keywords: dogfood, smoketest

Comment 2

19 years ago
Can i get some confirmation on this? ``Worksforme''

Comment 3

19 years ago
Well, as soon as my Linux build finishes, I'll try it ...

Comment 4

19 years ago
I can open mine.  I'll have to investigate.

Comment 5

19 years ago
Happened to me, too, after I removed my localstore.rdf.  I filed 42516 (which
I'll mark as a dup of this one).  Putterman's checkins to
mailnews/base/resources/content fix the problem for me, and also the other
problem I was seeing with the headers in the thread pane.

Comment 6

19 years ago
*** Bug 42516 has been marked as a duplicate of this bug. ***

Comment 7

19 years ago
ok.  It sounds like we just need to respin with my changes then.

Comment 8

19 years ago
which we are doing.

Comment 9

19 years ago
Putting on [NEED INFO] radar.
Whiteboard: [NEED INFO]

Comment 10

19 years ago
The problem is reproducible the 2nd time you try to run seamonkey.  The first 
time you migrate or create a new profile, you can successfully open mail.  

I can reproduce this bug on Windows 98 installed on a PIII Dell Precision 210 
and on Windows NT 4.0 SP6 installed on a Compaq 6000 deskpro using the 
2000-061409-m17 build. 
  *I migrated my profile and it allowed me to openning mail.  I was able to 
successfully log into my IMAP mail the first time.  The next time I launch 
seamonkey and try to open mail, my systems freeze.  On NT and 98, my CPU is 
peaked at 100% and mail fails to open.
  *I created a new profile and was successful in openning mail, entering my mail 
info, and logging into mail the first time.  The next time I launch seamonkey 
and try to open mail, my systems freeze.  On NT and 98, my CPU is peaked at 
100% and mail fails to open. 

I have to end the task.

Updated

19 years ago
Whiteboard: [NEED INFO] → Updated info... problem is reproducible.

Comment 11

19 years ago
Adding myself to CC list
(Reporter)

Comment 12

19 years ago
Just downloaded the bits timestamped 1:31pm since I assume this is the respin.
The problem is still reproducible.

I don't typically migrate or create new profiles, so pmock's steps seem
believable, except that it isn't the "second" time you run mozilla if you're
trying to reuse the same profile.

Comment 13

19 years ago
this is with a clean install? I wonder what's different on your machine.
(Reporter)

Comment 14

19 years ago
I'm installing on top of previous builds by letting the installer delete the 
previous build.

Comment 15

19 years ago
Phil - release hasn't announced a respin build yet and I don't see anything 
later than 2000-06-14-09-m17 (even after a shift+reload of the page).

Peter - can you try again for me if there is a new build? I was never able to 
reproduce this problem (even the second time of launching seamonkey) so I can't 
comment to Phil's findings. 

Thanks
(Reporter)

Comment 16

19 years ago
Lisa, the respin is in the 061408 directory, but it has newer timestamps. This 
seems to be a common practice for respins.

Comment 17

19 years ago
phil is correct, this respin is getting put in the same directory, because it's
two xul file changes, and the automation uses the preexisting buildid to
determine directory.

In any case... phil could this be a corrupt rdf file or some other corrupted
data file?

Comment 18

19 years ago
I just pulled the bits from 1:33 and although I didn't see this problem, it also 
didn't have my changes.
(Reporter)

Comment 19

19 years ago
I just kicked off a build, just in case...

Comment 20

19 years ago
I know it doesn't have my changes because I downloaded the build and looked at 
threadpane.xul and it's not the one I checked in this morning.

Comment 21

19 years ago
i believe you, i'm respinning after making clean in that directory, and *then*
making again (didn't catch the dependency automatically).

new build on the way.

Comment 22

19 years ago
fyi, I just downloaded the bits from 1:33 and I am still experiencing the problem 
I described earlier. I can bring up mail the first time then it freezes the 2nd 
time around.  I have to kill the task at this point.
/Peter

Comment 23

19 years ago
I just re-pulled and built with putterman's changes on Linux and everything
works just peachy.  I think this is just a Windows nmake disaster with the
previous bits.  Let's not hold the tree closed for this.

Comment 24

19 years ago
I am willing to clear the hook if mailnews qa, or mozilla.org net qa is happy.

Comment 25

19 years ago
We can reopen the commercial tree if:

(1) Development confirmed that putterman's changes corrects this problem.  Since 
Akkana had the problem with starting and then confirmed that putterman's changes 
fixes it, then I think this step is done.  Akkana - to confirm, your problem was 
that you couldn't start, right?

(2) Respins with these changes are on their way to QA.  We've had two respins so 
far and they still show the problem.  leaf will work with putterman to figure 
out why the changes are making it in.

(3) There are two other bugs which I would consider smoketest blockers - 
http://bugzilla.mozilla.org/show_bug.cgi?id=42485 and 
http://bugzilla.mozilla.org/show_bug.cgi?id=42488
Putterman says the fixes to xul files also fixes those two bugs (thus the 
downgraded severity on those bugs).  I'd like to have one other person 
verify them besides putterman.  I couldn't tell from Don's comments if all 
he did was start the product or if he tried the above two bugs.  Akkana - if you 
can verify the changes on your development build (since we don't have respins), 
that would be great.


Comment 26

19 years ago
I mean "why the steps AREN'T making it in" in item (2) above.
(Reporter)

Comment 27

19 years ago
I just tried the 15:14 bits, and the problem is still reproducible.

Comment 28

19 years ago
We just got my changes to make it over onto the build so it should work with the 
next respin.  

Comment 29

19 years ago
Ok, one more time. This time, the problem was the commercial build system not
picking up new mozilla files in dist.

mozilla bits work, am respinning commercial bits with the corrected files (no,
really!).

Comment 30

19 years ago
I just downloaded the latest respin win32 build 2000-061415-m17.  This problem 
looks resolved.  I can successful open mail and quit mail multiple times.
:) Nice work. 

/Peter

Comment 31

19 years ago
I'm happy to hear that. I'm going to mark as fixed then.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 32

19 years ago
The problem was resolved for me as soon as I pulled putterman's fixes; this
fixed my debug tree, and copying those files into my commercial tree fixed that
tree as well.
(Reporter)

Comment 33

19 years ago
Works for me now too

Comment 34

19 years ago
For the record, win32 build 2000-061415-m17 shows a Mozilla splash screen and a 
Mozilla throbber, but has IM in it.  Inquiring with leaf to make sure it's a 
commercial build.
(Reporter)

Comment 35

19 years ago
This is back for me in 06-14-20. Reopening. *sigh*
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 36

19 years ago
2000061420?  What about 2000061509, which is today's verification build?

Comment 37

19 years ago
I bet 42686 is a dup of this or vice versa.....

Phil what about todays bits?

Comment 38

19 years ago
Mail is working for me on Linux today.

Comment 39

19 years ago
This is scottip:  It looks like it's getting stuck in some tree code.  
We're able to reproduce it on jefft's machine.  I'm going to reassign to hyatt 
and cc'evaughan (it also looks like some box code if I stop again later).


nsEventListenerManager::RemoveEventListener(nsIDOMEventListener * 0x0ecccd00, 
const nsID & {...}, int 4, int 4) line 302 + 5 bytes
nsEventListenerManager::RemoveEventListenerByType(nsIDOMEventListener * 
0x0ecccd00, const nsString & {...}, int 4) line 515
nsXULElement::RemoveEventListener(nsXULElement * const 0x044a3b20, const 
nsString & {...}, nsIDOMEventListener * 0x0ecccd00, int 1) line 1936
nsTreeRowGroupFrame::~nsTreeRowGroupFrame() line 138 + 65 bytes
nsTreeRowGroupFrame::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsFrame::Destroy(nsFrame * const 0x0405ab50, nsIPresContext * 0x039d8030) line 
425 + 34 bytes
nsContainerFrame::Destroy(nsContainerFrame * const 0x0405ab50, nsIPresContext * 
0x039d8030) line 99
nsTreeRowGroupFrame::Destroy(nsTreeRowGroupFrame * const 0x0405ab50, 
nsIPresContext * 0x039d8030) line 152
nsFrameList::DestroyFrame(nsIPresContext * 0x039d8030, nsIFrame * 0x0405ab50) 
line 122
nsTreeRowGroupFrame::ContinueReflow(nsIFrame * 0x040503b4, nsIPresContext * 
0x039d8030, int 3825, int -113) line 1461
nsTableRowGroupFrame::ReflowMappedChildren(nsTableRowGroupFrame * const 
0x03f9f850, nsIPresContext * 0x039d8030, nsHTMLReflowMetrics & {...}, 
RowGroupReflowState & {...}, unsigned int & 0, nsTableRowFrame * 0x00000000, 
nsReflowReason eReflowReason_Resize, int 1, int 0) line 468 + 36 bytes
nsTableRowGroupFrame::Reflow(nsTableRowGroupFrame * const 0x03f9f850, 
nsIPresContext * 0x039d8030, nsHTMLReflowMetrics & {...}, const 
nsHTMLReflowState & {...}, unsigned int & 0) line 1088 + 38 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x03f9f850, nsIPresContext * 
0x039d8030, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 0, unsigned int & 0) line 693 + 31 bytes
nsTableFrame::ReflowMappedChildren(nsTableFrame * const 0x03f8c9a0, 
nsIPresContext * 0x039d8030, nsHTMLReflowMetrics & {...}, InnerTableReflowState 
& {...}, unsigned int & 0) line 2992 + 47 bytes
nsTableFrame::ResizeReflowPass2(nsTableFrame * const 0x03f8c9a0, nsIPresContext 
* 0x039d8030, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 1970 + 31 bytes
nsTableFrame::Reflow(nsTableFrame * const 0x03f8c9a0, nsIPresContext * 
0x039d8030, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 1613 + 34 bytes
nsTreeFrame::Reflow(nsTreeFrame * const 0x03f8c9a0, nsIPresContext * 0x039d8030, 
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0) 
line 417 + 25 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x03f8c9a0, nsIPresContext * 
0x039d8030, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 3, unsigned int & 0) line 693 + 31 bytes
nsTableOuterFrame::OuterReflowChild(nsTableOuterFrame * const 0x03f8c940, 
nsIPresContext * 0x039d8030, nsIFrame * 0x03f8c9a0, const nsHTMLReflowState & 
{...}, nsHTMLReflowMetrics & {...}, int * 0x00000000, nsSize & {...}, nsMargin & 
{...}, nsMargin & {...}, nsReflowReason eReflowReason_Resize, unsigned int & 0) 
line 885 + 47 bytes
nsTableOuterFrame::Reflow(nsTableOuterFrame * const 0x03f8c940, nsIPresContext * 
0x039d8030, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 1419 + 59 bytes
nsTreeOuterFrame::Reflow(nsTreeOuterFrame * const 0x03f8c940, nsIPresContext * 
0x039d8030, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 135 + 25 bytes
nsBoxToBlockAdaptor::Reflow(nsBoxLayoutState & {...}, nsIPresContext * 
0x039d8030, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0, int 0, int 195, int 2430, int 3712, int 1) line 796
nsBoxToBlockAdaptor::Layout(nsBoxToBlockAdaptor * const 0x03f8cef8, 
nsBoxLayoutState & {...}) line 467 + 52 bytes
nsSprocketLayout::Layout(nsSprocketLayout * const 0x01901660, nsIBox * 
0x03f8c7cc, nsBoxLayoutState & {...}) line 407
nsContainerBox::Layout(nsContainerBox * const 0x03f8c7cc, nsBoxLayoutState & 
{...}) line 552 + 34 bytes
nsBoxFrame::Layout(nsBoxFrame * const 0x03f8c7cc, nsBoxLayoutState & {...}) line 
797 + 13 bytes
nsSprocketLayout::ChildResized(nsIBox * 0x03f8c740, nsBoxLayoutState & {...}, 
nsIBox * 0x03f8c7cc, nsBoxSize * 0x03f9c668, nsComputedBoxSize * 0x03f9c6e0, 
nsBoxSize * 0x03f9c668, nsComputedBoxSize * 0x03f9c6e0, const nsRect & {...}, 
nsRect & {...}, nsRect & {...}, int 1, int & 0) line 966
nsSprocketLayout::Layout(nsSprocketLayout * const 0x01901660, nsIBox * 
0x03f8c740, nsBoxLayoutState & {...}) line 433
nsContainerBox::Layout(nsContainerBox * const 0x03f8c740, nsBoxLayoutState & 
{...}) line 552 + 34 bytes
nsBoxFrame::Layout(nsBoxFrame * const 0x03f8c740, nsBoxLayoutState & {...}) line 
797 + 13 bytes
nsSprocketLayout::Layout(nsSprocketLayout * const 0x01901660, nsIBox * 
0x03f510a8, nsBoxLayoutState & {...}) line 407
nsContainerBox::Layout(nsContainerBox * const 0x03f510a8, nsBoxLayoutState & 
{...}) line 552 + 34 bytes
nsBoxFrame::Layout(nsBoxFrame * const 0x03f510a8, nsBoxLayoutState & {...}) line 
797 + 13 bytes
nsStackLayout::Layout(nsStackLayout * const 0x01904380, nsIBox * 0x03f5101c, 
nsBoxLayoutState & {...}) line 245
nsContainerBox::Layout(nsContainerBox * const 0x03f5101c, nsBoxLayoutState & 
{...}) line 552 + 34 bytes
nsBoxFrame::Layout(nsBoxFrame * const 0x03f5101c, nsBoxLayoutState & {...}) line 
797 + 13 bytes
nsBoxFrame::Reflow(nsBoxFrame * const 0x03f50fe4, nsIPresContext * 0x039d8030, 
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0) 
line 651
nsRootBoxFrame::Reflow(nsRootBoxFrame * const 0x03f50fe4, nsIPresContext * 
0x039d8030, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 211
nsContainerFrame::ReflowChild(nsIFrame * 0x03f50fe4, nsIPresContext * 
0x039d8030, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 0, unsigned int & 0) line 693 + 31 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x03f50fa8, nsIPresContext * 
0x039d8030, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 546
nsHTMLReflowCommand::Dispatch(nsHTMLReflowCommand * const 0x0eca8a00, 
nsIPresContext * 0x039d8030, nsHTMLReflowMetrics & {...}, const nsSize & {...}, 
nsIRenderingContext & {...}) line 145
PresShell::ProcessReflowCommands(int 0) line 3928
PresShell::FlushPendingNotifications(PresShell * const 0x03375330) line 3069
PresShell::AppendReflowCommand(PresShell * const 0x03375330, nsIReflowCommand * 
0x0471afc0) line 2402
nsTableFrame::AppendFrames(nsTableFrame * const 0x03f8c9a0, nsIPresContext * 
0x039d8030, nsIPresShell & {...}, nsIAtom * 0x00000000, nsIFrame * 0x03f9f850) 
line 2303 + 16 bytes
FrameManager::AppendFrames(FrameManager * const 0x033841f0, nsIPresContext * 
0x039d8030, nsIPresShell & {...}, nsIFrame * 0x03f8c9a0, nsIAtom * 0x00000000, 
nsIFrame * 0x03f9f850) line 684
nsCSSFrameConstructor::AppendFrames(nsIPresContext * 0x039d8030, nsIPresShell * 
0x03375330, nsIFrameManager * 0x033841f0, nsIContent * 0x042065c0, nsIFrame * 
0x03f8c9a0, nsIFrame * 0x03f9f850) line 7845 + 30 bytes
nsCSSFrameConstructor::ContentAppended(nsCSSFrameConstructor * const 0x018e8950, 
nsIPresContext * 0x039d8030, nsIContent * 0x042065c0, int 3) line 8187
StyleSetImpl::ContentAppended(StyleSetImpl * const 0x018eedf0, nsIPresContext * 
0x039d8030, nsIContent * 0x042065c0, int 3) line 1081
PresShell::ContentAppended(PresShell * const 0x03375338, nsIDocument * 
0x039b5040, nsIContent * 0x042065c0, int 3) line 3155 + 46 bytes
nsXULDocument::ContentAppended(nsXULDocument * const 0x039b5040, nsIContent * 
0x042065c0, int 3) line 1730
nsXULTemplateBuilder::RebuildContainer(nsXULTemplateBuilder * const 0x043e8494, 
nsIContent * 0x042065c0) line 4291 + 48 bytes
nsXULDocument::RebuildWidgetItem(nsIContent * 0x042065c0) line 4602 + 22 bytes
nsXULDocument::AttributeChanged(nsXULDocument * const 0x039b5040, nsIContent * 
0x042065c0, int 0, nsIAtom * 0x03372cf0, int -1) line 1686
nsXULElement::SetAttribute(nsXULElement * const 0x042065c0, int 0, nsIAtom * 
0x03372cf0, const nsString & {...}, int 1) line 2924
nsXULElement::SetAttribute(nsXULElement * const 0x042065cc, const nsString & 
{...}, const nsString & {...}) line 1325 + 35 bytes
nsXULTreeElement::SetAttribute(nsXULTreeElement * const 0x0449f4d8, const 
nsString & {...}, const nsString & {...}) line 53 + 29 bytes
ElementSetAttribute(JSContext * 0x039dc760, JSObject * 0x03f4f7f0, unsigned int 
2, long * 0x03ec9064, long * 0x0012e44c) line 239 + 26 bytes
js_Invoke(JSContext * 0x039dc760, unsigned int 2, unsigned int 0) line 686 + 23 
bytes
js_Interpret(JSContext * 0x039dc760, long * 0x0012ed88) line 2490 + 15 bytes
js_Invoke(JSContext * 0x039dc760, unsigned int 1, unsigned int 2) line 702 + 13 
bytes
js_InternalInvoke(JSContext * 0x039dc760, JSObject * 0x017256d8, long 24772120, 
unsigned int 0, unsigned int 1, long * 0x0012ef20, long * 0x0012eec0) line 775 + 
19 bytes
JS_CallFunctionValue(JSContext * 0x039dc760, JSObject * 0x017256d8, long 
24772120, unsigned int 1, long * 0x0012ef20, long * 0x0012eec0) line 2801 + 31 
bytes
nsJSContext::CallEventHandler(nsJSContext * const 0x039de120, void * 0x017256d8, 
void * 0x0179fe18, unsigned int 1, void * 0x0012ef20, int * 0x0012ef1c, int 0) 
line 788 + 33 bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x04586234) line 154 + 64 bytes
nsEventListenerManager::HandleEventSubType(nsListenerStruct * 0x040fd110, 
nsIDOMEvent * 0x04586234, nsIDOMEventTarget * 0x039de190, unsigned int 1, 
unsigned int 7) line 754 + 19 bytes
nsEventListenerManager::HandleEvent(nsIPresContext * 0x039d8030, nsEvent * 
0x0012fa54, nsIDOMEvent * * 0x0012f3f8, nsIDOMEventTarget * 0x039de190, unsigned 
int 7, nsEventStatus * 0x0012fa94) line 1323 + 39 bytes
GlobalWindowImpl::HandleDOMEvent(GlobalWindowImpl * const 0x039de180, 
nsIPresContext * 0x039d8030, nsEvent * 0x0012fa54, nsIDOMEvent * * 0x0012f3f8, 
unsigned int 1, nsEventStatus * 0x0012fa94) line 413
nsWebShell::OnEndDocumentLoad(nsWebShell * const 0x038dd2e4, nsIDocumentLoader * 
0x038dc710, nsIChannel * 0x038fbc10, unsigned int 0) line 1153 + 56 bytes
nsDocLoaderImpl::FireOnEndDocumentLoad(nsDocLoaderImpl * 0x038dc710, nsIChannel 
* 0x038fbc10, unsigned int 0) line 712
nsDocLoaderImpl::DocLoaderIsEmpty(unsigned int 0) line 542
nsDocLoaderImpl::OnStopRequest(nsDocLoaderImpl * const 0x038dc714, nsIChannel * 
0x04539150, nsISupports * 0x00000000, unsigned int 0, const unsigned short * 
0x00000000) line 485
nsLoadGroup::RemoveChannel(nsLoadGroup * const 0x038de350, nsIChannel * 
0x04539150, nsISupports * 0x00000000, unsigned int 0, const unsigned short * 
0x00000000) line 544 + 39 bytes
nsFileChannel::OnStopRequest(nsFileChannel * const 0x04539158, nsIChannel * 
0x04539280, nsISupports * 0x00000000, unsigned int 0, const unsigned short * 
0x00000000) line 644
nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 0x045057f0) line 
307
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x04505710) line 97 + 12 bytes
PL_HandleEvent(PLEvent * 0x04505710) line 575 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x0197bd60) line 520 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x000204f4, unsigned int 49407, unsigned int 0, 
long 26721632) line 1032 + 9 bytes
USER32! 77e7124c()
Assignee: putterman → hyatt
Status: REOPENED → NEW

Comment 40

19 years ago
I didn't check in any tree code yesterday...

Comment 41

19 years ago
we think this problem existed the day before as well and that we mistakenly 
marked it closed.
(Reporter)

Comment 42

19 years ago
> Phil what about todays bits?

Today's installer seems to point at last night's bits. This from looking at the 
file dates, and the version number in the browser status bar.

Comment 43

19 years ago
Dan and I tested today's debug builds on all platforms.  It works on all of 
them.  I'm unable to reproduce this crasher.  Are we sure this isn't just some 
horkage in the build/install process?  We know this was broken yesterday...

(Reporter)

Comment 44

19 years ago
Now that the new installer (N6setup.exe) is posted, I tried with today's builds, 
and I still hang launching mail.

Comment 45

19 years ago
no idea.  seeing as how all these files were changed without informing build 
release, who knows what's going on or what's being delivered on win32 right now.

I wouldn't trust today's win32 build as far as I could throw it.

Comment 46

19 years ago
Which files are you talking about?  The old tree code wasn't changed yesterday.

Comment 47

19 years ago
the filenames of the installer files and several of the .xpi files.  basically 
the things the automation looks for to copy to the appropriate places and QA 
looks for to install and test.

Comment 48

19 years ago
Putting on [dogfood+] radar.
Whiteboard: Updated info... problem is reproducible. → [dogfood+]Updated info... problem is reproducible.

Comment 49

19 years ago
According to gemal in Bug #42605, he sees exactly this same problem. If he
deletes his localstore.rdf, he can open mail without hanging. The symptoms sound
identical to what Phil is seeing.

Phil, can you try deleting your localstore.rdf to test if your mail problem goes
away?

If so, we should make 42605 a dup of this bug.
here's why it may not launch the first time, but it will the second time.

the first time, on a new profile, do you have that crazy 6.0 start page?

(with the big floating "6", etc.)

having that page up causes all sorts of problems and it pings the CPU.

the second time in, you'd have your home page or something.

does that make sense?
(Reporter)

Comment 51

19 years ago
> Phil, can you try deleting your localstore.rdf

If I delete my localstore.rdf, I can start mail once. The next time I still 
hang, and need to delete it again.

Comment 52

19 years ago
I have been told that working on my focal is higher priority than working on 
dogfood or smoketest blockers. This bug should probably be re-assigned if you 
want it handled quickly, because I'm going to have to work on focal stuff today.

Comment 53

19 years ago
So the tree stays closed while we wait for Dave to do his focal review =).

Comment 54

19 years ago
sspitzer and I think we should just give Dave his raise and let him get back to
work.

Comment 55

19 years ago
Dave's self-review is lower priority than any smoketest blocker, but he doesn't 
see why this bug is assigned to him. Looking for someone else to assign this 
to.

Comment 56

19 years ago
Ok, apparently it goes like this:

dogfood ----> focal ---> smoketest blocker

So I guess the bug is higher priority.  Anyway, I can't reproduce this, so I'm 
not sure what you want me to do with it.  If it's an old tree widget bug, I'm 
not inclined to fix it, since the new tree is ready to land (but I'm told the 
new tree must land in a carpool, so I'm not allowed to turn it on this late in 
the day).

Comment 57

19 years ago
do we have any tree changes in mailnews that were made to help work with the new
tree that are checked in? The only thing I can thing of that mailnews uses
localstore.rdf is to store column widths for the tree widget.

Something is corrupting that information every other time you run. jefft now
sees this on his tip build too.

Comment 58

19 years ago
Hmmmm, maybe this isn't just a Windows-only problem.  I'm seeing something
similar to this on my linux mozilla build today.  But I can open the mail
window, select folders, etc., but ... after mousing around for about a minute,
my debug build just goes bye-bye.  No console message, no core.  Just gone. 
Truly weird.  Does anyone else see this on linux?

Comment 59

19 years ago
Try running under gdb.  Linux doesn't leave core files for multithreaded apps,
so you have to run under gdb in order to get a stack trace for a crash.

Comment 60

19 years ago
Crashes or freezes for me on Win98, Linux and Mac OS 8.6
Priority: P3 → P1

Comment 61

19 years ago
dave says waterson should look at this, reassigning, cc hyatt.
Assignee: hyatt → waterson

Comment 62

19 years ago
Alright. I see this bug now, after a slightly different chicken dance than the 
one mentioned above. With today's build, if you, say:
  1) launch in browser
  2) punch the taskbar mail/news button
  3) punch a twisty in the Mail Folders pane so that pane picks up a scrollbar
  4) close the mail window
  5) punch the taskbar mail/news button, reopening mail.

Step 3 is necessary. If after doing step 3 you punch the twisty again, so that 
the scrollbar goes away (we're making some assumptions about the relative size 
of that pane and the number of your folders, of course), then step 5 doesn't 
crash.

I don't get the same stack trace as above. I get this:

nsScrollbarButtonFrame::GetChildWithTag(nsIPresContext * 0x03372f28, nsIAtom * 
0x00e964e8, nsIFrame * 0x03ae5524, nsIFrame * & 0x03372f28) line 201 + 19 bytes
nsTreeRowGroupFrame::SetScrollbarFrame(nsIPresContext * 0x03372f28, nsIFrame * 
0x03ae5524) line 908 + 23 bytes
nsCSSFrameConstructor::CreateTreeWidgetContent(nsCSSFrameConstructor * const 
0x036fc288, nsIPresContext * 0x03372f28, nsIFrame * 0x039af9ac, nsIFrame * 
0x00000000, nsIContent * 0x03b0b028, nsIFrame * * 0x0012ca80, int 0, int 1, 
nsILayoutHistoryState * 0x00000000) line 12066
nsTreeRowGroupFrame::CreateScrollbar(nsIPresContext * 0x03372f28) line 1771
nsTreeRowGroupFrame::ReflowAfterRowLayout(nsTreeRowGroupFrame * const 
0x039af9ac, nsIPresContext * 0x03372f28, nsHTMLReflowMetrics & {...}, 
RowGroupReflowState & {...}, unsigned int & 0, nsReflowReason 
eReflowReason_Resize) line 1121
nsTableRowGroupFrame::ReflowMappedChildren(nsTableRowGroupFrame * const 
0x039af9ac, nsIPresContext * 0x03372f28, nsHTMLReflowMetrics & {...}, 
RowGroupReflowState & {...}, unsigned int & 0, nsTableRowFrame * 0x00000000, 
nsReflowReason eReflowReason_Resize, int 1, int 0) line 477
nsTableRowGroupFrame::Reflow(nsTableRowGroupFrame * const 0x039af9ac, 
nsIPresContext * 0x03372f28, nsHTMLReflowMetrics & {...}, const 
nsHTMLReflowState & {...}, unsigned int & 0) line 1088 + 38 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x039af9ac, nsIPresContext * 
0x03372f28, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 0, unsigned int & 0) line 693 + 31 bytes
nsTableFrame::ReflowMappedChildren(nsTableFrame * const 0x0391f3f8, 
nsIPresContext * 0x03372f28, nsHTMLReflowMetrics & {...}, InnerTableReflowState 
& {...}, unsigned int & 0) line 2992 + 47 bytes
nsTableFrame::ResizeReflowPass2(nsTableFrame * const 0x0391f3f8, nsIPresContext 
* 0x03372f28, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 1970 + 31 bytes
nsTableFrame::Reflow(nsTableFrame * const 0x0391f3f8, nsIPresContext * 
0x03372f28, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 1613 + 34 bytes
nsTreeFrame::Reflow(nsTreeFrame * const 0x0391f3f8, nsIPresContext * 0x03372f28, 
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0) 
line 417 + 25 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x0391f3f8, nsIPresContext * 
0x03372f28, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 3, unsigned int & 0) line 693 + 31 bytes
nsTableOuterFrame::OuterReflowChild(nsTableOuterFrame * const 0x0391f398, 
nsIPresContext * 0x03372f28, nsIFrame * 0x0391f3f8, const nsHTMLReflowState & 
{...}, nsHTMLReflowMetrics & {...}, int * 0x00000000, nsSize & {...}, nsMargin & 
{...}, nsMargin & {...}, nsReflowReason eReflowReason_Resize, unsigned int & 0) 
line 885 + 47 bytes
nsTableOuterFrame::Reflow(nsTableOuterFrame * const 0x0391f398, nsIPresContext * 
0x03372f28, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 1419 + 59 bytes
nsTreeOuterFrame::Reflow(nsTreeOuterFrame * const 0x0391f398, nsIPresContext * 
0x03372f28, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 135 + 25 bytes
nsBoxToBlockAdaptor::Reflow(nsBoxLayoutState & {...}, nsIPresContext * 
0x03372f28, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0, int 0, int 195, int 2430, int 1822, int 1) line 796
nsBoxToBlockAdaptor::Layout(nsBoxToBlockAdaptor * const 0x0391f950, 
nsBoxLayoutState & {...}) line 467 + 52 bytes
nsSprocketLayout::Layout(nsSprocketLayout * const 0x00e59d98, nsIBox * 
0x0391f224, nsBoxLayoutState & {...}) line 407
nsContainerBox::Layout(nsContainerBox * const 0x0391f224, nsBoxLayoutState & 
{...}) line 552 + 34 bytes
nsBoxFrame::Layout(nsBoxFrame * const 0x0391f224, nsBoxLayoutState & {...}) line 
797 + 13 bytes
nsSprocketLayout::Layout(nsSprocketLayout * const 0x00e59d98, nsIBox * 
0x0391f198, nsBoxLayoutState & {...}) line 407
nsContainerBox::Layout(nsContainerBox * const 0x0391f198, nsBoxLayoutState & 
{...}) line 552 + 34 bytes
nsBoxFrame::Layout(nsBoxFrame * const 0x0391f198, nsBoxLayoutState & {...}) line 
797 + 13 bytes
nsSprocketLayout::Layout(nsSprocketLayout * const 0x00e59d98, nsIBox * 
0x038c82f0, nsBoxLayoutState & {...}) line 407
nsContainerBox::Layout(nsContainerBox * const 0x038c82f0, nsBoxLayoutState & 
{...}) line 552 + 34 bytes
nsBoxFrame::Layout(nsBoxFrame * const 0x038c82f0, nsBoxLayoutState & {...}) line 
797 + 13 bytes
nsStackLayout::Layout(nsStackLayout * const 0x00e5a178, nsIBox * 0x038c8264, 
nsBoxLayoutState & {...}) line 245
nsContainerBox::Layout(nsContainerBox * const 0x038c8264, nsBoxLayoutState & 
{...}) line 552 + 34 bytes
nsBoxFrame::Layout(nsBoxFrame * const 0x038c8264, nsBoxLayoutState & {...}) line 
797 + 13 bytes
nsBoxFrame::Reflow(nsBoxFrame * const 0x038c822c, nsIPresContext * 0x03372f28, 
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0) 
line 651
nsRootBoxFrame::Reflow(nsRootBoxFrame * const 0x038c822c, nsIPresContext * 
0x03372f28, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 211
nsContainerFrame::ReflowChild(nsIFrame * 0x038c822c, nsIPresContext * 
0x03372f28, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 0, unsigned int & 0) line 693 + 31 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x038c81f0, nsIPresContext * 
0x03372f28, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 546
PresShell::ResizeReflow(PresShell * const 0x03779d00, int 11130, int 7095) line 
1796
PresShell::ResizeReflow(PresShell * const 0x03779d04, nsIView * 0x03595028, int 
11130, int 7095) line 3788
nsViewManager2::SetWindowDimensions(nsViewManager2 * const 0x03373050, int 
11130, int 7095) line 434
nsViewManager2::DispatchEvent(nsViewManager2 * const 0x03373050, nsGUIEvent * 
0x0012e47c, nsEventStatus * 0x0012e3e8) line 1229
HandleEvent(nsGUIEvent * 0x0012e47c) line 69
nsWindow::DispatchEvent(nsWindow * const 0x036b259c, nsGUIEvent * 0x0012e47c, 
nsEventStatus & nsEventStatus_eIgnore) line 560 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012e47c) line 581
nsWindow::OnResize(nsRect & {...}) line 3548 + 15 bytes
nsWindow::ProcessMessage(unsigned int 71, unsigned int 0, long 1239116, long * 
0x0012e7b8) line 2959 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x0036013c, unsigned int 71, unsigned int 0, long 
1239116) line 829 + 27 bytes
USER32! 77e13eb0()
USER32! 77e1591b()
USER32! 77e165dc()
NTDLL! 77f9fb83()
DocumentViewerImpl::SetBounds(DocumentViewerImpl * const 0x039e2ee8, const 
nsRect & {...}) line 691
nsDocShell::SetPositionAndSize(nsDocShell * const 0x03a4e97c, int 0, int 0, int 
742, int 473, int 0) line 1413 + 30 bytes
nsWebShell::SetPositionAndSize(nsWebShell * const 0x03a4e97c, int 0, int 0, int 
742, int 473, int 0) line 1601
nsWebShellWindow::HandleEvent(nsGUIEvent * 0x0012eac8) line 407
nsWindow::DispatchEvent(nsWindow * const 0x03b5a724, nsGUIEvent * 0x0012eac8, 
nsEventStatus & nsEventStatus_eIgnore) line 560 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012eac8) line 581
nsWindow::OnResize(nsRect & {...}) line 3548 + 15 bytes
nsWindow::ProcessMessage(unsigned int 71, unsigned int 0, long 1240728, long * 
0x0012ee04) line 2959 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x003c00f6, unsigned int 71, unsigned int 0, long 
1240728) line 829 + 27 bytes
USER32! 77e13eb0()
USER32! 77e1591b()
USER32! 77e165dc()
NTDLL! 77f9fb83()
nsXULWindow::SetSize(nsXULWindow * const 0x03c11c0c, int 750, int 500, int 0) 
line 470 + 38 bytes
nsXULWindow::LoadPositionAndSizeFromXUL(nsXULWindow * const 0x03c11c08, int 1, 
int 1) line 831
nsXULWindow::OnChromeLoaded() line 742
nsWebShellWindow::OnEndDocumentLoad(nsWebShellWindow * const 0x03c11c6c, 
nsIDocumentLoader * 0x03a4f478, nsIChannel * 0x03b47540, unsigned int 0) line 
1278
nsWebShell::OnEndDocumentLoad(nsWebShell * const 0x03a4ea7c, nsIDocumentLoader * 
0x03a4f478, nsIChannel * 0x03b47540, unsigned int 0) line 1182
nsDocLoaderImpl::FireOnEndDocumentLoad(nsDocLoaderImpl * 0x03a4f478, nsIChannel 
* 0x03b47540, unsigned int 0) line 712
nsDocLoaderImpl::DocLoaderIsEmpty(unsigned int 0) line 542
nsDocLoaderImpl::DocLoaderIsEmpty(unsigned int 0) line 514
nsDocLoaderImpl::OnStopRequest(nsDocLoaderImpl * const 0x039bb6b4, nsIChannel * 
0x039bbd48, nsISupports * 0x00000000, unsigned int 0, const unsigned short * 
0x00000000) line 485
nsLoadGroup::RemoveChannel(nsLoadGroup * const 0x039bb758, nsIChannel * 
0x039bbd48, nsISupports * 0x00000000, unsigned int 0, const unsigned short * 
0x00000000) line 544 + 39 bytes
nsStreamIOChannel::OnStopRequest(nsStreamIOChannel * const 0x039bbd4c, 
nsIChannel * 0x039bbeb0, nsISupports * 0x00000000, unsigned int 0, const 
unsigned short * 0x00000000) line 632
nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 0x039bc2b0) line 
307
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x039bc498) line 97 + 12 bytes
PL_HandleEvent(PLEvent * 0x039bc498) line 575 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00e30b10) line 520 + 9 bytes

The gang is kind of thinking that pollmann's scrollbar changes from last night 
may want scrutiny.
(Assignee)

Comment 63

19 years ago
cc: pollmann -- people are making accusations!
(Assignee)

Comment 64

19 years ago
I can reproduce the problem using danm's chicken dance with the bookmarks panel 
in the sidebar. Exact same stack trace.
that's the same evil stack trace for:

crash when clicking on "add" in sidebar
crash when running mail first time after installing.

that stack trace is valid, but I'm not sure it is related to this bug.

too many bugs going on right now.

Comment 66

19 years ago
I disabled the changes I made last night and the crash was still present.  I am 
now going to completely revert my changes to see if the crash is still present.

Comment 67

19 years ago
I checked in a one-liner that will disable my changes from last night.  This 
should clear up the crash the Scott is seeing.  There is no bug open for 
Scott's crash (sent to the hook).  I am also not able to reproduce Scott's crash 
in my Linux build pulled from immediately after my changes so I'm just checking 
it in now to eliminate it as cause of the others.

This does not clear up the "funky stack" crash above.  I honestly don't think 
that's related to my checkin, despite the scrollbar on the stack.

Comment 68

19 years ago
Hmm everyone is putting comments in the wrong bug report. This smoketest blocker
is not a crash it's a hang caused by a corrupt localstore.rdf

Pollmann, you said we don't hae a bug for the mail crasher. We do. it's actually
assigned to you: Bug #42686. This was the smoketest blocker from this morning
which caused mail to crash. Seth added some bullet proofing to the view manager
to prevent the crash and then it was re-assigned to you.
(Assignee)

Comment 69

19 years ago
checked in a fix for danm's stack trace. now trying to reproduce the "other" 
problem.
(Assignee)

Comment 70

19 years ago
Could someone who can reliably reproduce this bug attach their "corrupted" 
localstore.rdf to the bug?

As a side note, I was noticing some potentially related problems with the file 
cache today: the messenger start page's entry had become corrupted and was 
taking a very, very long time to load.
Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Reporter)

Comment 71

19 years ago
Created attachment 10225 [details]
my localstore.rdf file
(Reporter)

Comment 72

19 years ago
I can run mail fine using 2000-06-16-08 commercial on NT
(Assignee)

Comment 73

19 years ago
Marking fixed in that case.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 74

19 years ago
*** Bug 42605 has been marked as a duplicate of this bug. ***

Comment 75

19 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.