Pages stick on "Looking up..", not DNS problem

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Robert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Opera/9.26 (Windows NT 6.0; U; en)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

Opera works fine. Started with 2.0.0.12 and this new version still hasn't sorted it. Have tried rolling back, safe mode and disabling ipv6 with no avail. Using OpenDNS.

Reproducible: Always

Steps to Reproduce:
1. Open several tabs and go to different sites
Actual Results:  
Page status on most of them sticks on the "Looking up" stage.

Expected Results:  
Gone to the site properly
Do you mean with "disable IPV6" that you set network.dns.disableIPv6 to true ?

Comment 2

10 years ago
(In reply to comment #1)
> Do you mean with "disable IPV6" that you set network.dns.disableIPv6 to true ?
> 
I experienced the same issue with 2.0.0.12, then I switched to 3.0b4 which also has it.

And you are correct: network.dns.disableIPv6 is set to true.
(Reporter)

Comment 3

10 years ago
> And you are correct: network.dns.disableIPv6 is set to true.
> 

Yes, just checked. Is it possible that firefox is not obeying the config file?
Do you have some kind of Firewall installed which could cause this ?
I don't know what's different on your system because it works for everyone else.
Setting network.dns.disableIPv6 to true should rule out IPv6 problems.

Did you configure Firefox to direct connection (options/advanced/network) ?
Is it possible that you have 2 DNS servers configured and the first one is failing ?
(Reporter)

Comment 5

10 years ago
I have no firewall, the Windows one disabled, and I am connected directly.

Comment 6

10 years ago
(In reply to comment #4)
> Do you have some kind of Firewall installed which could cause this ?
The only active firewall is on my router. I did suspect the router, but Firefox
is the only application with the problem.

> I don't know what's different on your system because it works for everyone
> else.
> Setting network.dns.disableIPv6 to true should rule out IPv6 problems.
> 
> Did you configure Firefox to direct connection (options/advanced/network) ?
Yup.

> Is it possible that you have 2 DNS servers configured and the first one is
> failing ?
That seems unlikely to me. My ISP does give two DNS servers via DHCP, but a
failing DNS would come up as a red light on the status page and cause a lot of
complaints from users. Second reason why it's unlikely: Firefox is the only app
with the problem.
I really don't know what's wrong on your system.
You may find something helpful in http://kb.mozillazine.org/Error_loading_any_website#Websites_randomly_do_not_load

Comment 8

10 years ago
I set network.dns.disableIPv6 to false after my first comment. I haven't seen the problem again after doing that... It may be a coincidence, but the fact is that I never experienced the problem at work and the Firefox install there has the setting set to false (for some reason).

Comment 9

10 years ago
And the problem just resurfaced again, so that setting seems to have little effect.

Comment 10

10 years ago
Robert: do you still have this problem ?
I have been seeing delayed page loads with my home router {siemens speedstream 4200}. A workaround was to disable the network stacks ipv6 {ie not just firefox's}. I'm whether you could do that with vista ?

The second is to use my ISP's DNS server rather than home router's DNS. Does ipconfig/all show only the dns server addresses of your ISP ?

Comment 11

10 years ago
I now have the same problem after updating earlier today from 2.0.0.15 to 2.0.0.16, and it remains after upgrading to v3 (whatever the latest "sub" version is as of today).  As the original poster indicated....ALL OTHER PROGRAMS WHICH USE THE OS'S IP STACK WORK CORRECTLY (IE, FTP, POP/SMTP, tracert, etc)!!!  This problem is specific to FF only, so suggestions to change OS related configurations really shouldn't apply.  If you insist, I've checked all system TCP/IP configurations, and they are sound, DNS is correctly assigned (have even set it manually), etc.  Firewall is disabled, viruscheck also.  Checked to see if FF is even opening ports on my OS's TCP/IP stack, and it is not!!!!!  Sniffer confirms this also.  NO SIGN OF IT WHATSOEVER!   What files are common between FF2 and FF3 that can hinder it's port handling across versions?.

I'd rather forego uninstalling and reinstalling, and focus first on what went wrong, but if I must, I will eventually.  I've checked the settings, and/or made the changes suggested above with no resolution to the problem.  

Comment 12

10 years ago
I now have the same problem after updating earlier today from 2.0.0.15 to 2.0.0.16, and it remains after upgrading to v3 (whatever the latest "sub" version is as of today).  As the original poster indicated....ALL OTHER PROGRAMS WHICH USE THE OS'S IP STACK WORK CORRECTLY (IE, FTP, POP/SMTP, tracert, etc)!!!  This problem is specific to FF only, so suggestions to change OS related configurations really shouldn't apply.  If you insist, I've checked all system TCP/IP configurations, and they are sound, DNS is correctly assigned (have even set it manually), etc.  Firewall is disabled, viruscheck also.  Checked to see if FF is even opening ports on my OS's TCP/IP stack, and it is not!!!!!  Sniffer confirms this also.  NO SIGN OF IT WHATSOEVER!   What files are common between FF2 and FF3 that can hinder it's port handling across versions?.

I'd rather forego uninstalling and reinstalling, and focus first on what went wrong, but if I must, I will eventually.  I've checked the settings, and/or made the changes suggested above with no resolution to the problem.  

Comment 13

10 years ago
Sorry about the double posting...something from your site indicated a "mid-air collision?"  
This looks like the usual Firewall problem fletch. You wrote many text but you are missing the needed informations: OS, used Firewall etc.
You have a firewall issue, fix your broken Firewall and it will work.
and yes, i read what you wrote : Disabled Firewall = doesn't matter, many broken firewall drivers will still block. All other applications are working = doesn't matter or do you have a application with a changed .exe ?
marking wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 16

10 years ago
WinXP, SP2
NO FIREWALL (UNINSTALLED)
NO VIRUS CHECK (UNUBSTALLED)
FF3.0

Step by step here's what I did:
1.  Was running FF2.0.0.15.  Upgrade popup asked to upgrade.  
2.  Upgraded via popup to FF2.0.0.16.
3.  FF2.0.0.16 failed to load any pages, timing out after "Looking up..."
4.  Problem persisted for ALL URLs attempting to load.
5.  Ran FF-safe mode.  Problem persisted.
6.  Rebooted OS to safe mode (network enabled).  Problem persisted.
7.  Disabled virus check and firewall completely. Rebooted. Persisted.
8.  Upgraded to FF3.  Problem persisted. Rebooted. Persisted.
9.  Checked all system DNS & TCP/IP settings, confirmed operational.
10. Tested IMs, traceroute, DNS resolution, FTP, email, IE, etc.  All good.
11. Monitored TCP/IP stack for occurance of FF port handling...NONE!
12. Sniffed IP network for occurances of FF activity...NONE!
13. Uninstalled virus check.  Cleaned registry, removed all relevent folders.
14. Uninstalled firewall.  Cleaned registry, removed all relevent folders.
15. Uninstalled FF3.  Cleaned registry, removed all relevent folders.
16. Rebooted.
17. Ran double-check on registry for any FF/mozilla related occurance. Removed.
18. Rebooted.
17. Installed FF3.  Problem persists!
18. Ran FF3-safe mode...still persists.

I have no clue what IS going on, but I know for a fact is it NOT firewall related.  I've been a network engineer for 15+ years, and I know how to address firewall issues without thinking about it.  Never mind, I don't even have one installed (completely and totally removed), and XP's firewall service is disabled, and not running.  The problem began the very instant the upgrade from 2.0.0.15 to 2.0.0.16 took place, and has persisted since.  I have removed all "known" registry entries, and I have completely eliminated all previously "known" occurances of FF installations in both my user specific directories (all, me, windows, etc.), and program files directory, and yet the problem persists.  There were no other programs installed recently (within the last month), nor since.  I have made sure all other non-system programs aren't running during installations.  Anything and everything I know to do to ensure a clean install does nothing.  As it is now, I'm inclined to find 2.0.0.15, and see what that does, but my gut tells me there's something lurking on my system now that will affect it too.  

Regardless, this is NOT, I repeat...NOT a firewall issue!

Any ideas?



>14. Uninstalled firewall.
You still didn't told us which Firewall !

close Firefox, rename c:\program files\Mozilla Firefox\Firefox.exe to
c:\program Files\Mozilla Firefox1\firefox1.exe

(rename foldername and .exe filename)
Does it work now ?

Comment 18

10 years ago
Ok, you're starting to insult my intelligence, and technical experience.  If you MUST DOUBT MY ABILITY TO WIPE A PROGRAM COMPLETELY by insisting on knowing what my previously installed firewall was (WHICH IS NO LONGER ON MY COMPUTER), it was Zone Alarm, whatever the version several months ago.  I can assure you, however, there is NOTHING of it remaining on my system.  I have removed every single existing remnant of it from my hard drive and registry.  I have double and triple checked all processes running on my system for anything which shouldn't belong.  Of those published...there are 18 processes running, all of which are confirmed as needed for my system to run.  I had confirmed, and have since again confirmed there are no viruses on my computer.  

As for your folder and filename change...no, it did NOT fix the problem. It might have it was a firewall issue though.  I know you're fighting me on this one, but THERE IS NO FIREWALL ISSUE!  

Do you have any idea what might have changed between 2.0.0.15 and 2.0.0.16, and persists through to FF3 that might, if corrupted or conflicting, cause FF to NOT hook into/open a port in the OS's tcp/ip stack?  Whatever it is...is preventing FF2.0.0.16 - FF3.0 from opening tcp/udp ports (as confirmed in my earlier message wherein I tell you I can clearly see it is not, and can confirm with a sniffer).  No other tcp/udp/ip program I am running is affected!




Then it's very simple: you are posting in a wrong bug if you are sure that it's not a firewall issue.

Please use http://support.mozilla.com (Forum)

Comment 20

10 years ago
Matthias...

Look, I'll do what you say and post another bug, and I'll likely name it "Pages stick on "'Looking up..', and it's not DNS or a firewall problem."  LOOK FAMILIAR???    

The fact is the original poster reported only that it wasn't a DNS problem, and neither is mine.  The original poster refuted you when you questioned him if it was a firewall issue, just like I did.  His problem isn't resolved, and neither is mine.  The third poster indicated his problem disappeared, then reappeared, and so far as I have read, this hasn't been resolved for him either.  None of our problems are DNS related, just like the original poster indicated in his bug report, and none are resolved.  

So how did we get to this being a firewall issue that has been resolved when it was reported as a non-DNS issue, and hasn't been resolved?  So far as I can tell, the ONLY person who has continued to push this as a firewall issue is you, and a firewall issue isn't what the focus of the bug was originally....not being DNS was (that's pretty broad in scope).  It was YOU who interjected the firewall issue, and YOU who has continued to push it as the be-all-end-all solution that isn't a solution at all.  Then you marked this bug resolved, and from what I can read, none of us has yet said the issue was resolved.  You've proclaimed the solution is to fix our firewalls, and basically told us "if our problem isn't firewall related, it's being posted in the wrong bug."   That's pretty ugly troubleshooting.  Users present symptoms, declare what's not working, and you, unable to resolve the issue, get stuck on a so-called solution that is completely refuted, declare the bug resolved, then tell us (who still have the original problem) we're posting to the wrong bug if it isn't solved with a solution that isn't a solution at all.  WOW!  I bet you solve 100% of your problems without escalating them to higher support levels, don't you?!!

I'll post a new bug, nearly identically worded as this one, just so I don't have to deal with your incompetence and/or laziness anymore, and maybe somebody will take it who actually wants to troubleshoot this obscure, isolated problem.  

And would you mind telling me what your connection to Mozilla is?  I now have a vested interest in knowing.  
This is not a solution finder or support page.
Every support request is invalid in bugzilla, don't expect getting help to fix your issue.
This is a technical bug database and if we can confirm a bug and reproduce an issue it will can be fixed someday. A developer is unable to fix this bug because we can not reproduce this.

This got marked wfm because we can not reproduce this bug and there are not enough information to reproduce it.
That is the description from the Worksforme resolution:
" WORKSFORME
    All attempts at reproducing this bug were futile, and reading the code produces no clues as to why the described behavior would occur. If more information appears later, the bug can be reopened. "

The reporter wrote a bug about 2.0.0.13 and your 2.0.0.15 worked, it stopped working with 2.0.0.16 and that means that this is not the same bug and you are spamming this one.
And there changed nothing in TCP/IP between 2.0.0.15 and 2.0.0.16 and it works for 100 Million users, it doesn't on your system and that means that it's something on your system that caused this. If you find out what the problem is, then such a bug could be fixed. 
You need to log in before you can comment on or make changes to this bug.