Second click on tab should bring it back in background

RESOLVED WONTFIX

Status

()

enhancement
RESOLVED WONTFIX
11 years ago
10 years ago

People

(Reporter: ezh, Unassigned)

Tracking

({ue})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Could not find the feature request.

In Windows (Linux as well) clicking in taskbar on a program bar brings it foreground, clicking second time brings back the previous foreground window.

I would like tabs in FF behave the same.

Comment 1

11 years ago
I don't like this Windows feature and I don't think we should copy it.
If the request is that you want the previously selected tab to be focused, maybe Bug 395980 is what you want. Although this bug won't help mouse users, only keyboard users. People who only occasionally bend over to their keyboard have no profit of it.
(Reporter)

Comment 3

11 years ago
I meant actually the same as bug 395980, but clicking on a tab is simplier, since it's just a mouse move.

Updated

11 years ago
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
I cannot see any relation between these two bugs. Perhaps I also haven't completely understand your concern. Please give some steps to reproduce which make it much clearer. Thanks.
(Reporter)

Comment 5

11 years ago
Just like CTRL-TAB in Windows/Linux switches windows between first/second, such pressing the application button on the tast bar swithes it forground/background. It seems for me to be related mimiking the OS behavior for tabs.

Comment 6

11 years ago
(In reply to comment #5)
> Just like CTRL-TAB in Windows/Linux switches windows between first/second, such
> pressing the application button on the tast bar swithes it
> forground/background. It seems for me to be related mimiking the OS behavior
> for tabs.
> 

That is completely different.  Firefox's ctrl+tab behavior is like windows's alt+tab behavior.  
(Reporter)

Comment 7

11 years ago
And what had I said? Windows also has the click -> app in forground -> click again -> app in background behaviour.

Comment 8

11 years ago
Ahh I see....When hitting ALT+TAB on windows, the currently focused application is what is initially selected so that way if you let go of the keys, focus won't change.

This bug is asking that the same thing happen with CTRL+TAB as in the "next tab" (most recent) is not initially selected so that if we let go of the keys, focus (the tab selection) isn't changed.  Seems kind of valid to me but why would you press CTRL+TAB in the first place if you did not intend to switch tabs?
Sorry, but it looks like that you always talk about the task bar and not the Alt+Tab key combination. There is no way to bring an application to for- or background. Ctrl-Tab has nothing to do with the task bar. So I still don't see any relation to the other bug.

Eugene, please give clear steps how to reproduce the thing you are trying to explain like shortcuts, mouse clicks or anything else. Thanks.
(Reporter)

Comment 10

11 years ago
Kurt Schultz, yeah, that's a different point and a diferent bug.

I talk about taskbar on OS and tabbar in FF. 

1. Open 2 applications in say Windows.
2. Two boses on the taskbar appers - 1 and 2.
3. The number 2 (latest started) has the focus, or is pressed (is foreground).
4. Click on the number 1 unfocused app box.
5. Now this app has focus (the box is pressed) and is in foreground.
6. Now click again on the SAME box 1. The box 2 besomes pressed and in foreground.

I'd like the same behaviour in FF tabs. Pressing a tab open the tab. Pressing once more brings the old one foreground.
Ok, so as I already said in comment 4 it has nothing to do with the Ctrl-Tab feature. But beside that I also don't think that this should be a common feature. I don't have the spec about how tabs should react but as I know I have never seen such a behavior in other applications. I also don't see a reason why that should happen.

Mconnor is this probably wontfix?
(Reporter)

Comment 12

11 years ago
Why should it be WONTFIX? It's a RFE. It's very usefull feature from my point of view.

1. You have 10 tabs opened. 
2. The number 3 is active.
3. You need a quick look into tab 10.

So you press on it, view the needed information and then without mouse moving just press again on the 10th tab - the tab nunber 3 is the active again.

Comment 13

11 years ago
Sounds like a good idea to me to save time from manually scrolling back down the tab strip.  
Keywords: ue
I wouldn't appreciate it, I think it would be confusing if you click twice on it (unintentionally or with the purpose to display the focus outline) and your tab disappears into the darkness, but maybe with a hidden pref for it I wouldn't care.
But the reporter is right that there is no good mouse equivalent for ctrl+tab.
(Reporter)

Comment 15

11 years ago
No one is confusing with this on the windows and than someone should in FF? Why? The tab does not dissapears, it just get's and unget's focus.

Comment 16

11 years ago
I disagree with your assertion that the equivalent Windows feature confuses nobody.  It often gets in my way and occasionally confuses me.
When you click on the foreground tab unintentionally it can scroll all the way down to the 34st tab hidden somewhere far in the row behind the tabstrip arrow. And that is irritating :). So this would need at least an Undo possibility.
Additionally the second click on a tab is reserved to focus the tab for the keyboard tab scroll function.
Further the behavior of the buttons within the task bar are totally different to the tab controls which are implemented in different applications right now. Jesse, do you know who cares about the widget behavior?
The Last Tab extension seems exactly what you want. Or not? :)
https://addons.mozilla.org/en-US/firefox/addon/112
(Reporter)

Comment 20

11 years ago
Ria Klaassen, TNX a lot! I'm happy now. :) 

We may consider to close this RFE. But maybe someone will find it good to build-in.
Eugene, nice to see that you got your wished behavior with the mentioned extension.

I had a talk about with Gen Kenai @mozcamp in Vancouver Airport and he also thinks that this should be added by an extension. Mano, can we mark this as wontfix?
Tabs have pretty widely known and expected behaviours, and this would be a major departure, and would likely be confusing.  Great as an addon, but not great for default behaviour.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.