WARNING: Fonts still alive while shutting down gfxFontCache: 'mFonts.Count() == 0', file ../../../dist/include/thebes/gfxFont.h, line 165

REOPENED
Unassigned

Status

()

REOPENED
11 years ago
a year ago

People

(Reporter: mmokrejs, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Opera/9.50 (X11; Linux i686; U; en)
Build Identifier: 

This used to be an ASSERTION. See bugs #378836, #386211 and #386804. I compile cairo with debug symbols and installed the breakpoints. Is that of any help to you?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

11 years ago
Created attachment 311957 [details]
stacktrace

Upon closing browser windows I get this reproducibly with current cvs HEAD build.
A clean Mac trunk Sunbird debug build outputs the following on shutdown:

WARNING: Fonts still alive while shutting down gfxFontCache: 'mFonts.Count() == 0', file ../../../dist/include/thebes/gfxFont.h, line 165

-> Should go into some component of Core.
Blocks: 426966
Status: UNCONFIRMED → NEW
Component: General → GFX: Thebes
Ever confirmed: true
Product: Mozilla Application Suite → Core
Assignee: general → nobody
QA Contact: general → thebes
I can't reproduce on mac or linux. Please re-open with detailed STR.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
FWIW, I see this sporadically with debug Firefox builds, on various platforms, but I don't have any consistent STR. It typically seems to occur together with a bunch of messages about leaked chrome:// URLs, if I recall correctly.
Alright, that's enough evidence to reopen.
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---

Comment 6

2 years ago
Reproduced in Bughunter automated crash testing on Linux.

1. http://www.bvoltaire.fr/ in debug Nightly/53 build on Fedora 24/x86_64
2. Wait until page begins loading, then close browser by clicking on the window close (x).
3. Profit!

[Child 23570] WARNING: Fonts still alive while shutting down gfxFontCache: 'mFonts.Count() == 0', file /mozilla/builds/nightly/mozilla/gfx/thebes/gfxFont.cpp, line 207
WARNING: YOU ARE LEAKING THE WORLD (at least one JSRuntime and everything alive inside it, that is) AT JS_ShutDown TIME.  FIX THIS!
[Child 23570] ###!!! ASSERTION: Component Manager being held past XPCOM shutdown.: 'cnt == 0', file /mozilla/builds/nightly/mozilla/xpcom/build/XPCOMInit.cpp, line 1074
[Child 23570] WARNING: '!compMgr', file /mozilla/builds/nightly/mozilla/xpcom/glue/nsComponentManagerUtils.cpp, line 63

Note this occurs on Ubuntu and Fedora on Beta/51, Aurora/52, Nightly/53 and from this bug report from much earlier.
Blocks: 532972
You need to log in before you can comment on or make changes to this bug.