Last Comment Bug 425343 - No support for resource (Meeting/Conference Rooms) booking and scheduling
: No support for resource (Meeting/Conference Rooms) booking and scheduling
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Lightning Only (show other bugs)
: unspecified
: All Windows XP
: -- enhancement with 2 votes (vote)
: 1.9
Assigned To: Philipp Kewisch [:Fallen]
:
:
Mentors:
Depends on: 815568 816127
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-26 23:14 PDT by Siddharth Sharma
Modified: 2012-11-28 09:12 PST (History)
7 users (show)
bugzilla: wanted‑calendar0.9-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Show icons for different CUTYPES (30.57 KB, patch)
2012-06-28 13:46 PDT, Philipp Kewisch [:Fallen]
mbailly: review+
Details | Diff | Splinter Review
Screenshot - v1 (57.28 KB, image/png)
2012-08-23 09:26 PDT, Philipp Kewisch [:Fallen]
no flags Details
resource icon (628 bytes, image/png)
2012-08-27 05:53 PDT, Andreas Nilsson (:andreasn)
no flags Details
group icon (644 bytes, image/png)
2012-08-27 05:53 PDT, Andreas Nilsson (:andreasn)
no flags Details
room icon (343 bytes, image/png)
2012-08-27 05:53 PDT, Andreas Nilsson (:andreasn)
no flags Details

Description Siddharth Sharma 2008-03-26 23:14:15 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: TB version 2.0.0.12 (20080213); Lightening build 2008032619

Outlook 2003 has an option to add meeting/conference rooms as resources in order to book them. Essentially the rooms have email addresses and if the are free they accept the invite. There is a provision for seeing which ones are free and which ones are not (but I think this is due to the microsoft exchange server). This is one of the for most reasons due to which huge number of my colleagues are avoiding a transition from outlook to thunderbird+lightning

Reproducible: Always
Comment 1 Simon Paquet [:sipaq] 2008-03-27 04:15:07 PDT
IMO this bug is INVALID, as this is a functionality that cannot be provided on the client level, but must be implemented on a server (e.g. Exchange). I don't know whether stuff like this isn't already possible on a CalDAV server or Sun's Java Calendar Server that we both support. 
Comment 2 Daniel Boelzle [:dbo] 2008-03-27 06:38:52 PDT
I've often seen resource booking been implemented separate to the calendar system, but RFC 2445 defines user types (CUTYPE) for resources, so it's quite easy to use virtual calendar users for resources. Just invite such virtual users and the resources are booked. However, what's lacking are resource management facilities, and I think that's the primary reason why those are implemented separate to the calendar system.

[1] <http://tools.ietf.org/rfcmarkup?doc=draft-ietf-calsify-rfc2445bis-08#section-3.2.3>

So I am asking myself if and what we could do about resources, with sticking to RFC 2445. If resources appear as ordinary mail-addresses / attendees, calendar may determine the correct CUTYPE by corporate directory lookup. Or, more simple, we could enhance the "Invite Attendees" pane allowing the organizer to specify the CUTYPE.
Comment 3 Siddharth Sharma 2008-03-27 07:09:03 PDT
I am not changing the state of the bug but I still believe the feature to send an invite to a Room/Resource should not be infeasible along with acknowledging a confirmation/rejection. Ideal case would be to have support for the exchange server. *Thinking whether that is too much to ask*
Comment 4 Lars Wohlfahrt (thetux) 2008-03-28 01:36:07 PDT
I think dbo is right. Modification of Invite Attendees seems best.
Comment 5 Daniel Boelzle [:dbo] 2008-03-28 02:08:32 PDT
I think we need to separate things here:
- Inviting virtual resources by iTIP/iMIP should already work (apart from the Outlook issues and missing methods which are tracked in other bugs)
- UI enhancements to tag attendees as "resource". This may affect both the invite attendees dialog and maybe the read-only dialog where the PARTSTATs of attendees are shown. Christian, could you imagine a sensible UI?
Comment 6 Simon Paquet [:sipaq] 2008-05-05 13:16:13 PDT
Siddharth, please don't set the '+' flag. This is reserved for release drivers.
Comment 7 James Andrewartha 2008-09-02 00:05:51 PDT
I tested resource booking with Bedework (which is just an auto-accept) using CalDAV scheduling and it worked. I created a Bedwork user upstairsmeetingroom, invited upstairsmeetingroom@daa.com.au in Lightning and the invitation was accepted.
Comment 8 Philipp Kewisch [:Fallen] 2012-06-28 13:46:13 PDT
Created attachment 637654 [details] [diff] [review]
Show icons for different CUTYPES
Comment 9 Philipp Kewisch [:Fallen] 2012-06-28 13:48:30 PDT
This patch at least shows different icon types. I will need new icons for RESOURCE, GROUP, and ROOM userTypes as well as the icons in a disabled state.

This does not provide a way to select meeting rooms from a list or such, since there is no standardized way to do so. We should file a new bug when such a standard is known or created.
Comment 10 Philipp Kewisch [:Fallen] 2012-08-09 11:22:56 PDT
Andreas, any update on this? I would like to get this in before the next merge.
Comment 11 Andreas Nilsson (:andreasn) 2012-08-10 06:54:46 PDT
Sorry, been occupied by other bugs. When is the merge specifically?
Comment 12 Philipp Kewisch [:Fallen] 2012-08-10 09:02:48 PDT
August 27th
Comment 13 Philipp Kewisch [:Fallen] 2012-08-23 09:26:09 PDT
Created attachment 654658 [details]
Screenshot - v1
Comment 14 Andreas Nilsson (:andreasn) 2012-08-27 05:53:07 PDT
Created attachment 655564 [details]
resource icon
Comment 15 Andreas Nilsson (:andreasn) 2012-08-27 05:53:29 PDT
Created attachment 655565 [details]
group icon
Comment 16 Andreas Nilsson (:andreasn) 2012-08-27 05:53:47 PDT
Created attachment 655566 [details]
room icon
Comment 17 Philipp Kewisch [:Fallen] 2012-08-27 09:37:34 PDT
Thanks for the graphics! Could you elaborate on why you chose a checkmark for a "resource" ?
Comment 18 Philipp Kewisch [:Fallen] 2012-08-27 09:39:35 PDT
Given the merge is today, I'm going to push this patch as is first, then update the icons afterwards.
Comment 19 Philipp Kewisch [:Fallen] 2012-08-27 09:41:12 PDT
Pushed to comm-central changeset f8c22d29debf
Comment 20 Andreas Nilsson (:andreasn) 2012-08-27 09:55:59 PDT
(In reply to Philipp Kewisch [:Fallen] from comment #17)
> Thanks for the graphics! Could you elaborate on why you chose a checkmark
> for a "resource" ?

To be all frank, because that was the best I could come up with.
I'm happy to draw something else if anyone has a better idea what to do for that.


http://www.iconfinder.com/search/?q=resource
https://www.google.com/search?num=10&hl=en&site=&tbm=isch&source=hp&biw=1920&bih=938&q=resource&oq=resource&gs_l=img.3..0l10.903.2939.0.3314.8.5.0.3.3.0.69.302.5.5.0...0.0...1ac.lZrf2QOZg24
Comment 21 Philipp Kewisch [:Fallen] 2012-09-04 04:23:02 PDT
Since a resource is usually something like a beamer or flipchart, I'd suggest using something like that. Not sure if its possible to do in that little px though. I'd prefer beamer over flipchart.
Comment 22 Martin Schröder [:mschroeder] 2012-11-02 07:58:30 PDT
Comment on attachment 637654 [details] [diff] [review]
Show icons for different CUTYPES

Clearing ui-review flag as this patch has been checked in two months ago.
Comment 23 ingo.goeppert 2012-11-11 02:36:11 PST
Tested with lightning 1.9b2 and tb 17.0b2: There are no icons/blank icons for resource/group/room (it looks like https://bugzilla.mozilla.org/attachment.cgi?id=654658). In which version are the ions included?

Note You need to log in before you can comment on or make changes to this bug.