Bring back the sexy discussion pages with option to set an external support url

VERIFIED DUPLICATE of bug 428139

Status

addons.mozilla.org Graveyard
Public Pages
--
enhancement
VERIFIED DUPLICATE of bug 428139
10 years ago
2 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Details

In AMO v3.2, the discussions are read-only and developers should link to an external support page. But in the real world, most often only big add-ons have their own support page (so a user would have to register for each add-on he wants to discuss) and smaller add-ons use theirs add-ons details pages as homepage links. Furthermore, third party forums like mozillazine.org doesn't fit the needs of many add-on developers because the support of multiple threads with notifying the developer on creation of the topic doesn't exist.

Comment 1

10 years ago
I will  have to strongly agree with this.
The disappearance of discussions is a serious problem. While authors should be able to disable them(for those that have discussion forums/dont read amo/find it generates too much volume), this is an extremely useful feature, that many authors, that did not want to publish an email/a website, used. It also had the great advantage of letting people see if other people had seen/solved existing problems or not. And as archaeopteryx@coole-files.de said, it also provided the advantage of a separate section for each extension, way simpler than setting complete forums/using existing public forums.

Comment 2

10 years ago
I would also vote for bringing back the option for discussions - my extension already has several "reviews" that are not reviews at all.  


When an extension does provide a "support link", that information is not provided anywhere near where reviews are written - so it's likely someone won't even see that information before they write their request for help in their review.  Also that support link is stuck into a big long paragraph that no one is going to read.  The support link should be more distinct

Comment 3

10 years ago
In bug 428139, we are suggesting to bring back the sexy discussion pages on a per addon basis. Hopefully that will address this request.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 428139
Verified as a sexy dupe
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.