Painting issue on large pages

RESOLVED DUPLICATE of bug 215055

Status

()

RESOLVED DUPLICATE of bug 215055
11 years ago
11 years ago

People

(Reporter: chris.sherlock79, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008031317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008031317 Firefox/3.0b4

When I try to click on the link to gain information about Holroyd City Council from the Australian NSW Dept of Local Government, the new page does not render. 

Reproducible: Always

Steps to Reproduce:
1. Go to the URL http://www.dlg.nsw.gov.au/dlg/dlghome/dlg_LocalGovDirectory.asp?index=1&mi=3&ml=5
2. Search for "Holroyd City Council"
3. Click on the link. I cannot get to the next page, and the existing page looks somewhat unusual - it does not repaint at all! See screenshot - as you can see, Gnome Screenshot is actually in the foreground, yet that is not because I've kept that program open! It appears that Firefox doesn't repaint the page. 
Actual Results:  
Window doesn't repaint, also doesn't take you to the correct page. 

Expected Results:  
Should take you to the next page, while you are waiting the window should be repainted. 

This is Firefox 3.0b4. I run this on Ubuntu Linux Hardy Heron beta.
(Reporter)

Comment 1

11 years ago
Created attachment 312018 [details]
Screenshot of the Firefox window that doesn't look like it's repainting.

This is a screenshot that shows what I'm talking about.

Comment 2

11 years ago
I can reproduce the issue with beta 4. With trunk, things are a bit different:
The window is repainted but the repainted part is wrong. If you scroll the page by a small amount, the part at the center of the window is not scrolled.

The behavior changed between:

http://bonsai.mozilla.org/cvsquery.cgi?&date=explicit&mindate=2008-03-14%2000-50&maxdate=2008-03-14%2001-26

(I guess bug 380115)

The remaining issue looks like to be there from a long time. I can see the same issue with a very old Firefox 3 version or Firefox 2.

Comment 3

11 years ago
That was not quite correct

2007-01-15 (maybe older) --> 2008-03-14 2000-50

No repaint

Gecko 1.8, or
2008-03-14 2001-26 --> now

Repainted but wrong

Updated

11 years ago
Status: UNCONFIRMED → NEW
Component: General → GFX: Thebes
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → thebes
Summary: New page does not render when clicking on link to Holroyd Council → Painting issue on large pages
Version: unspecified → Trunk

Comment 4

11 years ago
Created attachment 312128 [details]
Vladimir's testcase slightly changed

When reducing this bug I came close to Vladimir's testcase on bug 380115 (attachment 292672 [details]). I changed it slightly in order to make the issue more visible.

Steps to reproduce:
* Load testcase and scroll down to about 3/4 of the page
* Now try to scroll by a few lines at a time (using wheel mouse button, or keyboard up/down arrows).
* Notice how the page is refreshed at the top/bottom of the viewport, but the center of the viewport is not updated.

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 215055
You need to log in before you can comment on or make changes to this bug.