If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Page layout of form is incorrect

VERIFIED FIXED

Status

()

Core
Layout
P1
major
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Stephen P. Morse, Assigned: mjudge)

Tracking

({regression})

Trunk
x86
Windows NT
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
This may be related to bugs 42451 and 42471 in that it is a regression that 
started failing somewhere between 5PM on June 8 and 5PM on June 10.  Go to above 
url.  The page layout is not quite correct but it's hard to describe.  Go fill 
in any field.  The characters will appear in the field below the one you 
selected.
Keywords: nsbeta2, regression
Note the demo URL referenced is a saved copy of a real-world page, so whatever 
this is affects sites that are out there.

Comment 2

18 years ago
The page layout looks bad, but not bad enough to hold beta2 for. We'd also like 
to see this on the real page out on the web. Also, we can't reproduce the 
problem with form fields.
Whiteboard: [nsbeta2-]

Comment 3

18 years ago
Part of the badness of this page is the lack of the images that came with it, 
the images were instrumental in the layout. The issues with the form fields I 
believe has to do with invalid html, for example, there is a font element within 
 a TR that is specifying specific font style and height. That may be the cause. 
If this page is being used as an example, I would ensure that the images are 
also brought over and I would ensure the page is valid HTML. If you can provide 
the images needed for this document, I would be more than happy to clean it up 
for you.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
Target Milestone: --- → M17
OK, what about http://lxr.mozilla.org/seamonkey/search?string=ACCESS_DENIED

There's lots of layout wierdness that used to work fine.
Communicator handles this sample JUST FINE without the images. Mozilla USED to 
handle this form JUST FINE.

Closing this for lack of images is flimsy, lazy, and missed the point.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Comment 6

18 years ago
Based on the initial wontfix resolution that was given to this, I went and 
changed the sample page itself so that it lays out properly in seamonkey (it's 
part of the wallet demo which is part of the seamonkey product).  So now 
we've lost the test case to demonstrate this bug.

If you decide to work on this, you'll need to fetch version 1.2 of 
netmarket.html from mozilla-org/html/wallet/samples and use that as the test 
case.

Comment 7

18 years ago
updated priority and severity
Severity: normal → major
Priority: P3 → P1
(Assignee)

Comment 8

17 years ago
http://lxr.mozilla.org/seamonkey/search?string=ACCESS_DENIED

works fine for me. morse can you grab that version of the web page for me? or 
let me know if I can contact you for help finding it?

also is this "problem" directly from the form fields? or the way layout is 
handling the strange HTML??  is this something for the editor group or layout?
Status: REOPENED → ASSIGNED
Keywords: nsbeta2 → nsbeta3
Whiteboard: [nsbeta2-]
Target Milestone: M17 → M19
(Reporter)

Comment 9

17 years ago
Created attachment 11937 [details]
Here's the original version of netmarket.html
(Reporter)

Comment 10

17 years ago
I've attached the original version of netmarket.html that was showing the 
problem.  Things are a bit better now than they were when I originally reported 
the bug but the layout is still not correct.  Note the words "spacer" and "hr" 
sprinkled over the page.  Compare this to the way that 4.x lays out the same 
page.

Comment 11

17 years ago
Fix URL.

The reason that page layout might differ, if there are broken images on the page, 
is that gecko handles broken images very poorly. It does not preserve their 
height and width. See bug 41924.
(Reporter)

Updated

17 years ago
(Reporter)

Comment 12

17 years ago
No, that URL won't demonstrate it.  Recall that I had rewritten the html of that 
page in order to work around this bug.  So you'll need the original html file 
which is what I just attached.

Comment 13

17 years ago
I'm sure that the remaining layout issues here are because of our broken broken 
image handling. Should this be closed, or marked a dup of 41924? The original 
problem that the bug describes is fixed.

Comment 14

17 years ago
as Simon indicated, the original problem described here is resolved, marking as 
such.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Keywords: nsbeta3
Resolution: --- → FIXED

Comment 15

17 years ago
Marking verifed per last comments.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.