Print & Print Preview truncate tables over 1 page long (with or without a caption)

RESOLVED DUPLICATE of bug 129941

Status

()

--
major
RESOLVED DUPLICATE of bug 129941
11 years ago
10 years ago

People

(Reporter: dante3333, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

I've tried to print the test page (there is a CSS for media="print"), but Firefox truncate the table after 1 page.

Reproducible: Always

Steps to Reproduce:
1. Follow the link
2. Make a print preview (doesn't work)
3. Printed (doesn't work too).
Actual Results:  
The table is broken, only one page is printed (and previewed).

Expected Results:  
Table printed correctly on multiple pages.

This bug appears in Firefox 3.0 Beta 4, and Firefox 2.0.0.13, on Windows XP.
(Reporter)

Comment 1

11 years ago
This bug is still present in Firefox 3.0 Beta 5 on Windows XP.
(Reporter)

Comment 2

11 years ago
This bug is still present in Firefox 3.0 RC1 on Windows XP.
(Reporter)

Comment 3

11 years ago
This bug is still present in Firefox 3.0 RC3 on Windows XP.

Comment 4

10 years ago
I have confirmed this as well and have experianced the same issue on one of my sites as well.  I am not able to post the site for security reasons, but can confirm this bug!

Comment 5

10 years ago
Sorry forgot current version

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Comment 6

10 years ago
Created attachment 339812 [details]
Minimized Test Case

Minimized test case from the site.  Most of the test case is the table used to generate content.  The important part of the test case is the bit inside the <style> tag.  If you comment out the <style> tag, then the test will show as two pages in print preview.  If you leave that <style> tag in play then the problem occurs. Both Minefield and Firefox 2 exhibit the problem.  Safari renders it properly, though.

My minefield version: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b1pre) Gecko/20080922020341 Minefield/3.1b1pre

Comment 7

10 years ago
Created attachment 339813 [details]
the image I use in the file to generate some content
Created attachment 339822 [details]
testcase2

I managed to reduce it a bit further and this still seems like the same bug on print preview. Nothing gets rendered on the second page.
I think this is basically the same as bug 129941.

Comment 10

10 years ago
(In reply to comment #9)
> I think this is basically the same as bug 129941.
Hmmm... I think so too.  Should we dupe?
Yes, I'm doing it now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 129941

Updated

10 years ago
Component: General → Printing: Output
Product: Firefox → Core
QA Contact: general → printing
You need to log in before you can comment on or make changes to this bug.