Closed Bug 425419 Opened 14 years ago Closed 14 years ago

Help window opened from the Options dialog is modal (Windows only)

Categories

(Firefox Graveyard :: Help Documentation, defect, P2)

x86
Windows XP
defect

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 3

People

(Reporter: steffen.wilberg, Assigned: mconnor)

References

Details

Attachments

(1 file)

After bug 423486, Help pages are loaded in a browser window instead of toolkit's Help Viewer.
On Windows, where the Options dialog is modal, the new browser window with the help page is itself modal. You can use the new window for regular browsing, but can't access the original window or even the Options dialog while the new window is open.
Only the new window appears on the Windows task bar. And it's fullscreen if you use fullscreen browsing windows, hiding the original window and the Options dialog.

This is related to bug 256555.

We should either open the help page in a popup window instead of a regular
browser window. Or we should make the window not modal: Gavin suggested to either use the opener or the window watcher to launch the window, or teach openUILinkIn to do that.
Flags: blocking-firefox3?
Assignee: nobody → mconnor
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
Status: NEW → ASSIGNED
Whiteboard: [swag 1hr]
Whiteboard: [swag 1hr] → [has patch][needs review gavin]
Duplicate of this bug: 429213
Comment on attachment 315238 [details] [diff] [review]
switch openUILinkIn to use window watcher, use the top browser window as the opener

>Index: browser/base/content/utilityOverlay.js

>+    ww.openWindow(w,

(w || window) would be closer to the previous behavior of always using "window" as the parent, but I'm not sure it matters. Shouldn't hurt, though.

I still don't like the idea of making this change to openUILinkIn now, and would prefer a specific fix in openPrefsHelp, but I'm not adamant.
Attachment #315238 - Flags: review?(gavin.sharp) → review+
Whiteboard: [has patch][needs review gavin] → [has patch]
Target Milestone: --- → Firefox 3
Attachment #315238 - Flags: approval1.9?
Comment on attachment 315238 [details] [diff] [review]
switch openUILinkIn to use window watcher, use the top browser window as the opener

a1.9+=damons
Attachment #315238 - Flags: approval1.9? → approval1.9+
Checked in.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008050718 Minefield/3.0pre

Verified.
Status: RESOLVED → VERIFIED
Whiteboard: [has patch]
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.