Closed Bug 425441 Opened 17 years ago Closed 16 years ago

Slightly-stretched images look worse than in Fx2 due to use of bilinear filtering

Categories

(Core :: Graphics, defect)

x86
Windows 2000
defect
Not set
minor

Tracking

()

RESOLVED WONTFIX

People

(Reporter: davidcorley, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9pre) Gecko/2008032705 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9pre) Gecko/2008032705 Minefield/3.0pre

The main graphic on the Winamp homepage is "blurred" when viewed with FX3. FX2 and IE do not show the same blurring.

Reproducible: Always

Steps to Reproduce:
1.Visit Winamp.com with FX3
2.Repeat with FX2
3.Repeat with IE6
Actual Results:  
Image (including text in the image) is blurry

Expected Results:  
Image should be sharp
Bilinear filtering.

Image is 760x275 but it's scaled to 760x276. Such scaling can't possibly look good.
Is it the fault of Winamp.com then, or is FX being overly aggressive in filtering it?
I see IE reports it's size (right-click -> properties) as 760x276 also.
I guess I should let the Winamp guys know either way. Does seem a bit strange to be stretching the image.
Does the image look better if you load only the image in a new tab/window ?
Looks perfect. I've let the Winamp site guys know about this here:
http://forums.winamp.com/showthread.php?s=&threadid=289119
I'm pretty sure this isn't a bug from what's been discussed. Anyone have any objections to me marking this as INVALID?
It looks better in FF2 and IE6, i move this to Thebes for image scaling.
They can decide if this is just invalid or if we can do that better.
Component: General → GFX: Thebes
Product: Firefox → Core
QA Contact: general → thebes
Can't have it both ways... either we do filtered scaling or we don't.  We maybe might could do some tricks where we drop down to nearest-neighbour filtering if the scaling factor is less than some small amount (e.g. scaled up by less than 2px and less than 10% of the total image size)... roc, what do you think?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 381661
Severity: trivial → minor
Keywords: regression
Summary: Strange anti-aliasing-type effect on Winamp homepage making text blurry → Slightly-stretched images look worse than in Fx2 due to use of bilinear filtering
I've seen a few off-by-one errors in the wild like this. We could try to work around it but I think we'd do the Web a service if we don't try to work around and try to get these sites fixed instead. They're not really serious problems for our users and fixing the image sizes will give a significant speedup for all Web users.
Even though I'm only a user, I'm actually in agreement with Robert on the issue. In the case of Winamp, I think the cause of the issue is a typo (setting the height to 276 instead of 275) and should be corrected on their end. I've posted to their forum and send a PM to one of the more active forum admins to get them to fix the issue. It's the only site I've noticed the issue on.
It is perhaps worth adding that nearest neighbour resizing is not a good solution to deal with this case either.

Nearest neighbour will duplicate a line in the middle to add the extra height. It is pure coincidence that middle line of this particular picture is all black, therefore doubling is invisible. If there was any text in the middle, it would be obvious.

There is no good fallback in case of very small zoom ratio (that I know of).
"There is no good fallback in case of very small zoom ratio (that I know of)."

Well, if for some perverse reason you really needed an image to be scaled by a few pixels, and look just as sharp, you could use seam carving ( http://portal.acm.org/citation.cfm?id=1275808.1276390 ), but I guess that's out of the question here...
I'm going to go ahead and close this out. For what it's worth, winamp appears to have fixed their site.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: