Dropmarker and hover state/effect should not be active when addon is not compat

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED WONTFIX
11 years ago
3 years ago

People

(Reporter: marcia, Unassigned)

Tracking

Details

Seen using : Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008032705 Minefield/3.0pre.

STR:
1. Visit an addon that is not compat
2. Observe on Windows XP the dropmarker is active on hover

Expected: It would not be active since the addon is not compat.
Duplicate of this bug: 425494
OS: Windows XP → All
Hardware: PC → All

Comment 2

10 years ago
Thanks for filing this, Marcia.

A technical note: The hover effect is a CSS :hover pseudo-class. Marking add-ons as incompatible is done via JS, and removing this pseudo-class from the CSS file on the fly with JS is not possible that I know of (consulted jresig and he concurs). So we'd have to *add* the effect for each *compatible* add-on via JS, rather than removing it just for the incompatible ones in order to make this work as intended.
Summary: Dropmarker should not be active when addon is not compat → Dropmarker and hover state/effect should not be active when addon is not compat
The button is very gray in both states indicating to me that it's disabled but has the potential to be enabled.  With our fancy new "check this box to enable the button" I think it makes sense to leave this as is.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.