UMR: TextFrame::PaintAsciiText() and into GTK land

VERIFIED FIXED

Status

()

Core
Selection
P3
normal
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: Bruce Mitchener, Assigned: mjudge)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: waiting for reporter/developer to verify, URL)

(Reporter)

Description

20 years ago
Drag in the PRE area on the given URL.  This happens after the bugs previously
reported that are similar to this one. #3702 and #4254.  Build from March 23,
1999.

UMR: Uninitialized memory read (106 times):
  * This is occurring while in:
        XTextWidth     [TextExt.c]
        gdk_text_width [gdkfont.c:265]
        nsRenderingContextGTK::GetWidth(const char*,unsigned int,int&) [nsRender
ingContextGTK.cpp:872]
        TextFrame::PaintAsciiText(nsIPresContext&,nsIRenderingContext&,nsIStyleC
ontext*,TextFrame::TextStyle&,int,int) [nsTextFrame.cpp:1524]
        TextFrame::Paint(nsIPresContext&,nsIRenderingContext&,const nsRect&,nsFr
amePaintLayer) [nsTextFrame.cpp:544]
        nsContainerFrame::PaintChild(nsIPresContext&,nsIRenderingContext&,const
nsRect&,nsIFrame*,nsFramePaintLayer) [nsContainerFrame.cpp:276]


  * Reading 1 byte from 0xefffd702 on the stack.
  * Address 0xefffd702 is 1970 bytes past start of local variable "rawPaintBufMe
m" in function TextFrame::PaintAsciiText(nsIPresContext&,nsIRenderingContext&,ns
IStyleContext*,TextFrame::TextStyle&,int,int).

Comment 1

20 years ago
fyi, this behavior results in a crash on Linux builds (3/24) and poor highlighting/displaying garbage text on NT and Mac.....
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

19 years ago
*** Bug 4146 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

19 years ago
this works now no crashing only pleasant selecting.  minus the flickering :)

Updated

19 years ago
Whiteboard: waiting for reporter/developer to verify
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

19 years ago
no more UMR.

Comment 5

19 years ago
Per a request from Selection and Search component eng (mjudge) and qa (elig),
moving all "Selection and Search" bugs to new "Selection" component.  Original
"Selection and Search" component will be retired.
You need to log in before you can comment on or make changes to this bug.