Protector Suite QL (<5.8) causes typing three backslashes into the address bar to crash [@ pbgk1_8]

VERIFIED WORKSFORME

Status

()

Firefox
File Handling
VERIFIED WORKSFORME
10 years ago
10 years ago

People

(Reporter: David Schneider, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: FIXED in 5.8 (extension), URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

I have tried reproducing this on two other computers and have failed; but the bug still happens on mine even when all extensions are disabled.
The crash seems to happen after Firefox starts to show a directory listing page for '\'.
The main difference between the computers I have tried it on is that my computer is set up with Japanese locale (it is still the US verison of Windows) and has Japanese set for "language for non-unicode programs"

Reproducible: Always

Steps to Reproduce:
1.Take Firefox at any state
2.Replace the contents of the address bar with three backslashes (\\\)
3.Hit enter.
Actual Results:  
Firefox starts to show a directory listing with page title "Index of file:////" and then crashes.

Expected Results:  
Anything but crashing.

Using the standard theme; extensions all disabled.
Crashed in module: pbgk1_8.dll
Please type about:crashes and post the crash id
(Reporter)

Comment 2

10 years ago
I am unable to access about:crashes--Firefox claims it is not a valid URL...

Comment 3

10 years ago
reporter: please read http://kb.mozillazine.org/Talkback

this is caused by: http://www.upek.com/solutions/psql/default.asp
please file a trouble ticket against them (include this bug's url) and then report your trouble ticket here.
Summary: typing three backslashes into the address bar causes a crash → Protector Suite QL causes typing three backslashes into the address bar to crash [@ pbgk1_8]
(Reporter)

Comment 4

10 years ago
Good call.  I sent a support request.  We'll see what happens...

On a side note it seems the next version of protector suite QL is out; unfortunately Sony hasn't released the version for updating on a VAIO laptop yet.
(Reporter)

Comment 5

10 years ago
Fast response!  Quoted follows:

This is fixed since 5.8 version...

Actually since PS QL 5.8 there was significant change in way how
Password Bank is communicating with Firefox. From this new version of PS
QL it is done by Firefox Add-on, which is also taking care about
upgrades and new versions of Firefox...

I can confirm, that Password Bank in PS QL 5.8 work fine with latest
Firefox 2.0.0.13...

Best Regards,
 
Mirek Buran
UPEK
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

10 years ago
Mirek was kind enough to send me a copy to evaulate, and I can confirm that it is indeed fixed.

Props to the UPEK support team for the quick, precise response!

Updated

10 years ago
Status: RESOLVED → VERIFIED
Summary: Protector Suite QL causes typing three backslashes into the address bar to crash [@ pbgk1_8] → Protector Suite QL (<5.8) causes typing three backslashes into the address bar to crash [@ pbgk1_8]
Whiteboard: FIXED in 5.8 (extension)
no change in the firefox support and sorry, about:crashes is only available for Firefox3 builds. I should read the UA string....... 
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.