Link to Word document on Netcommunity site does not launch Microsoft Word

VERIFIED INVALID

Status

()

VERIFIED INVALID
11 years ago
11 years ago

People

(Reporter: chip_welch, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

Selecting a word document (e.g. Legacy Act Fact sheet on page at http://www.greatlakes.org/NETCOMMUNITY/Page.aspx?pid=336&srcid=335) does not launch Word automatically. Instead, Firefox loses the extension of the file and states it is a "application/octet-stream" and prompts for the application to use to open the file.

Using Internet Explorer instead of Firefox and the document opens the file using  Word automatically.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.greatlakes.org/NETCOMMUNITY/Page.aspx?pid=336&srcid=335
2. Click on Legacy Act Fact Sheet on right side.
3.
Actual Results:  
Firefox loses the extension of the file and states it is a "application/octet-stream" and prompts for the application to use to open the file.

Expected Results:  
File should open Word automatically
from http://web-sbniffer.net :
HTTP Status Code: HTTP/1.1 200 OK
Connection:	close	
Date:	Fri, 28 Mar 2008 06:34:49 GMT	
Server:	Microsoft-IIS/6.0	
X-Powered-By:	ASP.NET	
X-AspNet-Version:	2.0.50727	
title:	Water Quality-Legacy Act Fact Sheet 032608	
content-disposition:	filename=Legacy Act Fact Sheet 032608.doc	
Set-Cookie:	ASP.NET_SessionId=mayjeguiu31eom45vomc0g45; path=/; HttpOnly	
Cache-Control:	private	
Last-Modified:	Thu, 27 Mar 2008 19:03:16 GMT	
Content-Type:	application/octet-stream	
Content-Length:	405504

The file is served as application/octet-stream. Ie doesn't follow the http RFCs and that's the reason why it works in IE.
The file should be served as application/x-msword or something like that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
And that the filename from the content-disposition is cut off at the space is bug 221028 (wontfix).

Comment 3

11 years ago
You'd think a microsoft IIS/ASP.NET server would know how the correct MIME type for msword.  Verified invalid.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.