Makefile.in is missing $(MOZ_JS_LIBS) inside the EXTRA_DSO_LDOPTS

VERIFIED FIXED

Status

SeaMonkey
General
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Yannick Koehler, Assigned: cls)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
There's a missing dependency which make the BeOS fail to compile.  Adding the dependency fix it.

I won't sent a patch for nothing as it's to easy ...

EXTRA_DSO_LDOPTS += $(MOZ_COMPONENT_LIBS) $(MOZ_JS_LIBS)

Just add the $(MOZ_JS_LIBS) has show here...
(Reporter)

Comment 1

18 years ago
Oups!!! quite easy I forgot to mention WHICH makefile to modify...

it's the mozilla/dom/src/jsurl/Makefile.in
(Reporter)

Comment 2

18 years ago
After talking with Leaf that seems to be inside the Dom module and not Build Config related.
Component: Build Config → DOM Viewer
(Reporter)

Comment 3

18 years ago
We had some question about should we put "js" inside the REQUIRES field of the Makefile.in also... Poeple were 
saying that the REQUIRES is now useless and should be stripped from Makefile.in.  So I'll let that up to the 
Assigned person but.. you've been inform ;-)
(Assignee)

Comment 4

18 years ago
Yep, REQUIRES is useless. It made more sense in the classic build where the
include files installed in $(DIST) were split up on a per module basis.
Fix has been checked in.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 5

18 years ago
verified.
Status: RESOLVED → VERIFIED
Obsolete DOM Viewer bugs -> Browser-General; DOM Viewer component is going away.
Component: DOM Viewer → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.