Image Scaled down to custom size takes forever to print in print preview, bogs system down

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: Bob Johnson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

I scaled a large jpeg image (920KB) down to a custom scaling size of 13% in the print preview window.  I adjusted the header and footer and then pressed the print button.  I had numerous other programs open while Firefox 3 was running and I was trying to print the image.
Firefox did not print the image and the computer became extremely sluggish.  The program was spooling to the print queue but the process was very very slow.  After about 5 minutes, I was able to exit Firefox by stopping it with the Windows Task Manager.
I loaded Firefox 2 and repeated the same task with the same custom scaling at 13% and the program printed the image just fine and much quicker than Firefox 3.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.Open a large number of programs.  I had open Firefox 3 with 11 or more tabs, Winamp 5.52, Thunderbird,and a Manufacturing program with 6 modules.
2. Go to http://forums.nicoclub.com/zerothread/232059 and scroll to the middle of the page, you will see three jpeg thumbnail images. Open the first one by double-clicking.
3.The jpeg image will be displayed very large.  Use the print preview and the page setup to scale the image to 13% or lower.
4. Press the print button.  Firefox will thrash the disk and take about 3 to 5 minutes to print the image if it prints at all.
5. My system then becomes very sluggish and I have to use Windows Task Manager to Close Firefox 3.
Actual Results:  
Firefox seemed to lock up and become unresponsive.

Expected Results:  
I expected the program to print the image scaled down properly within a reasonable amount of time like Firefox 2 did.
sounds like a scaling/printing problem from Cairo
Component: General → GFX: Thebes
Product: Firefox → Core
QA Contact: general → thebes
(Reporter)

Comment 2

10 years ago
I just noticed today (4/1) that when the custom scaling gets set in print preview, it apparently applies to all printing from that point forward and normal printing (through the printer button) will be printed using the scaling factor.

In my opinion this should not be so.  The scaled printing should only apply to the one print preview session and then be reset to normal after printing is complete.

Comment 3

9 years ago
This appears to be fixed in Fx 3.0. The print fired off immediately and the system didn't bog down. Please re-open if you're still seeing the problem.

(In reply to comment #2)
> I just noticed today (4/1) that when the custom scaling gets set in print
> preview, it apparently applies to all printing from that point forward and
> normal printing (through the printer button) will be printed using the scaling
> factor.
> 
> In my opinion this should not be so.  The scaled printing should only apply to
> the one print preview session and then be reset to normal after printing is
> complete.


This is still present, you might spin it off. My guess is this is by design to simplify printing of multiple pages with the same settings.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.