Closed Bug 425739 Opened 13 years ago Closed 13 years ago

Space bar action is reversed (scrolls up page)

Categories

(Firefox :: Keyboard Navigation, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: bugzilla, Assigned: karlt)

References

Details

(Keywords: dogfood, regression)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008032804 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008032804 Minefield/3.0pre

The space bar no longer moves the view downward on a page - instead, it moves upward.

Reproducible: Always

Steps to Reproduce:
1. Visit a long page (e.g., http://en.wikipedia.org/wiki/American_Gods ).
2. Use the mouse to move the scrollbar halfway down the page.
3. Press the space bar.
Actual Results:  
The view is moved one screen upward.

Expected Results:  
The view should be moved one screen downward.

pal_moz has identified the regression range:

OK: 20080327_2209_firefox-3.0pre.en-US.win32.zip
NG: 20080327_2351_firefox-3.0pre.en-US.win32.zip 

Present on Vista Home Premium and OS X 10.5.2
Here is the bonsai link for the regression period
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1206680940&maxdate=1206687059
Severity: major → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Mac OS X → All
Hardware: Macintosh → All
Version: unspecified → Trunk
Depends on: 401086
Blocks: 401086
No longer depends on: 401086
Flags: blocking-firefox3?
Keywords: dogfood
Summary: Space bar action is reversed (goes up page) → Space bar action is reversed (scrolls up page)
Duplicate of this bug: 425770
Duplicate of this bug: 425770
I'll back out bug 401086, while I rethink the best way to fix that.
Assignee: nobody → mozbugz
Flags: blocking-firefox3?
We need to have a test for this....
Flags: in-testsuite?
Flags: in-litmus?
Duplicate of this bug: 425843
Duplicate of this bug: 425892
Duplicate of this bug: 425902
Duplicate of this bug: 425938
Created https://litmus.mozilla.org/show_test.cgi?searchType=by_id&id=5228 as litmus testcase.
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.