Closed Bug 42574 Opened 22 years ago Closed 21 years ago

Full-width space in JPN cannot be input at the beginning of a line

Categories

(Core :: DOM: Editor, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED
mozilla0.9.2

People

(Reporter: momoi, Assigned: mozeditor)

References

Details

(Keywords: intl, Whiteboard: [behavior][ws])

** observed with 6/13/2000 Win32 build **

This problem was first observed in a mail composer window
by a Japanese user but the same problem occurs with HTML editor.

When you want to input a full-width (Zenkaku) space in Japanese 
on a new composer document at the beginning of a line, you cannot
do this at all no matter how many times you press the Space.

If you first enter some characters, then you can backtrack and
enter a full-wodth space. Apparently some people do this quite often
in Japanese and it is a very annoying problem.
Changed QA contact to teruko.
QA Contact: sujay → teruko
assigning to Joe for debugging
Assignee: beppe → jfrancis
Target Milestone: --- → M17
interesting.  I dont have this problem on the mac.  It must be windows only.  
This may mean that it is a problem with layout (particularly the win text 
rendering code).  I'll try to get a recent windows build together and check it 
out.
Status: NEW → ASSIGNED
Yes. That seems to be true with Kotoeri. 
Kotoeri does not offer the option to choose
between half-width and full-width spaces in
Japanese. Under Windows IME from MS, there is 
such an option and the problem happens when
the full-width space option is chosen.

I have a different Mac Japanese IME (ATO12) and
there if I turn on half-width option, Mac has
a problem with inputting that without hitting
the space bar twice.
dup of 47015


*** This bug has been marked as a duplicate of 47015 ***
Status: ASSIGNED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
verified in 10/31 build.
Status: RESOLVED → VERIFIED
Sujay, the origanal bug is not fixed, yet.  Did you test 10/31 build to test this?
This bug should not be verified until the bug 47015 is fixed.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 47015 ***
Status: REOPENED → RESOLVED
Closed: 22 years ago22 years ago
Resolution: --- → DUPLICATE
verified in 10/31 build.
Status: RESOLVED → VERIFIED
Sujay, this is not fixed.  Please do not verify this bug.  I am the QA contact.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
I believe I'm going to need some help from Frank or some other windows-savvy ime
engineer on this.  Setting to moz 0.9
Status: REOPENED → ASSIGNED
Target Milestone: M17 → mozilla0.9
Frank is out on sabbatical, please cotact Roy Yokoyama.
mozilla-os2-installer-M18 also have this bug but
mozilla-i386-pcos2-vacpp-2000-11-08 works fine.
Keywords: intl
Changed QA contact to ylong@netscape.com.
QA Contact: teruko → ylong
*** Bug 66110 has been marked as a duplicate of this bug. ***
moving a bunch of 0.9 bugs to 0.9.1
Target Milestone: mozilla0.9 → mozilla0.9.1
Target Milestone: mozilla0.9.1 → mozilla0.9.2
jfrancis: Let me know if you need my help.  
this may be fixed by my patches in 65557. 
nominating for nsbeta1 since there might be a fix for it.
Keywords: nsbeta1
Checked it on 05-21 Win32 trunk:
NT-Ja: still has this problem.  Enable IME-Ja, when try to input a full-width 
space at the beginning of a new line by press "space", the cursor will become a 
very small mark and it will positon at the beginning of line.  This exists in 
both Mail and Composer.
However, it not reproducible on WinME-Ja and Win98-Ja.
Keywords: correctness
Whiteboard: [behavior][ws]
Yuying: can you repeat the test across the different wondows os's and add in
this step:  in the debug menu (use a debug build), choose "Dump Content Tree"
after typing the full-width space.  You will get data in the console window
which represents the content tree for the document.  If you could report back
what that data is, and if it is different on NT-Ja vs. WinME-Ja and Win98-Ja,
that might be very helpful.
This is no longer reproduciabe in Winnt 4.0J, either.  I found the 
half-width problem - bug 83515.
Status: ASSIGNED → RESOLVED
Closed: 22 years ago21 years ago
Resolution: --- → FIXED
Verified as fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.