If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Install two hgweb extensions onto hg.mozilla.org

VERIFIED FIXED

Status

mozilla.org Graveyard
Server Operations
VERIFIED FIXED
10 years ago
3 years ago

People

(Reporter: Benjamin Smedberg, Assigned: aravind)

Tracking

Details

(Reporter)

Description

10 years ago
I have written two extensions, available here:
http://hg.mozilla.org/users/bsmedberg_mozilla.com/hgpoller/
revision d0a8c7314fff

These extensions work with mercurial 1.0 to provide extra information from the hgweb interface. The README file in my repository has information about how to install them.

The feed provided by pushlog-feed will help fix bug 421175 and make the data collected in bug 422758 public.

Updated

10 years ago
Assignee: server-ops → mark

Updated

10 years ago
Assignee: mark → aravind
Blocks: 422754
(Reporter)

Comment 1

10 years ago
I do not think we need to block mozilla-central on this bug. We're collecting the data, and will report it in due course.
No longer blocks: 422754
Will we have any better way to answer the question "Who broke the tree?"?
(Reporter)

Comment 3

10 years ago
Assuming that people don't lie about the username in commit messages, I think we can figure out the relevant data from hg log, in the meantime.

Updated

10 years ago
Blocks: 422754
(Assignee)

Comment 4

10 years ago
upgraded to mercurial 1.0 and added the two extensions to the mozilla-central repo.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

10 years ago
Aravind, the extensions don't appear to be working:

To test pushlog-feed, visit a URL of this form:

http://hg.mozilla.org/mozilla-central/index.cgi/?pushlog
The results should be an Atom feed. For an example of correct functioning, see
http://office.smedbergs.us/hgwebdir.cgi/mozilla-central/pushlog

To test hgwebjson, visit a URL of this form:
http://hg.mozilla.org/mozilla-central/index.cgi/?jsonheads
The results should be a JSON text file. For an example of correct functioning, see
http://benjamin.smedbergs.us/hgwebdir.cgi/mozilla-central/jsonheads
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 6

10 years ago
With the config-file fix this is now working on mozilla-central. Can we either 

1) enable these globally
2) turn these on for the other toplevel repos:

* actionmonkey
* actionmonkey-tamarin
* tamarin-central
* tamarin-tracing
(Assignee)

Comment 7

10 years ago
So, the url you had was wrong.  It should be

http://hg.mozilla.org/mozilla-central/index.cgi/jsonheads
http://hg.mozilla.org/mozilla-central/index.cgi/pushlog

I enabled logging and those extensions globally (for all repos).
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

10 years ago
Woot, thanks.
Status: RESOLVED → VERIFIED
Hey Aravind, did these get turned on for user repos, too? I get an error on this URL:
http://hg.mozilla.org/users/bhearsum_mozilla.com/my-moz-central/index.cgi/pushlog
(Reporter)

Comment 10

10 years ago
The extensions are available, but we're not recording push information for user repos. This is by design: user repos may have multiple heads, and the push logging feature doesn't know how to record anything but a single head.
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.