Closed Bug 425804 Opened 17 years ago Closed 16 years ago

Firefox should have a UI for creating "Smart Bookmarks"

Categories

(Firefox :: Bookmarks & History, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 436380

People

(Reporter: gerbilsrule, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

Currently, in firefox 3, "smart bookmarks" with "place:" queries look just like normal bookmarks, and strange things can happen if a user tries to add new ones.  Firefox should provide users with a UI for managing smart bookmarks.

Reproducible: Always

Steps to Reproduce:
1. Open the bookmarks organizer
2. Click "Smart Bookmarks"
3. Right click in the right side of the window, and click "new bookmark"
Actual Results:  
A standard new bookmark dialog appears.

Expected Results:  
The menu item should say something along the lines of "New Smart Bookmark" and provide a way to create these.
You can create Smart Bookmarks in another way. If you type some search terms in the search field of the Bookmarks Organizer/Library (on top right of the window), a "Save" button will appear to allow you to save the search as a Smart Bookmark.
Then you could move this Smart Bookmark to the "Smart Bookmarks" folder.
Component: Bookmarks → Places
QA Contact: bookmarks → places
Version: unspecified → Trunk
Since "Smark bookmarks" folder doesn't exists any more, and you can save queries as written in Comment #1, I think thi bug can be resolved as INVALID. Can anyone confirm/do this?
In fact the advanced query builder I mentioned in comment 1 was removed (bug 422977). But it will be added back for Firefox 3.1, see bug 436380.
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → INVALID
not invalid: a dupe
Resolution: INVALID → DUPLICATE
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.