OS statistics should not be case-sensitive; multiple stats shown for each OS

RESOLVED DUPLICATE of bug 418969

Status

addons.mozilla.org Graveyard
Statistics
RESOLVED DUPLICATE of bug 418969
10 years ago
2 years ago

People

(Reporter: Dave Garrett, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080208 Mandriva/2.0.0.12-1.1mdv2008.0 (2008.0) Firefox/2.0.0.12
Build Identifier: 

In the operating system statistics, the first 6 possible entries are: WINNT, Linux, Darwin, winnt, darwin, linux.  (and automatic selections of graphs pick all 6)  Clients that return lowercase OS names should be included with the normal stats for that OS.  More to the point, all possible names for a particular OS should be included together and given a more user-friendly name.  WINNT should be shown as Windows NT/XP; Darwin should be shown as MacOSX; Linux and linux-gnu should both show simply as Linux.

Additionally, you might want to add entries for combined stats such as BSD (to include FreeBSD, OpenBSD, NetBSD, SunOS, etc.), *NIX (to include all Linux + BSD), and other (to include OS2, AIX, IRIX64, and any other minority OSes).

Reproducible: Always
(Reporter)

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 418969
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.