All users were logged out of Bugzilla on October 13th, 2018

Spacebar causes page to scroll up instead of down

VERIFIED DUPLICATE of bug 425739

Status

()

VERIFIED DUPLICATE of bug 425739
11 years ago
11 years ago

People

(Reporter: nate.prziborowski, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008032804 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008032804 Minefield/3.0pre

If the focus is on a page (not an object, like a textarea) and spacebar is pressed, the page scrolls up.
I realize that shift+spacebar is supposed to do this, but now both scroll up a page.

Reproducible: Always

Steps to Reproduce:
1. Load a web page that is more than a page and scroll down some
2. Press the space bar

Actual Results:  
Page is scrolled up

Expected Results:  
Page is scrolled down

It might be specific to the mac, but I have no confirmed that.

about:buildconfig

Build platform
target
powerpc-apple-darwin8.8.4

Build tools
Compiler 	Version 	Compiler flags
gcc-4.0 -arch ppc 	gcc version 4.0.1 (Apple Computer, Inc. build 5250) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -W -Wno-long-long -g -gfull -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fno-strict-aliasing -fpascal-strings -fno-common -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon
g++-4.0 -arch ppc 	gcc version 4.0.1 (Apple Computer, Inc. build 5250) 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-long-long -g -gfull -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fno-strict-aliasing -fpascal-strings -fno-common -fshort-wchar -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon

Configure arguments
--target=powerpc-apple-darwin8.8.4 --with-macos-sdk=/Developer/SDKs/MacOSX10.4u.sdk --enable-application=browser --enable-update-channel=nightly --enable-optimize --disable-debug --disable-tests --enable-update-packaging --enable-prebinding --enable-codesighs
Build platform
target
i386-apple-darwin8.8.4

Build tools
Compiler 	Version 	Compiler flags
gcc-4.0 -arch i386 	gcc version 4.0.1 (Apple Computer, Inc. build 5250) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -W -Wno-long-long -g -gfull -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fno-strict-aliasing -fpascal-strings -fno-common -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon
g++-4.0 -arch i386 	gcc version 4.0.1 (Apple Computer, Inc. build 5250) 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-long-long -g -gfull -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fno-strict-aliasing -fpascal-strings -fno-common -fshort-wchar -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon

Configure arguments
--target=i386-apple-darwin8.8.4 --with-macos-sdk=/Developer/SDKs/MacOSX10.4u.sdk --enable-application=browser --enable-update-channel=nightly --enable-optimize --disable-debug --disable-tests --enable-update-packaging --enable-codesighs
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 425739

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.