Download dialog should tell download file size

VERIFIED DUPLICATE of bug 328954

Status

()

Toolkit
Downloads API
--
enhancement
VERIFIED DUPLICATE of bug 328954
10 years ago
9 years ago

People

(Reporter: Jonathan, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME?)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; zh-TW; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; zh-TW; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4

When a download is about to start, a dialog box will popup asking you to open or save. The dialog box should also tell the user what size the file is.

Reproducible: Always

Steps to Reproduce:
1. Download something, a dialog box will pop up.
Actual Results:  
Download as normal.

Expected Results:  
It should have a line saying the size of the file to be downloaded.

It would be great if Firefox can state the download file size. Yes, some downloads are "hidden" an it won't let the browser know what the file size is, but like Opera it displays the file size about to be downloaded.

Comment 1

10 years ago
I like that idea, makes a lot of sense. Hopefully we'll see a general overhaul in the download manager to make it more useful for Firefox 4 (I have real reservations about the Firefox 3 one).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk

Updated

10 years ago
Whiteboard: DUPEME?
:) Good prediction Damian

This is worth looking at for a "revolution" of the download manager on 4, or future version sof 3.

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 328954
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.