Unicode 3.0 is not supported.

RESOLVED INVALID

Status

()

Core
Internationalization
P3
minor
RESOLVED INVALID
18 years ago
13 years ago

People

(Reporter: TAKAHASHI Makoto, Assigned: Jungshik Shin)

Tracking

({intl})

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Characters added in Unicode 3.0 are converted to "?".
Such as U+02EA, U+02EB, U+02EC, U+02ED, U+02EE, U+0343, U+0346...

For details, see

http://www.unicode.org/unicode/standard/versions/Unicode3.0.html

Comment 1

18 years ago
We weren't sure if this was i18n or parser. But it's real.
Status: UNCONFIRMED → NEW
Component: Browser-General → Parser
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Updated

18 years ago
Blocks: 21359

Comment 2

18 years ago
setting default owner
Assignee: asa → rickg
QA Contact: doronr → janc

Comment 3

18 years ago
Likely an i18n issue -- off to Frank for triage.
Assignee: rickg → ftang

Comment 4

18 years ago
we do support all Unicode 3.0 if a font contains such glyph are present in the 
system. Do you have a font which contains those glyph installed in your system ? 
Have you try the Office 2000 MS Arial Unicode font ?
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Component: Parser → Internationalization
Resolution: --- → INVALID

Comment 5

18 years ago
2000061720win32 windows2000.
I'm reopenning. IE5 on windows2000 renders more characters than we do in parts 
(the Combining Diacritical Marks, MS Font, MingLiU, Tahoma, Verdana, Arial).

--asside:
Please excuse my ignorance, I only have windows 2000 which shipped after office 
2000, and i get things like {blue}o{black}? and {blue}o in the 
Unicode?Combining Diacritical Marks section.
My fonts are versioned 2.76 arial and times have 1296glyphs and are internally 
dated 10/15/1999. -- I'd appreciate it if someone would note similar 
information from their MSOffice2000 fonts.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 6

18 years ago
I think the issue is the font do not have the combining glyph itself but have 
pre composed glyph with the base characters. Window rendering issue. Reassign to 
erik.
Assignee: ftang → erik
Status: REOPENED → NEW
(Reporter)

Comment 7

18 years ago
MS UI Gothic font of Windows 2000 has more glyphs than MS Arial Unicode font
of Office 2000. But both fonts did not have glyph of characters added in Unicode
3.0 such as U+02EA, U+02EB, U+02EC, U+02ED, U+02EE, U+0343, U+0346.

Problem is that these characters are not displayed as white box but displayed as
"?".

If Mozilla recognizes these character then these characters must be displayed as
white box.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 8

17 years ago
>If Mozilla recognizes these character then these characters MUST be displayed as
white box.
Why ?

Comment 9

17 years ago
adding intl keyword.

Ftang - Is this of any importance for nsbeta1 or standards compliance?
Keywords: intl

Comment 10

17 years ago
not my area, passing off to bindu 
(hi bindu!)
QA Contact: janc → bsharma

Comment 11

17 years ago
>> If Mozilla recognizes these character then these characters MUST be 
>> displayed as white box.

> Why ?

Frank, I thought we make a distinction between the case where a glyph cannot
be found in a font and the case in which a code point was not found.
I had thought that the question mark was used for the latter case only.

Comment 12

17 years ago
erik resign. reassign all his bug to ftang for now.
Assignee: erik → ftang
Status: ASSIGNED → NEW

Comment 13

17 years ago
mark all future new as assigned after move from erik to ftang
Status: NEW → ASSIGNED

Comment 14

13 years ago
what a hack. I have not touch mozilla code for 2 years. I didn't read these bugs
for 2 years. And they are still there. Just close them as won't fix to clean up.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago13 years ago
Resolution: --- → WONTFIX

Comment 15

13 years ago
Mass Re-assigning bugs that Frank Tang Closed on March 1st Spam is his fault

Mass Re-Open to follow
Assignee: ftang → nobody

Comment 16

13 years ago
Mass Bug Re-Open of bugs Frank Tang Closed with no good reason. Spam is his
fault not my own
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 17

13 years ago
Reassigning Franks old bugs to Jungshik Shin for triage - Sorry for spam
Assignee: nobody → jshin1987
Status: REOPENED → NEW

Comment 18

13 years ago
Showing the character as a question mark is mozilla's way of handling character
that can not be found in any font, as the reporter describe. IE display a white
box (with a dark line around the box) but mozilla never does that (except when
there *is* a white box glyph inside the font).

This method of showing character that can not be found is not great, and is
contrary to what is recommened by unicode (which is to use a round box,
optionally with a content inside the box that identifies the code range of the
character), but this is another bug. I remember this was opened already
somewhere (as use last resort font to display unfound glyph).
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.