Recent update of Halloween theme causes slow(er) scrolling; May be concurrent with install of FF 2.0.0.13

RESOLVED INCOMPLETE

Status

()

Core
General
--
minor
RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: Craig "Hob" Wear, Unassigned)

Tracking

({perf})

1.8 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

System:  Mac iBook OSX 10.2.5(Jaquar), tweaked/built to 10.2.8.  100 G external drive runs co-ordinated with on-board processor(Mac Classic (9.+)

Software:  Mac; Standard/baseline shipped

Browser:  Firefox 2.0.0.13 w/ extensions
    Theme:  Halloween

Issue:  I noticed I drop-off in smooth scrolling shortly after updates for both FF and Halloween extension.  Checked and re-checked system preferences settings for errors--none detected.

While still a relative novice, I know many people are light-decades beyond me(see Build Indentifier above).  I work here every day, so I tend to notice changes. As to all that code-thingy, um, well,... you know.  I'm like a chimp with a broken crayon trying to type Shakespeare on a Royal in the rain on a Sunday afternoon. 

Baseline:  It's different somehow--slower/'jerky.'  If I noticed, those smarter than me probably did as well.

Thanks.  Love your work(s).


Reproducible: Always

Steps to Reproduce:
1. Call up IMDb
2. Attempt to scroll to bottom of page via touchpad/mouse.("Apple" key + "pg dn" key hesitates, but DOES leap to bottom).
3. Clear all caches; re-start Firefox; See Step 1.
4. Loop.
5. Re-start iBook.
6. See Steps 1 through 3
7. Check System Preferences; Check Firefox Preferences.
8. Settings okay; abherent behavior still detected.
8a. Complete shut down.  One hour away.  Re-boot.
8b. See Steps 1 through 8. 
9. Contact Mozilla/Bugzilla; cite issue(s).
10. Wait.
11. All issues resolved in next up-date install.
12. Send 'thank you.'
Actual Results:  
None as yet.  Issue still unresolved.

Expected Results:  
Smooth scrolling, no hesitation in 'slide-bar.'

No crash;  all other software and sub-systems are nominal, i.e. 'five by five, and a mile wide.'  Completely satisfied with EVERY Mozilla construct,  but the scrolling issue is system/software universal. Oop.  Nope.  Haven't checked  off-line word-processing.  May only be Internet propriatery.  Will check and report later.

Comment 1

10 years ago
This is a bit worrisome, because the change to Halloween involved bringing xul scrollbars to OSX. If this is not going to work for OSX and fx2, then I will revert the changes for my themes.

The changes that were made were based on changes to the Firefox 3 beta 5: both OSX and Win/*NIX sue xul scrollbars. But I thought this was possible due to changes in OSX. 

Does anyone know the answer? OSX change or fx3 change?

This bug is important because if there is a similar performance hit in fx3, we might have a problem with more than my themes.

Comment 2

10 years ago
A user with a Mac tested Halloween 2.6 on fx 2.0.0.13. She found problems with the xul scrollbars on digg.com. The xul scrollbars work fine with 3b5 and digg.com.

I will update Halloween to be compatible with both fx2 and fx3.

Updated

9 years ago
Component: Theme → General
Product: Firefox → Core
QA Contact: theme → general

Comment 3

8 years ago
craig, ed, do you still see this in v3? If not, please close the bug with resolution set to WORKSFORME
Keywords: perf
Whiteboard: closeme 2010-04-28
Version: unspecified → 1.8 Branch

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Whiteboard: closeme 2010-04-28

Updated

8 years ago
Resolution: FIXED → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.