Bottom 5 rows of pixels in Find Bar's textbox only updated if mouse if over

RESOLVED DUPLICATE of bug 412646

Status

()

Toolkit
Find Toolbar
RESOLVED DUPLICATE of bug 412646
10 years ago
9 years ago

People

(Reporter: Dan Weiss, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008032904 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008032904 Minefield/3.0pre

The find bar leaves trails of garbage pixels underneath any typed text.  The height of the garbage pixels is 2 rows of pixels.  The garbage pixels are 3 pixels from the bottom of the find bar's textbox.
The blinking cursor, and any letter with a descender also leaves a trail.


Reproducible: Always

Steps to Reproduce:
1. Type something in the find bar
2. Select the text
3. Click on the main browser window
Actual Results:  
You get two rows of pixels at the bottom of the text showing the prior selection box, then the rest of the text box is correct.
If you mouseover the textbox in the find bar, the textbox finally refreshes and shows the correct image.

Expected Results:  
There should be no trails, or garbage left in the textbox.  This is a regression from past versions where there was no garbage in the find textbox.

Comment 1

10 years ago
This is probably the same as bug 412646.
Depends on: 412646

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 412646
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.