"Bittorrent Plugin 1" breaks Acid2 and Acid3 (no mimetype)

RESOLVED WONTFIX

Status

()

Core
Plug-ins
--
major
RESOLVED WONTFIX
10 years ago
a year ago

People

(Reporter: Kai de Leeuw, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008032904 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008032904 Minefield/3.0pre

With the above nightly the acid2 test fails with the eyes not being seen. A friend of mine tells me that with the same build on Mac the acid2 test succeeds, but I can't check this for myself.

Reproducible: Always

Steps to Reproduce:
1. Go to the url

Actual Results:  
No eyes.

Expected Results:  
Eyes.
(Reporter)

Comment 1

10 years ago
Created attachment 312576 [details]
screenshot of the error
wfm with Gecko/2008032900 SeaMonkey/2.0a1pre
Component: General → General
Product: Firefox → Core
QA Contact: general → general
(Reporter)

Comment 3

10 years ago
works in the build from March 28 for me, but in the build from 29 it does not.

Comment 4

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008032904 Minefield/3.0pre

WFM
(Reporter)

Comment 5

10 years ago
OK, two WFM. Doesn't matter, I still have the problem. Clean profile, safe mode.
wfm also in the tinderbox build :
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008033000 Minefield/3.0pre

Comment 7

10 years ago
I notice that the eyes are served from http://www.damowmow.com/ Can you reach that?
(Reporter)

Comment 8

10 years ago
yes I can.

Comment 9

10 years ago
What build you are using? Because i tested with zip build.

Comment 10

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008033004 Minefield/3.0pre

Have you tried the test from the original location?
http://www.webstandards.org/files/acid2/test.html

(WFM on both the URL submitted with this bug and the URL I provided)
(Reporter)

Comment 11

10 years ago
It still doesn't work in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008033105 Minefield/3.0pre.

I have no explanation to why this can happen. I have the same build at work and there I see the eyes.
(Reporter)

Comment 12

10 years ago
After some more research, I have narrowed it down to that disabling the plugin "Bittorrent Plugin 1" fixes the problem.

Comment 13

10 years ago
Acid 2 rules:

"Note: When taking the test, you should use the default settings of the browser you are testing. Changing the zoom level, minimum font size, applying a fit-to-width algorithm, or making other changes may alter the rendition of the Acid2 page without this constituting a failure in compliance."
(Reporter)

Comment 14

10 years ago
Ok, more info. I have discovered that builds after March 28 finds more plugins than the build of March 28. It finds this "Bittorrent Plugin 1" which in some way is a faulty plugin that screws up the acid tests.
Summary: Acid2 fails, eyes not seen → Firefox as of March 29 and later finds more plugins than before and one of the "new" plugin screws up both acid tests
(Reporter)

Updated

10 years ago
Duplicate of this bug: 426028

Comment 16

10 years ago
What MIME types are listed for that plugin in About:plugins?  There are three nested objects in the Acid test with these MIME types: 
application/x-unknown
text/html
image/png
The png is the one with the eyes.  
(Reporter)

Comment 17

10 years ago
None it seems. It looks like this:

BitTorrent

    File name: npbittorrent.dll
    BitTorrent Plugin 1

MIME Type Description  Suffixes Enabled
          npbittorrent          Yes
(Reporter)

Comment 18

10 years ago
Plugins aren't stored per profile, they are stored globally per browser install. Seems like my default install directory for trunk builds contained this plugin, but not the one from 28. Why it started to screw up all of a sudden seems to have no connection to build dates. I must have installed/uninstalled something that made this change.

--> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Comment 19

10 years ago
But that plugin not having any MIME types may be a problem.  It could be overriding the default plugin so one of the outer objects in the test is being used and sent to that plugin instead of using the PNG object.  Perhaps that overriding of the default plugin needs to be prevented.  It could be similar to Bug 132430.  
Component: General → Plug-ins
Version: unspecified → Trunk
(Reporter)

Comment 20

10 years ago
OK. I reopen this bug. Changing summary to reflect the latest findings.

Comment #17 gives a good example of what causes the problem.

Let me just say that the "RealJukebox NS Plugin" has "none" in the column of MIME Type, and not empty string like for "BitTorrent Plugin 1", so it may be related to bug 132430, but not entirelly.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: Firefox as of March 29 and later finds more plugins than before and one of the "new" plugin screws up both acid tests → Plugin with no mimetype screws both acid2 and acid3 up

Updated

10 years ago
Duplicate of this bug: 440613

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Blocks: 289480, 410460

Comment 22

10 years ago
(In reply to comment #21)
> *** Bug 440613 has been marked as a duplicate of this bug. ***
> 

Why did you confirm this?

Comment 23

10 years ago
(In reply to comment #22)
> (In reply to comment #21)
> > *** Bug 440613 has been marked as a duplicate of this bug. ***
> > 
> 
> Why did you confirm this?

Installing "Bittorrent Plugin 1" breaks Acid2 and Acid3; disabling it fixes things.  That's easily reproducible and the core bug here, however the current title makes a leap as to the root cause.

Comment 24

10 years ago
(In reply to comment #23)
> Installing "Bittorrent Plugin 1" breaks Acid2 and Acid3; disabling it fixes
> things.  That's easily reproducible and the core bug here, however the current
> title makes a leap as to the root cause.

Google for ["Bittorrent Plugin 1"] first returns SuMo threads.  Further narrowing it down, for ["Bittorrent Plugin 1" site:support.mozilla.org {acid|acid2|acid3}] brings the results to 9 sumo threads, all of which seem to say that removing Bittorrent Plugin 1 fixes their problems.

Can you provide a link to where someone can download "Bittorrent Plugin 1"

Comment 25

10 years ago
http://www.bittorrent.com/download?csrc=splash
(only tested the Windows version thus far)

Comment 26

10 years ago
To reproduce, only npbittorrent.dll is needed.  However, I don't know of any place to download just the DLL.  My testing was in a WinXPsp3 VirtualBox with Firefox 3.0.

For the time being, I'll rename this to be more accurate until someone can confirm the exact cause here.

In the end this may just be a TE bug and BitTorrent Inc. would need to correct the plugin.
Summary: Plugin with no mimetype screws both acid2 and acid3 up → "Bittorrent Plugin 1" breaks Acid2 and Acid3 (no mimetype)

Comment 27

10 years ago
(In reply to comment #26)
> To reproduce, only npbittorrent.dll is needed.
>
> In the end this may just be a TE bug and BitTorrent Inc. would need to correct
> the plugin.

Consider contacting them.  They actually have an article on the DLL: http://tinyurl.com/5epf2f

Comment 28

10 years ago
Comparing Acid3 with and without this plugin enabled, I get this error added:

Test 69 failed: timeout -- could be a networking issue

And this one is changed:

Normal:   Test 79 failed: expected '34' but got '33'
                          - SVGSVGTextElement.getNumberOfChars() incorrect
Enabled:  Test 79 failed: doc is null

Total time also goes up from 2.75s to 7.50s.

To be clear, this is with the npbittorrent.dll that is automatically installed with BitTorrent (Mainline) 6.0.3 on Windows XP SP3.  There does not appear to be a non-Windows version available for v6.

Comment 29

10 years ago
(In reply to comment #26)
> To reproduce, only npbittorrent.dll is needed.  However, I don't know of any
> place to download just the DLL.

I made a link to my homepage where you can download just the .dll file.
Version: 1.0.0.1 Size: 53,3KB Date: 12/09/2008 05:23:59 -
http://www.whitewolfstudios.net/firefox/npbittorrent.dll

I got it from http://www.softwareheadlines.com/modules/planet/view.article.php/219802    and file: Bittorrent 6.1.exe
**The newer "6.1 Beta Build 4459"  contains the same file as version 6.1.
QA Contact: general → plugins

Comment 30

8 years ago
Should this really block the Acid bugs, considering this seems to be a problem with an addon, which is something we can't do much about our selfs?

Comment 31

8 years ago
If the issue is due to a plugin/extension, I don't think this should block the Acid bugs. Could anyone motivate why, or remove them from the acid-blocking bugs list?

Comment 32

8 years ago
There's no reason the plugin should be loaded in this instance, thus I'd consider this a bug in handling the plugin rather than the plugin itself. No matter what the plugin does it shouldn't be breaking this.

Comment 33

8 years ago
I'm pleased with that explanation, thanks.

Comment 34

8 years ago
Just retested this under Firefox 3.6 and Trunk to see if anything changed. Comment 28 still applies, however in addition there's a new Acid3 failure with the plugin enabled:

Test 74 failed: contentDocument failed for <object> referencing an svg document.

Acid2 breaks as before, with a red stripe showing.

Note that while I'm saying that there's enough here to consider this to likely be a valid bug on Mozilla's end, no one who knows enough about the plugin handling here has investigated what's going on to say for sure.

The guess seems to be that because there's no mimetype listed it ends up getting loaded for <object>s it shouldn't. The implication would be that any plugin that has done this or possibly something similar could muck up unrelated embeded plugins in some way.

This bug has been sitting here without further investigation for a couple of years now. Anyone know who would be good to CC on this who would be able to make some progress here?

Comment 35

8 years ago
This bug is low priority and is probably not going to be fixed unless someone who's interested in it steps forward.

Comment 36

8 years ago
Reported the bug on their forums:
http://forum.utorrent.com/viewtopic.php?id=85014

Comment 37

7 years ago
Removing Acid blocker status.  While there's probably a legitimate bug here relating to how we deal with plugins with blank MIME types, it is not actually blocking Acid compliance, because Acid is supposed to be run without extra plugins installed.

Someone should probably follow-up on the link in Comment 36; there was a reply there asking for more information.
No longer blocks: 289480, 410460
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: NEW → RESOLVED
Last Resolved: 10 years agoa year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.