Closed Bug 426046 Opened 12 years ago Closed 11 years ago

"About" dialog: add full BuildID, as in Firefox

Categories

(Thunderbird :: General, enhancement, P3)

enhancement

Tracking

(Not tracked)

VERIFIED FIXED
Thunderbird 3

People

(Reporter: sgautherie, Assigned: standard8)

References

Details

(Whiteboard: [workarounds see comment #9])

Attachments

(4 files, 2 obsolete files)

[Mozilla Thunderbird, version 3.0a1pre (2008032702)] (nightly) (W2Ksp4)

The application name is an image,
the (copyable) details are limited to "version 3.0a1pre (2008032702)".

See
<http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/mail/base/content/aboutDialog.xul&rev=1.23&mark=69-70,116-117#67>

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b5pre) Gecko/2008032605 Minefield/3.0b5pre] (nightly) (W2Ksp4)

The application name is an image, the short version isn't selectable/copyable,
but the full BuildID is present (too) and copyable (as in the <about:> page).

See
<http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/browser/base/content/aboutDialog.xul&rev=1.30&mark=75,79#70>

Could TB have this too/instead ?
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 230182
(In reply to comment #1)
> *** This bug has been marked as a duplicate of bug 230182 ***

I disagree: the two issues are actually unrelated.
Reopening: see bug 230182 comment 37 for details.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Duplicate of this bug: 311519
Duplicate of this bug: 325146
In the future, do not close an older bug as a duplicate of an equivalent newer bug.  The older bug should be kept open as an indicator of how long the problem has been reported.  If the older bug does not completely describe the problem, update it.  
(In reply to comment #5)
> do not close an older bug as a duplicate of an equivalent newer bug.

I did not close these 2 bugs: they were already R.Duplicate...
Not sure if it's the right thing to do, but if something has to be done, it should be done for Thunderbird 3.

Nominating blocking-thunderbird3.
Flags: blocking-thunderbird3?
Duplicate of this bug: 431329
WORKAROUND 1: install the MR-Tech Local Install extension. Then you get (among many other goodies) a "Tools -> Copy User Agent / Build ID" menu which copies the data this bug wants to the clipboard: full UA and/or datestamp, as in

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.15pre) Gecko/20080505 Thunderbird/2.0.0.15pre - Build ID: 2008050504

WORKAROUND 2: set your Mail Start Page to "about:" in the "General" Preferences. Then "Go -> Mail Start Page" (which, however, works only if the preview pane is open _and_ the mailer is online, even for a local page) will display an "about:" page whose last line is (for instance in the same build as above)

Build identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.15pre) Gecko/2008050504 Thunderbird/2.0.0.15pre

The full UA can then be copied for pasting elsewhere.
Whiteboard: [workarounds see comment #9]
P.S. I showed the workarounds for a branch build but of course, at least the 2nd one works also on trunk (the 1st one might too depending on extension compatibility).
P.P.S. Oops: on the trunk, I think workaround 2 assumes fixing bug 424767
(In reply to comment #9)
> WORKAROUND 1: install the MR-Tech Local Install extension.> 
> WORKAROUND 2: set your Mail Start Page to "about:" in the "General"
> Preferences.

Yes they are workarounds, but they are both things we shouldn't expect a normal
user reporting a bug to do. They should just be able to go to one dialog to get
the required data without changing/installing anything extra.
(In reply to comment #12)
> (In reply to comment #9)
> > WORKAROUND 1: install the MR-Tech Local Install extension.> 
> > WORKAROUND 2: set your Mail Start Page to "about:" in the "General"
> > Preferences.
> 
> Yes they are workarounds, but they are both things we shouldn't expect a normal
> user reporting a bug to do. They should just be able to go to one dialog to get
> the required data without changing/installing anything extra.
> 

I know, that's why I call them "workarounds" (and I'll admit, if you want, that they're rather clumsy), but I certainly don't call them "fixes".

Oh, and BTW, on builds where "about:" gives an XML parsing error there is an even clumsier workaround: use chrome://global/content/about.xhtml instead.
Duplicate of this bug: 437592
this seems like low hanging fruit with possible upside for bug reports.
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Attached patch Possible fix (obsolete) — Splinter Review
I'm still testing this, but it should be pretty much there. This synchronises to be very similar to the Firefox dialog, with the current exception of the Distribution items.

Possibly still needs a few tweaks to layout, but the content and general is pretty much what I think we need now.
Assignee: nobody → bugzilla
Status: REOPENED → ASSIGNED
Blocks: 373345
Priority: -- → P3
is there any downside to doing this?  
(I don't know of any, but I don't see that it's been asked)
Or doc changes needed?

xref Bug 443729 – need accessible Thunderbird buildid (or alternative) for litmus test
(In reply to comment #17)
> is there any downside to doing this?  
> (I don't know of any, but I don't see that it's been asked)
> Or doc changes needed?

I can't see any negative downside to this, the only thing would be a little more space used up on that dialog.

The dialog still gives the same information, with a little more. The benefits to bug reporting are big - we'll get the platform and language on top of just the build id that we get now.
Blocks: 443729
Attached patch The fix (obsolete) — Splinter Review
I've played around with the original version a bit, and aligned the text better and reduced the gap between Mozilla Thunderbird and the version string.

I'll attach Mac & Linux screenshots in a moment (sorry, I haven't got windows ones, maybe someone can attach one for me).
Attachment #330493 - Attachment is obsolete: true
Attachment #330544 - Flags: ui-review?(clarkbw)
Attachment #330544 - Flags: review?(philringnalda)
Attached image Linux About Dialog
Attached image Mac about dialog
Comment on attachment 330544 [details] [diff] [review]
The fix

Phil's away apparently.
Attachment #330544 - Flags: review?(philringnalda) → review?(mkmelin+mozilla)
Comment on attachment 330544 [details] [diff] [review]
The fix

>+  width: 298px;

Any reason to cut it from 299px? (Though it does seem an odd number.)

>+        aboutlabel="&aboutLink.label;" aboutaccesskey="&aboutLink.accesskey;" versionlabel="&aboutVersion;"> 

Please line these up one per row, and versionlabel should be removed altoghther - looks like some old garbage. Remove the trailing space.

>-      <vbox id="versionWrapper" flex="1" pack="center">
>-        <textbox id="versionField" readonly="true" class="plain" tabindex="2"
>-#expand value="&aboutVersion; __MOZ_APP_VERSION__"/>
>-            </vbox>
>-      <description id="copyright">&copyrightText;</description>
>-      <separator/>
>+        <label id="versionField" value="&aboutVersion; 3.0a2pre"/>

Seems a step backward. I don't think we want to hard code the version.

I do like the looks of the dialog though!
Attachment #330544 - Flags: review?(mkmelin+mozilla) → review-
(In reply to comment #23)
> (From update of attachment 330544 [details] [diff] [review])
> >+  width: 298px;
> 
> Any reason to cut it from 299px? (Though it does seem an odd number.)

Yes, sorry I should have explained that. If you take a look at the current dialog, you'll notice there is a one-pixel white line down the right hand side. Hence the slight reduction.

> >+        aboutlabel="&aboutLink.label;" aboutaccesskey="&aboutLink.accesskey;" versionlabel="&aboutVersion;"> 
> 
> Please line these up one per row, and versionlabel should be removed altoghther
> - looks like some old garbage. Remove the trailing space.

I'm fairly sure I had problems removing this, but I think that may have been due to trying to remove the aboutVersion at the same time.

I'll look at wrapping these onto new lines, where they go over approx eighty columns, but I don't like maintaining one-per line unnecessarily, that's just a waste of space IMHO (which probably means I need to clean up some of the others as well).

> >-      <vbox id="versionWrapper" flex="1" pack="center">
> >-        <textbox id="versionField" readonly="true" class="plain" tabindex="2"
> >-#expand value="&aboutVersion; __MOZ_APP_VERSION__"/>
> >-            </vbox>
> >-      <description id="copyright">&copyrightText;</description>
> >-      <separator/>
> >+        <label id="versionField" value="&aboutVersion; 3.0a2pre"/>
> 
> Seems a step backward. I don't think we want to hard code the version.

My mistake, caused by deleting a patch and then recovering from an object directory.
Attached patch The fix v2Splinter Review
This patch addresses Magnus' comments. I've done what I think looks best for the attributes on the dialog, see what you think.
Attachment #330544 - Attachment is obsolete: true
Attachment #330609 - Flags: ui-review?(clarkbw)
Attachment #330609 - Flags: review?(mkmelin+mozilla)
Attachment #330544 - Flags: ui-review?(clarkbw)
Comment on attachment 330609 [details] [diff] [review]
The fix v2

based on the screenshots this looks good to me
Attachment #330609 - Flags: ui-review?(clarkbw) → ui-review+
Comment on attachment 330609 [details] [diff] [review]
The fix v2

Yup, labels and accesskeys go hand in hand anyway. r=mkmelin
Attachment #330609 - Flags: review?(mkmelin+mozilla) → review+
Patch checked in -> Fixed.
Target Milestone: --- → Thunderbird 3
Status: ASSIGNED → RESOLVED
Closed: 12 years ago11 years ago
Resolution: --- → FIXED
Attached image Windows about dialog
(In reply to comment #19)
> (sorry, I haven't got windows ones, maybe someone can attach one for me).

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.2pre) Gecko/2008072203 Shredder/3.0a2pre] (nightly) (W2Ksp4)

V.Fixed
Status: RESOLVED → VERIFIED
Flags: in-litmus-
Blocks: 448246
Duplicate of this bug: 458267
You need to log in before you can comment on or make changes to this bug.