always crash on startup, even in safe mode

RESOLVED DUPLICATE of bug 423226

Status

()

Firefox
Installer
--
critical
RESOLVED DUPLICATE of bug 423226
10 years ago
10 years ago

People

(Reporter: trondsg+bugzilla+mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Opera/9.26 (Windows NT 5.1; U; en)
Build Identifier: http://pv-mirror02.mozilla.org/pub/mozilla.org/firefox/releases/2.0.0.13/win32/nb-NO/Firefox%20Setup%202.0.0.13.exe

A fresh install of Firefox downloaded from above refuses to start without crashing. Also in safe mode.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox

Actual Results:  
Firefox crashes

Expected Results:  
Firefox should not crash

TB43320693Q, TB43320095K, TB43319394K, TB43319257H, TB43318312W

OS: Windows XP Pro SP 3.
(Reporter)

Comment 1

10 years ago
Ok, you have serious problems there because it can't find the incidents in the database...

Here is some crash info from inspector (it crashes even if inspector is disabled, so that's not the reason).
firefox.exe       1.8.1.13: 2008031114 caused exception C0000005 at address 6039FC51 (Base: 400000)

Registers:
EAX=00000001   EBX=00000000   ECX=0012F95C   EDX=0000000D   ESI=0277349C
EDI=01642610   EBP=00000191   ESP=00000199   EIP=00000000 FLAGS=00000287
CS=001B   DS=0023   SS=0023   ES=0023   FS=003B   GS=0000
FPU stack:
4006FF80000000000000 3FFF8000000000000000 3FFF8000000000000000
00000000000000000000 FFFF000000FE00FE00FE FFFF000000D800D800D8
FFFF0000000000000000 FFFF00FFFFFF00FFFFFF SW=0020 CW=027F

Stack dump:

Used DLLs:
ntdll.dll         5.1.2600.3311 (xpsp.080212-0005)              Base: 7C900000
KERNEL32.dll      5.1.2600.3311 (xpsp.080212-0005)              Base: 7C800000
js3250.dll        4.0                                           Base: 600D0000
nspr4.dll         4.6.8                                         Base: 601A0000
ADVAPI32.dll      5.1.2600.3311 (xpsp.080212-0010)              Base: 77DD0000
RPCRT4.dll        5.1.2600.3311 (xpsp.080212-0003)              Base: 77E70000
Secur32.dll       5.1.2600.3311 (xpsp.080212-0010)              Base: 77FE0000
WSOCK32.dll       5.1.2600.3311 (xpsp.080211-1047)              Base: 71AD0000
WS2_32.dll        5.1.2600.3311 (xpsp.080211-1047)              Base: 71AB0000
msvcrt.dll        7.0.2600.3311 (xpsp.080212-0005)              Base: 77C10000
WS2HELP.dll       5.1.2600.3311 (xpsp.080211-1047)              Base: 71AA0000
WINMM.dll         5.1.2600.3311 (xpsp.080211-1045)              Base: 76B40000
GDI32.dll         5.1.2600.3311 (xpsp.080212-0004)              Base: 77F10000
USER32.dll        5.1.2600.3311 (xpsp.080212-0004)              Base: 7E410000
xpcom_core.dll    1.8.1.13: 2008031114                          Base: 60360000
plc4.dll          4.6.8                                         Base: 60280000
plds4.dll         4.6.8                                         Base: 60290000
SHELL32.dll       6.00.2900.3311 (xpsp.080212-0004)             Base: 7C9C0000
SHLWAPI.dll       6.00.2900.3311 (xpsp.080212-0004)             Base: 77F60000
ole32.dll         5.1.2600.3311 (xpsp.080212-0003)              Base: 774E0000
VERSION.dll       5.1.2600.3311 (xpsp.080212-0004)              Base: 77C00000
smime3.dll        3.11.5 Basic ECC                              Base: 602B0000
nss3.dll          3.11.5 Basic ECC                              Base: 601D0000
softokn3.dll      3.11.4 Basic ECC                              Base: 602D0000
ssl3.dll          3.11.5 Basic ECC                              Base: 60310000
xpcom_compat.dll  1.8.1.13: 2008031114                          Base: 60340000
comdlg32.dll      6.00.2900.3311 (xpsp.080212-0004)             Base: 763B0000
COMCTL32.dll      6.0 (xpsp.080212-0004)                        Base: 773D0000
OLEAUT32.dll      5.1.2600.3311                                 Base: 77120000
WINSPOOL.DRV      5.1.2600.3311 (xpsp.080211-1047)              Base: 73000000
IMM32.dll         5.1.2600.3311 (xpsp.080212-0004)              Base: 76390000
LPK.dll           5.1.2600.3311 (xpsp.080212-0004)              Base: 629C0000
USP10.dll         1.0420.2600.3311 (xpsp.080212-0004)           Base: 74D90000
SERWVDRV.dll      5.1.2600.0 (xpclient.010817-1148)             Base: 5CD70000
umdmxfrm.dll      5.1.2600.0 (xpclient.010817-1148)             Base: 5B0A0000
MSCTF.dll         5.1.2600.3311 (xpsp.080212-0004)              Base: 74720000
TabHook.dll       4.56-6                                        Base: 10000000
msctfime.ime      5.1.2600.3311 (xpsp.080212-0004)              Base: 755C0000
SETUPAPI.dll      5.1.2600.3311 (xpsp.080212-0005)              Base: 77920000
CLBCatQ.DLL       2001.12.4414.700                              Base: 76FD0000
COMRes.dll        2001.12.4414.700                              Base: 77050000
browserdirprovider.dll1.9b3                                     Base:  15D0000
xpcom.dll         1.8.1.13: 2008031114                          Base: 60330000
brwsrcmp.dll      1.9b3                                         Base:  1600000
jar50.dll         1.8.1.13: 2008031114                          Base: 60010000
jsd3250.dll       1.8.1.13: 2008031114                          Base: 60030000
myspell.dll       1.8.1.13: 2008031114                          Base: 60040000
spellchk.dll      1.8.1.13: 2008031114                          Base: 60050000
xpinstal.dll      1.8.1.13: 2008031114                          Base: 60060000
MSWSOCK.dll       5.1.2600.3311 (xpsp.080211-1047)              Base: 71A50000
HNetCfg.dll       5.1.2600.3311 (xpsp.080211-1047)              Base: 662B0000
WSHTCPIP.dll      5.1.2600.3311 (xpsp.080211-1047)              Base: 71A90000
iphlpapi.dll      5.1.2600.3311 (xpsp.080211-1047)              Base: 76D60000
                                                                Base:  1A80000
fullsoft.dll      2.2.unofficial                                Base:  1AA0000
qfaservices.dll   1.8.1.11: 2007112718                          Base:  1AD0000
DNSAPI.dll        5.1.2600.3311 (xpsp.080212-0010)              Base: 76F20000
WINRNR.dll        5.1.2600.3311 (xpsp.080212-0010)              Base: 76FB0000
WLDAP32.dll       5.1.2600.3311 (xpsp.080212-0010)              Base: 76F60000
msimtf.dll        5.1.2600.3311 (xpsp.080212-0004)              Base: 746F0000
xpsp2res.dll      5.1.2600.3311 (xpsp.080212-0010)              Base:  2180000
UxTheme.dll       6.00.2900.3311 (xpsp.080212-0004)             Base: 5AD70000
freebl3.dll       3.11.4 Basic ECC                              Base: 60090000
nssckbi.dll       1.65                                          Base: 60230000
rasadhlp.dll      5.1.2600.3311 (xpsp.080211-1047)              Base: 76FC0000
MSIMG32.dll       5.1.2600.3311 (xpsp.080212-0004)              Base: 76380000
DBGHELP.dll       5.1.2600.3311 (xpsp.080212-0004)              Base: 59A60000

Comment 2

10 years ago
The next incident id in the queue is 43316869 and was submitted on 2008-03-31 09:51:26.0.
   DB error looking for Incident ID: 43320693 patience please
Are you sure you installed in an empty direvtory ?
Did you try a new profile ?
Do you use some kind of firewall on your system ?


nsACString_internal::Assign  [mozilla/xpcom/string/src/nsTAString.cpp, line 231]
nsHttpChannel::GetResponseHeader  [mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 3711]
brwsrcmp.dll + 0xde8f (0x0160de8f)
brwsrcmp.dll + 0xe4c9 (0x0160e4c9)
CallTypeSniffers  [mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 698]
CallPeekFunc  [mozilla/netwerk/base/src/nsInputStreamPump.cpp, line 128]
nsInputStreamPump::PeekStream  [mozilla/netwerk/base/src/nsInputStreamPump.cpp, line 140]
nsHttpChannel::CallOnStartRequest  [mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 752]
nsHttpChannel::ProcessNormal  [mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 924]
nsHttpChannel::ProcessResponse  [mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 846]

Comment 4

10 years ago
brwsrcmp.dll      1.9b3                                         Base:  1600000

that's from the wrong firefox (i.e. this is anything but fresh). please explain *exactly* how you did your install. was there something installed there before hand?
Component: Startup and Profile System → Installer

Updated

10 years ago
QA Contact: startup → installer
(Reporter)

Comment 5

10 years ago
> Are you sure you installed in an empty direvtory ?
I can't be absolutely sure, but Firefox has not been installed on this computer after I reformatted and re-installed Windows. (I am sure of that.) Also I'm sure I've never created the directory manually.
I have had QTrax installed, but it's uninstalled now.

> Did you try a new profile ?
If I rename C:\Documents and Settings\Trond\Application Data\Mozilla\Firefox then it crashes again, but this time without even showing the main window, and TalkBack doesn't appear (!). An empty Firefox directory is recreated. If I start Firefox then it still crashes.
Message: firefox.exe       1.8.1.13: 2008031114 caused exception C0000005 at address 603617D4 (Base: 400000)

If I put back the old Firefox directory it's back to the old behaviour.
Message: firefox.exe       1.8.1.13: 2008031114 caused exception C0000005 at address 6039FC51 (Base: 400000)

If I rename just C:\Documents and Settings\Trond\Application Data\Mozilla\Firefox\Profiles\zdgjmveg.default I get this message: "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system." Firefox.exe is not running.

There's also a profile folder inside C:\Documents and Settings\Trond\Local Settings\Application Data\Mozilla\Firefox (note the "Local Settings"). Deleting it seems to have effect on the problem, it's simply recreated.

> Do you use some kind of firewall on your system ?
No.


>brwsrcmp.dll      1.9b3                                         Base:  1600000
>that's from the wrong firefox (i.e. this is anything but fresh). please explain
>*exactly* how you did your install. was there something installed there before
>hand?
That's strange. I simply downloaded the file mentioned above, installed a custom install with the default options ("c:\Program Files\Mozilla Firefox 3 Beta 3", DOM inspection, Error reporting).
Before I had Opera 9.26, Opera 9.5 beta, Safari 3.1, Swift and IE installed, but that shouldn't matter. I think I might have had QTrax installed (it's a ripped-off version of Songbird). Also I have LastFM installed. Both of these use Gecko I think.

I tried to install it in a different directory, in that case that file doesn't even get installed. That install even runs correctly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 423226
You need to log in before you can comment on or make changes to this bug.