Last Comment Bug 426228 - attachment failure with gcc-4.3
: attachment failure with gcc-4.3
Status: RESOLVED WORKSFORME
:
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: 2.0
: x86 Linux
: -- normal with 5 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 435331 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 11:49 PDT by Jürgen Löb
Modified: 2008-06-20 09:39 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Jürgen Löb 2008-03-31 11:49:22 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.8.1.13) Gecko/20080331 Firefox/2.0.0.13
Build Identifier: Mozilla Thunderbird Version 2.0.0.12 (20080331)

Hi,

I noticed that my Thunderbird (x86_64) does not display many attachments (i.e. all pdf attachments) properly when compiled with gcc-4.3.

When the mail arrives the paperclip icon is being displayed in the list. After I click onto the the mail to get it displayed in the preview area the paperclip disapears and no attachment is being shown. The problem also exists for old mails.

The attachment afterwards is still existent on the mail server (I use IMAP). Using mozilla-thunderbird-bin-2.0.0.12 (binary version from gentoo) everything can be displayed properly.

I already tried to create a new profile and to recompile thunderbird with minimal CFLAGS and LDFLAGS, but the problem was still there.

I recently recompiled my system (gentoo) with gcc 4.3, thus as a last step I recompiled with gcc-4.2.3 and everything works as ususal.

Reproducible: Always

Steps to Reproduce:
1.build thunderbird with gcc-4.3
2.try to read mails with attachment
Comment 1 Mikko C. 2008-04-10 12:42:30 PDT
I can confirm this bug with Thunderbird 2.0.0.13 compiled with gcc-4.3.0 on x86_64.
Comment 2 Magnus Melin 2008-04-16 02:57:56 PDT
Have you tested building cvs HEAD?
Comment 3 Jacek Sieka 2008-04-29 02:16:36 PDT
I can confirm this too, gcc 4.3.0, thunderbird 2.0.0.12, x86_64, but with pop accounts. I haven't tested HEAD (don't have time for that right now - maybe I'll try in the weekend)
Comment 4 Mikko C. 2008-05-02 08:25:08 PDT
The problem is still present in the new version of Thunderbird: 2.0.0.14.
I can confirm that both POP and IMAPs accounts have this bug.


Comment 5 Jürgen Löb 2008-05-07 15:11:47 PDT
Can confirm that the problem persists in 2.0.0.14.
Comment 6 Magnus Melin 2008-05-08 00:55:28 PDT
Confirming based on the comments of multiple people. Can someone try HEAD too?
Comment 7 Jan de Groot 2008-05-22 14:02:18 PDT
Not an issue anymore here: after removing almost all patches we have applied on archlinux, this issue wasn't fixed yet. After unsetting CFLAGS and CXXFLAGS and removing the --enable-optimize=$CFLAGS thing from .mozconfig, thunderbird works reliable and no longer has problems with attachments when compiled with gcc 4.3.
Comment 8 Alex Kotov 2008-05-24 10:25:36 PDT
*** Bug 435331 has been marked as a duplicate of this bug. ***
Comment 9 Alex Kotov 2008-05-24 10:28:53 PDT
Hit the same problem with Thunderbird 2.0.0.12 and 2.0.0.14 x86_64/linux and gcc 4.3.0.
Comment 10 Doug Goldstein 2008-06-03 08:04:52 PDT
Gentoo users confirm this issue as well, along with the hack of --disable-optimize fixing the issue.

http://bugs.gentoo.org/show_bug.cgi?id=223375
Comment 11 Jürgen Löb 2008-06-20 09:39:49 PDT
Works for me with gcc-4.3.1

Note You need to log in before you can comment on or make changes to this bug.