If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Difficulty in picking files from file navigation dialog, and difficulty in clicking on OK and CANCEL buttons in that dialog box.

RESOLVED WORKSFORME

Status

()

Core
Widget: Cocoa
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Mike Clark, Assigned: Josh Aas)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b4) Gecko/2008030317 Firefox/3.0b4

File navigation-related dialog boxes seem to have an issue where there is a difficulty in selecting a file from a navigation list, and regardless of whether a file is chosen or not, in clicking on either the Cancel or OK buttons in that dialog box. I am aware of this issue having affected me starting sometime within the last several GranParadiso nightlies leading up to the latest release of the Firefox beta (b4) and seem to be present in the current b4 release.

At present, my G4-based iMac is running Mac OS X Tiger 10.4.11. Even going so far as to erase and reinstall Mac OS X 10.4 (and naturally do Apple's system updates) has not resolved this issue. Also interestingly, no version thus far of Firefox 2.x seem to suffer from this difficulty.

Reproducible: Always

Steps to Reproduce:
1. Go to a web site where it is possible to upload a file from your local system.
2. Click on the web page button which initiates a file navigation session and dialog box generation.
3. Navigate through the directory structure; attempt to click on a file; attempt to click on either the OK or Cancel buttons.
Actual Results:  
It takes a while and a number of attempts for the dialog interface to finally respond to the user's actions. It eventually does work.

Expected Results:  
The user should be able to click on any file they want anywhere within the accessible file directory structure, and have the dialog box confirm that the file the user clicked on is now selected. Clicking on the Cancel button, or the OK button if a file has been chosen, should produce the expected result.
Confirming because I've seen this behaviour before (Leopard, Intel Mac) but I can't reproduce it at the moment.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
I recall seeing Bug 420967, which seems to be similar to what Mike describes but has been fixed. I also filed Bug 419668 for issues I was encountering with flash based uploaders, but that bug has also been fixed, but I think that fix went in after the B4 build. It would be good if Mike could try the latest nightly trunk or the upcoming B5 and confirm he sees the same issues.
Assignee: nobody → joshmoz
Component: OS Integration → Widget: Cocoa
Product: Firefox → Core
QA Contact: os.integration → cocoa
(Reporter)

Comment 3

10 years ago
Marcia: Ok, just pulled down the 2008033104 build and *poof* no more bug. I've tried it on all the places I was having trouble before, and everything works perfectly now. Based on this revelation, it should be obvious why _you_ folks are software developers and I am *not*... ;)  Thanks again, folks, I apologize for the inconvenience....

P.S.: Who closes this bug report out? I'll be happy to clean up after myself, but I don't know what your procedures are, and don't want to disrupt them. Please advise... mikethec@gmail.com ... thanks!
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.