Drag and drop into bookmarks menu makes it expand into infinity

RESOLVED FIXED in Firefox 3

Status

()

RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: mads.ohm, Assigned: jdarmochwal)

Tracking

({polish, regression})

Trunk
Firefox 3
x86
Linux
polish, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008031317 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008031317 Firefox/3.0b4

When I drag a something into the bookmark menu, and hover on top of the last element, the list expands into infinity, with only grey.

Reproducible: Always

Steps to Reproduce:
1. Drag a link into the bookmark menu
2. Hover on top of the last element
3. Watch it expand
Actual Results:  
The menu expanded into infinity

Expected Results:  
Maybe only expanded so that there was room for the link
Component: Bookmarks → Places
QA Contact: bookmarks → places
Summary: Drag and droping links into bookmarks make the toolbar expand into infinity → Drag and dropping links into bookmarks make the toolbar expand into infinity
Version: unspecified → Trunk
(Assignee)

Comment 1

11 years ago
I can confirm this with current Linux trunk build. Can't find a dupe.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

11 years ago
The bug was introduced between 2008022004 and 2008022104, probably by the patch for bug 389290.
(Assignee)

Updated

11 years ago
Blocks: 389290
(Assignee)

Comment 3

11 years ago
Created attachment 314574 [details] [diff] [review]
fix indicator-bar offset
Attachment #314574 - Flags: review?(mano)

Comment 4

11 years ago
mh, why do you want to remove that? it's needed to calculate the eventual space taken by the scrollbox arrows, if you remove it on a long (scrolling) bookmarks menu the dropmarker will be wrong. at least you should provide an alternative way...

Comment 5

11 years ago
Created attachment 314581 [details] [diff] [review]
patch

could you try if this solves the problem for you on Linux?
(Assignee)

Comment 6

11 years ago
Comment on attachment 314574 [details] [diff] [review]
fix indicator-bar offset

(In reply to comment #4)

OK, removing the lines is wrong as well.
Attachment #314574 - Attachment is obsolete: true
Attachment #314574 - Flags: review?(mano)

Updated

11 years ago
Summary: Drag and dropping links into bookmarks make the toolbar expand into infinity → Drag and dropping links into bookmarks make the bookmarks menu expand into infinity

Updated

11 years ago
Summary: Drag and dropping links into bookmarks make the bookmarks menu expand into infinity → Drag and drop into bookmarks menu makes it expand into infinity
(Assignee)

Comment 7

11 years ago
(In reply to comment #5)

> could you try if this solves the problem for you on Linux?

That fixes the bug, but the indicator-bar is 3px to high when scrollbuttons are visible (scrollButton.boxObject.height == 7, actual height of the scrollbutton is 10px).
Summary: Drag and drop into bookmarks menu makes it expand into infinity → Drag and dropping links into bookmarks make the toolbar expand into infinity
(Assignee)

Updated

11 years ago
Summary: Drag and dropping links into bookmarks make the toolbar expand into infinity → Drag and drop into bookmarks menu makes it expand into infinity
(Assignee)

Comment 8

11 years ago
How about this (seems to works fine here):

           // set the new marginTop based on arrowscrollbox
-          newMarginTop += scrollBoxObject.y - this.boxObject.y;
+          newMarginTop += scrollBoxObject.y - this._scrollBox.boxObject.y;

Comment 9

11 years ago
no, scrollBoxObject == this._scrollBox.boxObject
(Assignee)

Comment 10

11 years ago
(In reply to comment #9)
> no, scrollBoxObject == this._scrollBox.boxObject

      scrollBoxObject == this._scrollBox.scrollBoxObject
you're right and that works, if the problem is solved on Linux with that, prepare a patch and ask review to mano@mozilla.com

Thank you
(Assignee)

Comment 12

11 years ago
Created attachment 314844 [details] [diff] [review]
really fix indicator-bar offset
Attachment #314581 - Attachment is obsolete: true
Attachment #314844 - Flags: review?(mano)

Updated

11 years ago
Keywords: polish, regression

Updated

11 years ago
Assignee: nobody → jdarmochwal
Comment on attachment 314844 [details] [diff] [review]
really fix indicator-bar offset

r=mano
Attachment #314844 - Flags: review?(mano) → review+
Comment on attachment 314844 [details] [diff] [review]
really fix indicator-bar offset

drivers: a fix for a bad behaviour in Linux, tested on Windows too
Attachment #314844 - Flags: approval1.9?
Comment on attachment 314844 [details] [diff] [review]
really fix indicator-bar offset

a1.9=beltzner
Attachment #314844 - Flags: approval1.9? → approval1.9+
(Assignee)

Updated

11 years ago
Keywords: checkin-needed
mozilla/browser/components/places/content/menu.xml 	1.129 
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.