firefox 3 font appearance problem

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
10 years ago
3 years ago

People

(Reporter: leranix, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4) Gecko/2008030714 Firefox/3.0b4

see: http://i31.tinypic.com/35kjzue.jpg
it should be a english site but as you see fonts (maybe encoding) are nonreadable.
i tried so much to solve the font appearance problem but i couldn't.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

10 years ago
Check View->Character_Encoding to see what encoding it is set. I'm using Auto-Detect/Universal without any problems. You might have accidentally set it to something else (you can force it to a different encoding), or the automatic encoding has made a mistake. Note that the automatic encoding depends on the actual content, so it might disappear again.
(Reporter)

Comment 2

10 years ago
hmm, default encoding was Unicode (UTF-8) but for tests i changed it to almost all of them and problem exists as previous. Auto-Detect is same as Unicode (UTF-8)
wfm with Firefox 3b4 and SM trunk.
Did you try a shift+reload ?

Comment 4

10 years ago
I think this is Bug 396315.  Can you report back when beta 5 is released on whether you still see the problem?  

Comment 5

10 years ago
I'm using beta 5, and while the situation with corrupted font rendering has improved from beta 4 (was horrible then), the problem persists. I run in to sites with problems abt. 3 times per day.
See for example this page:
http://today.java.net/pub/a/today/2006/11/07/nuances-of-java-5-for-each-loop.html
Or the attached file.

I'm using Windows XP SP2 and my encoding is unchanged. (That is, automatic: Universal, UTF8)

Comment 6

10 years ago
Created attachment 316770 [details]
Firefox 3 Beta 5 font problem.

Comment 7

10 years ago
Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008042904 Minefield/3.0pre

recommend change to NEW

Updated

10 years ago
Component: General → GFX: Thebes
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk

Updated

10 years ago
Keywords: qawanted

Comment 8

10 years ago
First we need to figure out how to reproduce it.  The parts of the page that are rendering incorrectly in the screenshot in comment #6 have a font-family set to Monaco, Courier, "Courier New".  With the fonts I have installed I don't see the problem.  
OS: Windows XP → All
Summary: firefox 3 beta4 font appearance problem → firefox 3 font appearance problem

Comment 9

10 years ago
Update: It seems that my problem with font rendering has disappeared in RC1. Not sure whether its completely gone, but I haven't noticed any problems up until now.

Comment 10

10 years ago
Is there any problem left with Firefox 3 final?

Comment 11

10 years ago
The font rendering / encoding problem persists with Firefox 3.0.1  on Windows XP SP3. As others have mentioned this before: 
http://support.mozilla.com/tiki-view_forum_thread.php?locale=no&comments_parentId=48889&forumId=1

For example, at http://fluxbb.org the FF3 renders the link text as jumbled characters:
 <p id="sitelogo"><a href="http://fluxbb.org">Flux<span>BB</span></a></p>
  
This problem disappears when changing the value of a property in the style sheet such as eliminating helvetica from the font-family or switching the selector id to class.

Comment 12

8 years ago
do you still see this problem?

I don't see any jumbled characters at http://fluxbb.org/ but the page may have changed. Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a3pre) Gecko/20100306 Minefield/3.7a3pre

Comment 13

8 years ago
With my current Firefox 3.5.8, I'm not seeing the problem anymore on the above mentioned sites.

Comment 14

8 years ago
re: jumbled characters

Font problems persist with Firefox 3.6 and Helvetica. Possible cause may be corrupt font(s). (Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.21022).

Firefox 3.6 - Renders illegible, encoding instead of Helvetica
Safari 4.0.4 (531.21.10) - Substitutes Helvetica with Arial
Opera 10.50 (3296) - Renders Helvetica
IE 8.07600.16385 - Renders Helvetica

Other user feedback:
http://getsatisfaction.com/mozilla/topics/firefox_3_displays_illegible_fonts
WFM: 
Mac OS X nightly
Built from http://hg.mozilla.org/mozilla-central/rev/0664108eb19d

Win XP :
http://hg.mozilla.org/mozilla-central/rev/f262c389193e

Please reopen if you see this issue still occuring.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Issue is Resolved - removing QA-Wanted Keywords - QA-Wanted query clean-up task
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.