KB article: Bookmark problems in Firefox 3 beta

VERIFIED INVALID

Status

--
major
VERIFIED INVALID
11 years ago
9 years ago

People

(Reporter: djst, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
We need an article that explains about stuff that can only be fixed by removing files in the profile folder. Specifically, there are a few bugs that can only be fixed by removing the places.sqlite file from the profile; upgrading to the latest beta isn't enough. 

There might be other things that would fit into this article too. Article title is just a suggestion.

See bug 421483 and bug 404658.
Lets add all these bugs to the dependency list so we can track them easier.
Depends on: 404658, 420520, 421483

Comment 2

11 years ago
Generally troubleshooting articles are named after the symptom, not the solution. Users are using search terms that match the symptoms because they don't yet know the solution.

So there shouldn't be one article "Things that can be fixed by removing files in the profile folder". Rather, there should be multiple articles (or edits to existing articles), one per symptom.
(Reporter)

Comment 3

11 years ago
How about  Bookmark problems in Firefox 3 beta? That's what it is. Not convinced creating separate articles for all of the issues is a good approach; feels a little redundant. Thoughts?
Yes, it should be one article which will cover each of the mentioned problems. The fix is simply the same. My thoughts would be something like: "Information for Beta users upgrading to final release". That will cover most of all possible issues. We could even run into something different than places...

Comment 5

11 years ago
Why do we need an article for this, rather than putting it in the beta/RC release notes?
support.mozilla.com should only be for end-user releases.
(Reporter)

Comment 6

11 years ago
Because people are searching for Firefox 3 info on our site, which means non-end-users are our target too. This is a special case because fx3 is becoming popular and increasing its user base.
Summary: KB article: Firefox 3 beta testing info → KB article: Bookmark problems in Firefox 3 beta
Marco, how many of these bugs we could fix for existing profiles with your patch on bug 425161? Perhaps this page is not needed anymore?
Depends on: 413483

Comment 8

11 years ago
bug 404658 had added readonly to all bookmarks. actually not still fixed so i don't know if final will be, but should be ok after left pane replace

bug 413483 will be fixed (sorted by default)

bug 421483 will clearly not be solved, since beta users will always need to delete Smart bookmarks folder manually

bug 420520 will be totally correct now with tag containers patch, so after left pane upgrade we should not have any problem.

So the only thing remaining by now is removing old Smart Bookmarks folder
Depends on: 412682
Depends on: 412692

Comment 9

11 years ago
i can confirm that we should be in a good shape, apart the manual removal of Smart Bookmarks folder... so probably this page is not a first priority actually
Marco, these are fantastic news! Thanks for the information. David, I think in that case we don't really need this page anymore. The remaining problem doesn't limit the functionality of Firefox for users who ran the beta version.
(Reporter)

Comment 11

11 years ago
Great news! Thanks for the update Marco.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Depends on: 421974

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.