no way to specify the download path when downloading files to open with a helper app




Downloads API
10 years ago
10 years ago


(Reporter: Mason, Unassigned)


Firefox Tracking Flags

(Not tracked)


(Whiteboard: DUPEME, URL)



10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv: Gecko/20080311 Firefox/
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv: Gecko/20080311 Firefox/

Sorry if this bug is a duplicate.  I know I've seen a bug report for this problem, but I could not find it with searches and I think it may have been marked as "resolved" because a fix used to exist, but that fix longer works in 10.5.

Basically, the issue is that Firefox has no way of specifying the download path to use when choosing to open files with a helper app.  I don't know the specifics, but I am given to understand that FF uses a global preference from the Mac OS internet framework.  

The default for this preference in 10.4 and 10.5 is ~/Desktop.  This leads to a very annoying behavior: when I click a PDF file and have it open with Preview, I get a PDF file saved to my desktop.  This leads to clutter.  

There used to be a fairly easy way to change this preference.  Safari 2 used to change this preference when one specified a default download path in Safari 2's preferences, and changing the Safari preference would implicitly change the Firefox preference.

This solution was always a bad one.  First, it is unintuitive to use Safari to alter a Firefox behavior.  Second, it defies one of the great commandments of programming, which is program modularly (i.e., Firefox's behavior should not be dependent upon Safari).  Third, it broke Safari downloading, because I would have to specify /tmp/ in Safari in order to get what I feel is the appropriate Firefox behavior, and so Safari would download everything to /tmp/.

Now 10.5 has come out, and with it Safari 3.  Safari 3 breaks the old method of changing the helper app path.  When a user changes the default download path in Safari 3, the global preference that Firefox looks at no longer changes.  Instead, Safari 3 now changes a preference file in ~/Library.

Thus, in 10.5, there is no way to change the helper app path.  The Safari hack doesn't work in Safari 3. 

However, if you had 10.4, and had changed the path using Safari 2, when you upgraded to 10.5, that preference file was no overwritten.  Thus there are many on 10.5 systems who had previously changed the path, and the fix has remained in 10.5.  But this option is not available to new users or clean installs.

Reproducible: Always

Steps to Reproduce:
1. I installed 10.5.2 from scratch and loaded FF onto it.  
2. I used Preview to open a PDF.  It saved the file to my desktop.  
3. I opened Safari 3, and changed the download directory to /tmp/.  
4. I tried to open another PDF from Firefox.  It saved another icon to my desktop.
5.  I used my 10.4.9 system discs to "archive and install", which reverted my test system to 10.4.9, and Safari 3 to Safari 2.  
6. I tried to open a PDF from FF, and got another icon on the desktop.
7. I opened Safari 2 and changed the download path to /tmp/.
8. I opened another PDF from FF, and this time it saved it to /tmp/.
9. I inserted my Leopard discs and upgraded my system to 10.5.  
10. I opened another PDF from Firefox in 10.5.  It still saved to /tmp/.

Expected Results:  
FF should allow me to specify the path for helper apps, just like it lets me specify the download path.  As long as the helper app path defaults to the download path, it solves all the problems.  It allows users like me to specify /tmp/ for helper apps, and novice users are not at risk of data loss unless they specifically change the path.  It will not break when Safari 4 comes out, and it doesn't require me digging through my Applications folder and dusting off the quixotic Safari application to change a Firefox preference.


10 years ago
Whiteboard: DUPEME
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 374184

Comment 2

10 years ago
Verifying, and the bug you were thinking that had been 'fixed' but not for leopard is bug 302433.


10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.