Closed Bug 426358 Opened 17 years ago Closed 17 years ago

Firefox doesn't know Rhythmbox can handle itms protocol links

Categories

(Firefox :: File Handling, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 388701

People

(Reporter: mcepl, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en; rv:1.9pre) Gecko Fedora/2.22.0-2.fc9 Epiphany/2.22
Build Identifier: firefox-3.0-0.50.cvs20080327.fc9.i386

(originally filed as https://bugzilla.redhat.com/show_bug.cgi?id=439646)

One of the big new features in Rhythmbox is that it can handle itunes podcast
feeds using the itms protocol. It even installs a firefox plugin in the default
install to better handle this ('iTunes Application Detector').

This apparently works fine in Epiphany since rhythmbox is associated with
/desktop/gnome/url-handlers/itms. However, clicking an example itms link such as
http://phobos.apple.com/WebObjects/MZStore.woa/wa/viewPodcast?id=207870198 in
firefox asks for an application since firefox is not aware of this. Users should
not manually have to know to navigate to /usr/bin/rhythmbox

----

My comment to this would be that apparently firefox when it doesn't know about a protocol/data-format just gives up. Firefox should instead (when it cannot help itself) look for platform resources (Gnome GIO-VFS) to find out whether there is there a way how to handle the resource.

Reproducible: Always

Steps to Reproduce:
1.see above
2.
3.
Actual Results:  
Firefox asks what to do with (for example) itms:// resource

Expected Results:  
It should let Gnome gio subsystem (or Gnome VFS on older platforms) take care of the resource
I want to dupe to bug 352089 and broaden it's scope but I'd prefer to dupe it back to here and just broaden the scope of this bug, which is (at it's core) that url handlers for the OS and for Fx aren't the same (on linux, I _think_ they are on windows/mac).

For now, leaving UNCO.
One more example -- https://bugzilla.redhat.com/show_bug.cgi?id=439647 -- the same problem, but with the extended verison of this bug.
Matej: That's bug 389766 actually
Marking dupe, this has been fixed in trunk and I'm thinking that the user probably isn't as up to date.
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
I've encountered this bug with Firefox 3.0b4 on Ubuntu 8.04 as well as Firefox 3.0 (a nightly somewhere between b4 and b5) on Fedora 9.
(In reply to comment #5)
You still seeing this?
You need to log in before you can comment on or make changes to this bug.