Closed Bug 426365 Opened 12 years ago Closed 10 years ago

Firefox does not have any menu button to choose between alternative XSLT stylesheets.

Categories

(Core :: XSLT, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 126841

People

(Reporter: lim.fung.chai, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: 

The xml file contains 4 PI, one of which is
    <?xml-stylesheet type="text/xsl" title="text" href="stylesheets/text.xsl"?>
while the other 3 are of the form
    <?xml-stylesheet type="text/xsl" alternate="yes" title="Scott Lindhurst's icons" href="stylesheets/scott.xsl"?>

These 4 PI conform to http://www.w3.org/TR/xml-stylesheet/ (Associating Style Sheets with XML documents Version 1.0) specification.  However Firefox does not provide any menu button to choose between the 4 XSLT stylesheets (although the "View -> Page Style" menu button can be used to choose between alternative CSS stylesheets).

The Firefox browser should provide a menu button for this purpose.

FYI.  Background to the xml file: The xml file contains some puzzles for the Sokoban puzzle games.  The puzzle data use text symbols such as # for wall, and @ for the player.  The idea is to use XSLT stylesheets to render the puzzles in various ways.  The default stylesheet shows the puzzles in a textual style, while the other 3 stylesheets render the puzzles graphically using 3 sets of icon images.  The menu button would allow the user to choose between the 4 styles.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
I have a work-around at http://web.singnet.com.sg/%7Efclim/sbml/sasquatchv-4css.xml whose (single) XSLT stylesheet tranforms the xml data into html which contains references to 4 CSS stylesheets.  You can choose between the 4 alternative CSS stylesheets with the "View - Page Style" menu button.

The enhancement request is to provide a menu button to choose between alternative XSLT stylesheets.  Please note that when the user selects a different XSLT stylesheet, the list of choices in "View - Page Style" may change depending on the chosen XSLT stylesheet.
This is a duplicate of 126841.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 126841
You need to log in before you can comment on or make changes to this bug.