five-to-six second delay which occurs when re-deleting and undeleted mail.

RESOLVED INCOMPLETE

Status

Thunderbird
General
RESOLVED INCOMPLETE
10 years ago
10 years ago

People

(Reporter: John, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
Build Identifier: version 2.0.0.6 

A five-to-six second delay occurred after re-deleting and undeleted mail. 

I searched for large attachments and found some residing in a subscribed public folder, but unsubscribing the user had no immediate effect.

I tried moving the ImapMail/ folder to the side as ImapMail/.old. 

Also tried moving the whole .thunderbird folder to .old.

Although this may appear as a minor problem, if you have hundreds of emails it takes a toll. The quick fix is to simply restart but it's not practical.

Any ideas?   Thank you



Reproducible: Always

Steps to Reproduce:
1.Delete an email (Accidental delete)
2.undo the Delete  (Also tried CNTL+Z) 
3.Delete again     (Good delete)
4. View or delete additional email from list. (5-6sec processing delay/email)

Actual Results:  
A five-to-six second delay will occur for any follwing deletion. The only fix for now is to restart the application.


Expected Results:  
Delete the email and not affect following deletions or mail viewing.

Comment 1

10 years ago
If you are just looking for ideas, then this is the wrong place.  Start from: http://www.mozilla.org/support/thunderbird/

One idea would be to try the current release, 2.0.0.12, but I think a problem in your profile or on your server is a more likely cause.

It works for me with no delay using imap.fastmail.net and Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008040103 Thunderbird/3.0a1pre

Comment 2

10 years ago
maybe related bug 393123

Comment 3

10 years ago
John, are you seeing high CPU? (bug 393123 -> bug 296453)
and on a newer release?

(using windows) I don't see what you describe. But I do see cases where inline images don't display in a message C after prior message B is deleted before all of B's inline attachments has displayed - which I think would be a dupe of another bug, probably imap.

Comment 4

10 years ago
hmm, no response
=> incomplete (but likely invalid)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.