FF doubling padding on div element

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Ricardo Tomasi, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: padding rendering, URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

I'm using an unordered list with image replacement inside a wrapper DIV, and another DIV below. When I set a top margin of 10px it works as expected, but if I set a padding of 12px FF applies a 12px padding to the bottom also, even if using padding-bottom:0 or -12px. Using XHTML 1.0 Transitional in standards mode, both HTML and CSS validate. The padding is added to the wrapper DIV, it has a 35px height before padding and reports as 59px after setting top padding to 12px. Checked the image replacement (negative text indent), surrounding elements, zeroed margins and padding, with no results. IE 6 and 7 and Opera 9.1 render it ok.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Firefox version 2.0.0.13, Windows XP.

found this:
http://bytes.com/forum/thread99565.html
http://www.sitepoint.com/forums/showthread.php?t=507238
Please provide a testcase and do you get the same problem with Firefox 3b4 or later builds ?
(Reporter)

Comment 2

10 years ago
Right, I reduced it to a test case and put it online:

http://ff6600.org/moz/teste.htm

I'm also including a screenshot of how FF is rendering it at ff6600.org/moz/padding_bug.gif

I can't install any other version (at work).

thanks for helping
Whiteboard: padding rendering
Version: unspecified → 2.0 Branch
Created attachment 313195 [details]
This is a screenshot from a current trunk build (in this case Seamonkey)
looks like this is already fixed on the trunk.
marking worksforme.

Please reopen if you see this still in Firefox3 Beta5 or later builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.