If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

download stats periodically forgotten for extension

VERIFIED DUPLICATE of bug 473716

Status

addons.mozilla.org Graveyard
Statistics
VERIFIED DUPLICATE of bug 473716
10 years ago
2 years ago

People

(Reporter: Dave Garrett, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080208 Mandriva/2.0.0.13-1.1mdv2008.0 (2008.0) Firefox/2.0.0.13
Build Identifier: 

Not sure when this started, but it worked fine the other day.  Flagfox is currently set to have its stats public, however as of this moment they're missing.  (also missing when logged in)  I get the error message "We don't have any data for your add-on yet. Please check back in a few days."  Total downloads shows as zero, yet downloads in the last 7 days and active daily users still show correctly, and the developer control panel still shows a number for the total.  All other stats functions are unaccessible.  The usage of "yet" implies it thinks this is a new add-on, so I'm posting this report here for someone to look at.  (marked as critical, as per the definition including potential data loss)

I've checked a handful of other extensions with their stats set public, and I haven't found any other broken ones.  If this is resolved at some point I'll close the report myself, however I'd like this to be looked into nonetheless as it could happen again to someone else.

Reproducible: Always
I can't reproduce this - everything looks fine for me on that page.
Severity: critical → normal
(Reporter)

Comment 2

10 years ago
Ditto.  Looks like I just had to wait a little longer as it's working now.  Must've only been down for a matter of hours or so.

Regardless, something exploded somewhere for a while there and it should be looked into.

Closing.  Please re-open if this happens again with someone else.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Updated

10 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Summary: download stats forgotten for extension → download stats periodically forgotten for extension
(Reporter)

Comment 3

10 years ago
Created attachment 320709 [details]
screenshot

Happened again.  Attaching screenshot this time.

Can someone else check this to confirm?  It must come and go.
(Reporter)

Comment 4

10 years ago
Well, it's working again.  Seeing as it happened multiple times, something isn't right somewhere, though I have no clue how one would attempt to reproduce.

I'll leave this open for the time being.  Hopefully someone can look into this at some point.
(Reporter)

Comment 5

9 years ago
(never confirmed this; might as well do so now)

Flagfox currently shows "545,365 Active Daily Users On Wednesday, Aug. 20" and "8 Total Downloads Since Oct. 2, 2007". Has a graph this time, though.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 10 years ago9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

9 years ago
Forward duping. Should hopefully be fixed now.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 473716
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.