Folder name in Bookmark All Tabs dialog behaves incorrectly

VERIFIED FIXED in Firefox 3

Status

()

--
major
VERIFIED FIXED
11 years ago
9 years ago

People

(Reporter: Ehsan, Assigned: mak)

Tracking

({regression})

Trunk
Firefox 3
regression
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

11 years ago
STR:

1. Open a window and load some pages in a few tabs.
2. From the Bookmarks menu, choose Bookmark All Tabs....
3. Select the drop-down button next to the "Create in" field.  A new item with no text is added to the "Create in" combo-box.
4. Select a root item in the list box below the "Create in" combo-box.  Another new item with no text is added to the "Create in" combo-box.  For each root item, this can be reproduced.  Children of these folders behave correctly.
5. Select the drop-down button once again so that the list becomes hidden.  The empty items persist.
6. Make sure one of the empty items are selected in the "Create in" field, and click Add Bookmarks.  The bookmarks are added, but it's not apparent which folder they are created in.  In my testing, I didn't edit the folder name and used the default value ("[Folder Name]").  Clicking the Star button on one of the pages shows the bookmark is created in that folder, but it's not accessible from the Library (or anywhere else in the UI where Bookmark folders are shown).
7. Invoke the Bookmark All Tabs dialog again.  The folders with empty titles have been added to the "Create in" combo-box this time.

Apparently, this can cause a number of untitled folders be created and a new folder ([Folder Name]) be added as a child of one of those.  These folders can't be accessed from the Library and can't be even deleted.  The bookmarks created in those folders can't be found via the Search Bookmarks field in the Library, and don't seem to get used in AwesomeBar results as well.
Flags: blocking-firefox3?
(Reporter)

Comment 1

11 years ago
Here's my build info:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b5pre) Gecko/2008040209 Minefield/3.0pre

about:buildconfig

Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	15.00.21022.08 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
cl 	15.00.21022.08 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser 
Component: Bookmarks → Places
QA Contact: bookmarks → places
Duplicate of this bug: 426999
I'm not quite sure, since this is a hard thing to describe, but I think this is the same as bug 425536. And assuming it hasn't been broken forever, a regression range would be a huge help.
Flags: blocking-firefox3? → blocking-firefox3+
Assignee: nobody → mak77
(Assignee)

Comment 4

11 years ago
first seen on 26-01-2008. most likely a regression from bug 413107
(Assignee)

Updated

11 years ago
Duplicate of this bug: 425536
(Assignee)

Comment 6

11 years ago
(In reply to comment #3)
> I'm not quite sure, since this is a hard thing to describe, but I think this is
> the same as bug 425536. And assuming it hasn't been broken forever, a
> regression range would be a huge help.

confirmed, that's the same identical problem (and same dialog, so i've marked that as a dupe of this (since this is a blocker).

Status: NEW → ASSIGNED
(Assignee)

Comment 7

11 years ago
Created attachment 315965 [details] [diff] [review]
patch

mimic the same behaviour of editBookmarkOverlay so should be safe enough
Attachment #315965 - Flags: review?(mano)
(Assignee)

Updated

11 years ago
OS: Windows Vista → All
Hardware: PC → All
Whiteboard: [has patch][needs review mano]
(Assignee)

Comment 8

11 years ago
Created attachment 315966 [details] [diff] [review]
patch

fix a trailing space
Attachment #315965 - Attachment is obsolete: true
Attachment #315966 - Flags: review?(mano)
Attachment #315965 - Flags: review?(mano)
(Assignee)

Updated

11 years ago
Duplicate of this bug: 428722
(Assignee)

Updated

11 years ago
Blocks: 428833
Comment on attachment 315966 [details] [diff] [review]
patch

_staticFoldersListBuilt doesn't make sense in the context of this dialog, this method can only get called once.
Attachment #315966 - Flags: review?(mano) → review-
(Assignee)

Updated

11 years ago
Duplicate of this bug: 421222
(Assignee)

Comment 12

11 years ago
Created attachment 316185 [details] [diff] [review]
patch

ok, minimum change
Attachment #315966 - Attachment is obsolete: true
Attachment #316185 - Flags: review?(mano)
(Assignee)

Updated

11 years ago
Whiteboard: [has patch][needs review mano] → [has patch][has review]
Comment on attachment 316185 [details] [diff] [review]
patch

a1.9=beltzner
Attachment #316185 - Flags: approval1.9? → approval1.9+
(Assignee)

Updated

11 years ago
Keywords: checkin-needed
Whiteboard: [has patch][has review]
Whiteboard: [has patch][has reviews]
mozilla/browser/components/places/content/bookmarkProperties.js 	1.85 
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [has patch][has reviews]
Target Milestone: --- → Firefox 3
verified with: 
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008041804 Minefield/3.0pre
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.