Visual C++ Runtime Error messages on program launch (old msvcr conflicts w/ custom crt for jemalloc)

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: ecarpenter, Assigned: mcsmurf)

Tracking

({crash, stackwanted})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040101 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040101 SeaMonkey/2.0a1pre

On daily builds of Seamonkey since 4/1/08:
On launch, pop up error message appears:
"Microsoft Visual C++ Runtime Library
Runtime error
Program C:\Program Files\SeaMonkey\seamonkey
R6034
An application has made an attempt to load the C runtime library incorrectly. Please contact the applications' suppport team for more information."

Pop up occurs twice, each time just before ZoneAlarm requests permission for new build to access the internet. Application appears to crash to desktop each time (icon on lower task bar disappears) but then continues launching and appears to function normally.

Reproducible: Always

Steps to Reproduce:
1.Launch seamonkey
2.Watch new daily build get installed
3.Pop up occurs
4.Program requests permission from ZoneAlarm to access internet
5.Pop up occurs again
6.Program request permission from ZoneAlarm to access internet (it is normal for it to ask twice after a new build is installed.)
Actual Results:  
I had to click okay on the pop up windows, but the program eventually launches and functions normally.

Expected Results:  
No error messages

Comment 1

11 years ago
http://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg

when the dialog appears, open windbg, follow the steps in that url to set it up, then use debug>attach to process to attach to seamonkey. and follow the steps in the url to get a stack. please add the output as an attachment.
URL: N/A
Keywords: crash, stackwanted
(Reporter)

Comment 2

11 years ago
I'm sorry, I'm not a tech person. Where do I go to open windbg and use debug? (Note, there is no Seamonkey window open until I have closed both of the warning popups.) 
(Reporter)

Comment 3

11 years ago
Additional info: It has crashed to desktop twice in the 2 hours since I launched it this am. Each time I was typing a block of text into a form, but not clicking on any buttons or links. (Once was on this page.)
Confirming with Mozilla/5.0 (Windows; U; Windows NT 6.0; sk; rv:1.9pre) Gecko/2008040101 SeaMonkey/2.0a1pre
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

11 years ago
the url i gave has fairly detailed instructions, please read it.
(Reporter)

Comment 6

11 years ago
Thank you. The instructions are specific for Firefox and I didn't know which file paths to rename as "seamonkey" and which to keep as "firefox." By the time I got that far it was crashing almost continuously, so as no one else seems to be having this problem I downloaded and installed the nightly build fresh (previously it had been an auto-update) and it has been stable so far.
(Reporter)

Comment 7

11 years ago
It did an auto-update, and on first launch repeated the error messages, but on subsequent launches did not.

I'm still trying to figure out the debug program. I think I set the symbol file path correctly according to the instructions, but it isn't there the next time I relaunch WinDbg. Is that what is supposed to happen?

http://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg#Debugging
says I need to "open the firefox.exe executable that I downloaded before." I don't know what that refers to. I also don't know if there should be a seamonkey.exe executable instead.
Created attachment 313326 [details]
WinDbg output when error message appears

hopefully this can help you (I'm doing this for the first time)

Comment 9

11 years ago
.sympath SRV*c:\symbols*http://symbols.mozilla.org/seamonkey

be sure to check "also debug child processes" if you're using open.
(Assignee)

Comment 10

11 years ago
Created attachment 313638 [details] [diff] [review]
Possible fix

Same fix as Firefox needed when jemalloc was turned on (see Bug 415928). Probably there are still the old runtime files left.
Assignee: general → bugzilla
Status: NEW → ASSIGNED
(Assignee)

Comment 11

11 years ago
Comment on attachment 313638 [details] [diff] [review]
Possible fix

Easy review.
Attachment #313638 - Flags: review?(bugzilla)
Comment on attachment 313638 [details] [diff] [review]
Possible fix

yep, looks good, though I haven't tried it myself.
Attachment #313638 - Flags: review?(bugzilla) → review+
(Assignee)

Comment 13

11 years ago
Vlado and Eileen: Can you check tomorrow if the error is gone with the new nightly? I just checked in a possible fix for this.

Checking in suite/installer/removed-files.in;
/cvsroot/mozilla/suite/installer/removed-files.in,v  <--  removed-files.in
new revision: 1.19; previous revision: 1.18
done
(Reporter)

Comment 14

11 years ago
Actually, it only happened on the computer where I have ZoneAlarm installed, and I won't be at that one again for a few days. This one, that did not have an outgoing firewall, never showed the behavior. I just installed Comodo, and the problem still did not happen with today's update on this computer. 
Seems to be OK in Mozilla/5.0 (Windows; U; Windows NT 6.0; sk; rv:1.9pre) Gecko/2008040601 SeaMonkey/2.0a1pre. Let's mark it FIXED and if eileen confirms it VERIFIED. Otherwise reopen.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Summary: Visual C++ Runtime Error messages on program launch → Visual C++ Runtime Error messages on program launch (old msvcr conflicts w/ custom crt for jemalloc)
You need to log in before you can comment on or make changes to this bug.