Closed Bug 426548 Opened 15 years ago Closed 15 years ago

two sets of back and forward buttons in navigation bar

Categories

(Firefox :: Toolbars and Customization, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 425079

People

(Reporter: xxaz0r, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

I just updated from FF3 beta 3 to beta 5 and I now have two sets of back and forward buttons in my navigation bar. I have restarted the browser several times and even completely removed it and reinstalled, but the second set is still there. I also removed the two extentions I had, even though both were already disabled, to no avail. I tried renaming my profile but then when I tried to start Firefox it popped up a message box that said "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system." Of course, I checked my processes and it wasn't already running and renaming my profile back to its original name allowed Firefox to start again. So, I really don't know if it's just something with the profile that is causing the problem or not, but nothing I do seems to fix it. The second set of buttons are just stuck there, but the arrow that shows the history on the second one doesn't do anything whereas the first one does. I'll attach a screenshot.

Reproducible: Always

Steps to Reproduce:
1. Install Firefox 3 beta 5
2. Run it
Actual Results:  
I had two sets of back and forward buttons with the first one fully functional and the second one mostly functional.

Expected Results:  
Had one set of navigation buttons.

I'm just using the default theme, nothing special.
Ah, I should've read the what's new page all the way first. I scrapped my old profile and created a new one and that fixed it. I don't know what it was with my old profile that was causing the problem, but it works now. So, ignore this whole bug and if anyone else has this problem, just run firefox with the -P option to run the profile manager and create a new profile.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
I am seeing this as well and I would really hate to recreate my profile. Is it acceptable to expect users to create a new profile when they install 3.0?
(In reply to comment #3)
> I am seeing this as well and I would really hate to recreate my profile. Is it
> acceptable to expect users to create a new profile when they install 3.0?
>

I found the problem, it's localstore.rdf. So, your options are to either create a new profile, copy localstore.rdf from that profile into your new profile and overwrite your old one and then delete the new profile, or, I'll upload a copy of a new localstore.rdf and you can just download it and replace your current one with the new one.
Replace your localstore.rdf in your profile with this one to fix the problem.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 425079
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.