Status

()

Core
Layout
RESOLVED DUPLICATE of bug 713784
10 years ago
6 years ago

People

(Reporter: David E. Ross, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9

To track bug reports in which I'm interested, I have a saved query for the Mozilla Bugzilla database that currently reports a summary of 166 bug reports.  I run that query twice each week, selecting most bug reports that show changes since the last time I ran the query.  I select each report to appear in a different tab, with several tabs loading at the same time.  I am using a dial-up connection, which means the longer bug reports take a significant amount of time to load.  

Too often, I get a popup that indicates the page has no data; loading of that page is then terminated.  When I look at the tab, part of the page already is displayed, proving that indeed data exist for the page.  


Reproducible: Sometimes




Today, almost every bug report I selected (about 8-9) had this problem.  

I get the same problem with other pages unrelated to mozilla.org.  Thus, this appears to be a browser problem and not a Bugzilla problem.  

It seems that there is some kind of timeout that terminates the rendering of a page even after the page has actually begun to render.  If this is true, the popup is in error, reporting the wrong situation.  

When the problem occurs and I see a partial page already loaded, selecting the Reload button does nothing.  There is no action whatsoever from selecting that button even if I clear all caches.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 421566
(Reporter)

Comment 2

10 years ago
After reading bug 421566 and its comments, I do not see how this is a duplicate.  This bug involves the error popup with the message "The document contains no data."  Bug 421566 involves a network reset or connection interruption; I get no message to that effect.  Reopening.  

I just ran two tests similar to what I had been doing this afternoon, which prompted my submitting this bug report.  

Based on what I read in bug 421566, I set network.http.pipelining=False (the SeaMonkey 1.1.9 default).  I then requested 12 bug reports, each in a separate tab, all loading and rendering simultaneously.  The problem did not appear.  

Then, I set network.http.pipelining=True, which was the setting this morning when I had multiple "The document contains no data." popups.  I then requested 11 bug reports, each in a separate tab, all loading and rendering simultaneously.  I had one occurrence of the problem.  Only a partial report was displayed for bug 915, truncated within that bug's comment number 27.  

I have been seeing this problem sporadically for a long time at various Web sites, including non-Mozilla servers.  This morning, however, was the most frequent, so frequent as to prompt this bug report.  The problem seems to be related to attempts to open several large Web pages concurrently, each on its own tab.  
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

10 years ago
This happened again, about 5 minutes ago.  Again, it happened while trying to display several Bugzilla reports, all at the same time, each on a separate tab.  In this case, about 4 bug reports were in process.  This happened with bug 335197, the loading of which died in the middle of comment number 42.  
(Reporter)

Comment 4

10 years ago
Today, I ran a stored query of mine that listed 56 bugs.  I selected nine of them for reports, each in a separate tab.  In another tab, I initiated an update to another query stored in my profile, which causes a query form to load.  While the pages were being fetched and loaded, I got a "Document contains no data" error popup on one of the bug reports (again Bug #335197) in the middle of its 41st comment.

Comment 5

9 years ago
so this only happen when multiple links are opened at once?
& why is this in layout?
(Reporter)

Comment 6

9 years ago
I've also seen this with "normal" (not tabbed) browsing, with Web pages that do load but from slow servers.  However, using tabbed browsing to load a number of large bug reports seems to be a way to trigger this problem, especially with how slow the bugzilla.mozilla.org server delivers pages.  

I submitted this bug report for Core/Layout because I didn't know what other Product/Component might be more appropriate.  Feel free to change the Product/Component.
(Reporter)

Comment 7

9 years ago
I saw this again this morning.  I was opening a large number of bug reports simultaneously, each in a separate tab.  The reports were selected from a list generated by a Bugzilla query.  This time, the report for Bug #436056 failed in its 8th comment.  

This appears to be a timing problem.  Reloading the failed page succeeds when no other Web pages are being loaded.
(Reporter)

Comment 8

9 years ago
From a query executed today that resulted in "176 bugs found", I selected 11 for display, loading simultaneously each in its own tab.  The display of bug 915 died with the error popup after its 121st comment.
(Reporter)

Comment 9

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0

This is still a problem.  I observed it this morning while requesting about six bug reports from a query list.  SeaMonkey/Gecko recognized that the affected report did indeed have data since approximately half the page had already rendered before the "No Data" popup appeared.
(Reporter)

Comment 10

8 years ago
Today, I got this error many times, even when trying to get only three bugzilla.mozilla.org bug reports from a query list.  It appears that either the bugzilla.mozilla.org server has a problem, or else Core-Layout is timing out without presenting a Timeout error popup.  I suspect the latter since I occasionally (but rarely) see this at other Web sites.
(Reporter)

Comment 11

8 years ago
I have not seen this problem since I recently upgraded to a broadband Internet connection (10 days ago).  This does NOT mean the problem is resolved.  What it means is that there is a timing problem somewhere in the Core.  When HTTP packets are slow to arrive, a timeout causes the "No Data" popup to display and Core to stop rendering the page.
(Reporter)

Comment 12

7 years ago
I am seeing this problem again.  I suspect it might involve Web pages that contain content or images from third-party servers that might be slow.  I will try to capture more data.
(Reporter)

Comment 13

7 years ago
No, I have found that third-party servers are not involved.  

It may be that this is a problem with either my ISP (Road Runner) or the cable modem they provided to me.  I do not see this problem with a dial-up connection through a different ISP (ISWest).  

The one Web site where this problem is almost consistent tells me that I am the only one reporting this problem.  Since I don't see this problem through a dial-up connection, that assertion is likely correct.  

Still investigating.
(Reporter)

Comment 14

7 years ago
Mozilla/5.0 (Windows NT 5.1; rv:6.0) Gecko/20110820 SeaMonkey/2.3.1

Now that I have a broadband connection, I no longer see this problem at bugzilla.mozilla.org.  As I already noted (comment #13), however, I have found another Web site where this problem can be created quite frequently (but not necessarily always).  I see this problem on and off with a number of pages at that site, even while in Safe Mode.  

While I reported that the problem does not appear when using a dial-up connection, I do indeed see it on occasion through that connection.  The problem does not exist with IE 7.  

I can supply a TraceRoute to the domain.  I have LiveHTTPHeaders installed and can supply a complete set of headers, both outgoing and incoming.  I can also provide an image of my Error Console.  Just let me know what is wanted.  

Note:  In comment #13, I stated "The one Web site where this problem is almost consistent tells me that I am the only one reporting this problem."  Of course, I was told this by the site's administrator, not by the site itself.  He made that assertion when I could not create the problem with IE 7.

Comment 15

7 years ago
David, have you looked at 
Bug 586988 - Too many HTTPS connections slows down greatly opening sites
Bug 513564 - Firefox 3.5.1 is very slow with low-bandwidth/dialup connection compared with older versions such as Firefox 2 (TESTED)
(Reporter)

Comment 16

7 years ago
Neither of those two -- 513564 or 586988 --  are applicable here.  

Bug #513564 is about problems with a dial-up connection, but I see this problem more often with a broadband connection greater than 1 Mbps.  Per my comment #13, I thought the problem did not exist at all with dial-up; but now I see it occasionally with dial-up.  

While bug #586988 is very similar to what I originally reported here (attempting to open many tabs at one time), I am now seeing this problem while attempting to open only a single Web page.

Comment 17

7 years ago
(In reply to David E. Ross from comment #16)
> Neither of those two -- 513564 or 586988 --  are applicable here.  
> 
> Bug #513564 is about problems with a dial-up connection, but I see this
> 
> While bug #586988 is very similar to what I originally reported here

David, I really do not believe that the Firefox issues mentioned here or in the two bug reports above are dialup issues.  Dialup simply shows the problem, what ever it is, sooner and more consistently.
In Firefox version 3.6.8, when I click on few links to be opened on multiple tabs, almost always one or more will come back with server not found AFTER displaying the server name on the URL line (some connection is made).
To test this, take four sites with simple few kilobytes of data page and do the above.  All will appear on different tabs within a few seconds.  Then repeat it for heavily graphically loaded sites, and you will see the Server Not Responding message.
I will venture a guess that something is timing out in Firefox.  And the problem may show itself after the ratio of web page data (M bytes) to the Bandwidth of internet connection (kilo bits/sec) is larger than this timeout number.
(Reporter)

Comment 18

7 years ago
Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20110902 SeaMonkey/2.3.3

Let me clarify what I now see relative to this bug.  Prior to obtaining broadband Internet service, the most frequent problem occurred while launching several tabs during a review of bug reports with each tab being launched by selecting a report from the result of a bugzilla.mozilla.org query.  Now that I have broadband, that particular instance of this bug no longer appears.  

Now, when I go to a Web page at a certain domain, I have this problem even if I am NOT launching tabs.  I have tried this with both broadband and dial-up.  It is more common with broadband.  A page will only partially load, sometimes cutting off in the middle of a line.  About half the time, I get the "No Data" popup; the rest of the time, I see "Done" in the status bar.  Repeated Reload requests generally cut off at the exact same point, but sometimes the cutoff is higher or lower on the page.  

Many (most?) of the pages are plain ASCII (Content-Type: text/plain; charset=ISO-8859-1), but some are HTML.  The Web site uses compression on its pages (Transfer-Encoding: chunked, Content-Encoding: gzip).  I think this is true for all pages, even the shorter pages.  The problem afflicts both.  I see this problem even when browsing in Safe Mode.

Comment 19

7 years ago
(In reply to David E. Ross from comment #18)
> Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20110902 SeaMonkey/2.3.3

A)
> Now that I have broadband, that particular instance of this bug no
> longer appears.  

B)
> but sometimes the cutoff is higher or lower on the page.  
 
David, I confirm having seen both of your reported problems.  The important item is that these two are different issues.  The one I referred to as being "content-bandwidth" related is the one that you have mentioned in A).

Now item B), whether it is connected to this bug or if it is from another place in the code is that the painting of the screen is not complete.  I have seen it as if HTML rendering is not taking place and most items seem like displayed in a NOTEPAD editor.  Although I have seen links and other properties but much of the screen rendering is left out.  Few times a week I get this on dialup.

Question: If this is not already reported, should it not be separated from this bug report which has "NO DATA" in its title?  To best of my knowledge, in item B) of your report Firefox does see all the data and does not say "no data" or as I commented does not display "server not found" message.
(Reporter)

Comment 20

7 years ago
I get the problem for both HTML (Content-Type: text/html; charset=ISO-8859-1) and text pages.  When it happens with HTML pages, the partial page renders appropriately and not as if in an ASCII editor (e.g., Notepad).  I see the intended background and foreground images, and the page renders according to styles from external CSS files.  It just that the bottom of the page is missing with a break usually in the middle of a line.  

I never see an error popup about a timeout or server not being found, only the popup about no data (and not even that about half the time).  I don't use Firefox.  I see this in SeaMonkey, but I also get this problem while spoofing Firefox with the UA string
   Mozilla/5.0 (Windows NT 6.1; rv:6.0) Gecko/20100101 Firefox/6.0 (not really)
I do not have this problem with IE7, and the Web master tells me that he has not received any other reports of this problem.  

If the entire page (all Internet packets) were downloaded but not displayed, would the entire page be in the cache?  I just now saw the problem.  I then made SeaMonkey go offline by selecting the icon near the lower-right corner.  I then attempted to view the page.  I got exactly the same rendering as when I was online, including images and CSS.  This tells me that I did not receive all packets sent by the Web server.  

On getting this error, I viewed the source, which does have content beyond what was rendered.  However, the source also cuts off in the middle of a line (in the middle of the URI in an HTML anchor).

Comment 21

6 years ago
(In reply to David E. Ross from comment #20)
Using Firefox version 7.0.1

Every time and only the first time that Firefox starts after booting the system, with my home page being http://www.bbc.co.uk/ , only the text shows up, as David has mentioned, with full HTML details and as far as I can tell a complete page.  But no pictures or graphics.  All the links are functional.

Subsequent re-loadings without closing the Firefox will display the graphics and pictures, including symbols for running flash, etc. 

Actually, if this is a feature I like it because over the dialup it appears fast and I can read the news quickly without the graphics.  :)  However, it may not be so intended and last version of Firefox that I used (3.1.2) does not behave this way.

Comment 22

6 years ago
Firefox version 7.0.1

This may give a clue to what is happening; On http://www.bbc.co.uk/ when I see the text only HTML, the page ends with this message:

-----------------------------------------

BBC links

    About the BBC
    BBC Help
    Contact Us
    Accessibility Help
    Terms of Use
    Careers
    Privacy & Cookies
    Advertise With Us
    Ad Choices

BBC

BBC © 2011 The BBC is not responsible for the content of external sites. Read more.

This page is best viewed in an up-to-date web browser with style sheets (CSS) enabled. While you will be able to view the content of this page in your current browser, you will not be able to get the full visual experience. Please consider upgrading your browser software or enabling style sheets (CSS) if you are able to do so.

------------------------------------

Does above message mean that CSS is disabled and then on reload it enables itself?


These are the last lines after reload:
=========================================
    BBC Help
    Contact Us
    Accessibility Help
    Terms of Use
    Careers
    Privacy & Cookies
    Advertise With Us
    Ad Choices

BBC

BBC © 2011 The BBC is not responsible for the content of external sites. Read more.


=========================================

Comment 23

6 years ago
(In reply to Parkhideh from comment #22)

Could someone tell me how to disable CSS in Firefox 7 ? I want to confirm that the behavior seen is the same as a browser with disabled CSS.
(Reporter)

Updated

6 years ago
Blocks: 713784
(Reporter)

Comment 24

6 years ago
As the originator of this bug report, I have submitted new bug #713784, which more clearly describes the problem.
No longer blocks: 713784
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 713784

Comment 25

6 years ago
David, I like your 713784 bug description;  shouldn't you do the same for "server not found" of multi-tab opening?  I am still on dial-up  :) 
The difference being is that in 713784 the page is not "fully" rendered; while in multi-tab the page remains blank and the message "Server not found" appears.
(Reporter)

Comment 26

6 years ago
I have never seen the server not found unless (1) I forgot to enable an Internet connection or (2) I entered a truly invalid domain.  Both of those would be my errors, not errors in my browser.  Generally, I do not submit bug reports unless I personally observe the problem.
You need to log in before you can comment on or make changes to this bug.