ask IE6 to load a site and get the site in Firefox

RESOLVED INVALID

Status

()

Firefox
Shell Integration
--
major
RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: Jim Barty, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13

context: Firefox is my default browser but as a web developer I need to test sites in IE6.  Firefox seems to have mucked up IE6 so that if I just enter a URL, I get the URL displayed in Firefox.  If I search for a local file with IE6, find it and ask IE to load it, I get the file in Firefox.  At present, the only way of testing a page in IE6 is to load it to the web and make a link to it from another site.  The reason I am reporting it here is that this has happened since the last upgrade of Firefox.  IE6 has been static on my setup for a long time.

Reproducible: Always

Steps to Reproduce:
1. Load IE6, enter a valid URL, I will get that URL in Firefox
2. Search for a local file with IE6, ask IE6 to load it and get the file in Firefox
3.
Actual Results:  
URL or local file displayed in Firefox.  This matter because my reason for loading IE6 is to test sites in IE6 which is very necessary for pure CSS sites.

Expected Results:  
To see the URL or local site in IE6.

XP/SP2
This is the first report about such a problem.
Firefox does nothing that could break IE, it may only change the system default browser.
Did you try to set IE6 back as default browser ?
If you don't wanna have that Firefox opens local HTML files you have to change the entries in the file associations so that IE will be opened. I can't see why this is a bug. Feel free to reopen if it cannot be fixed that way and you have more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Version: unspecified → 2.0 Branch
Component: Toolbars → Shell Integration
QA Contact: toolbars → shell.integration
Also, IE 6 should add an open with entry in the explorer context menu for local html files
You need to log in before you can comment on or make changes to this bug.