Import Wizard should show an hourglass while it is working

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: Jason Spiro, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-09-15])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040204 Minefield/3.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040204 Minefield/3.0pre

While the Import Wizard is busy working, the mouse pointer is the ordinary arrow cursor.  (The second-last screenshot at http://www.mouserunner.net/FF_Import_Wizard demonstrates that fact.)  It should be an hourglass (wait cursor) instead: that makes it instantly clear to me I must be patient and wait.

Reproducible: Always
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008040300 Minefield/3.0pre

I do see an hour glass and the word "Importing.." on the dialog. It is taking extraordinary long BTW (several minutes).
(Reporter)

Comment 2

10 years ago
I had seen the word Importing... but no hourglass.

I wonder why you saw an hourglass but I didn't?
Maybe my system displayed the hourglass because CPU and/or memory were too busy to do something else?
(Reporter)

Comment 4

10 years ago
(In reply to comment #3)
> Maybe my system displayed the hourglass because CPU and/or memory were too busy
> to do something else?

Sounds plausible.

Does anyone have access to a different computer on which they could try the import?  I have tried it on 2 computers at my school, and on both those computers, there is no hourglass.
I assume you want some progress indicator more clear than "Importing..."? I see here bug 329736 but that is meant for automatic import, not for manual import.
Reporter, are you still seeing this issue with Firefox 3.6.8 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2010-09-15]
No reply, INCOMPLETE. Please retest with Firefox 3.6.11 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.